This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 809837 - SELinux is preventing ls from 'getattr' accesses on the blk_file /dev/sdb.
SELinux is preventing ls from 'getattr' accesses on the blk_file /dev/sdb.
Status: CLOSED DUPLICATE of bug 809832
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0ee41db145af7433c53e1fed4c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 09:40 EDT by Karel Volný
Modified: 2012-04-04 19:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 19:47:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-04-04 09:40:12 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.i686
reason:         SELinux is preventing ls from 'getattr' accesses on the blk_file /dev/sdb.
time:           Wed 04 Apr 2012 09:39:40 AM EDT

description:
:SELinux is preventing ls from 'getattr' accesses on the blk_file /dev/sdb.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ls should be allowed getattr access on the sdb blk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ls /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tuned_t:s0
:Target Context                system_u:object_r:fixed_disk_device_t:s0
:Target Objects                /dev/sdb [ blk_file ]
:Source                        ls
:Source Path                   ls
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.i686 #1
:                              SMP Mon Mar 19 03:19:22 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Wed 04 Apr 2012 09:37:35 AM EDT
:Last Seen                     Wed 04 Apr 2012 09:37:35 AM EDT
:Local ID                      d7190751-be00-4525-8c60-6c8fff941af1
:
:Raw Audit Messages
:type=AVC msg=audit(1333546655.577:321): avc:  denied  { getattr } for  pid=2213 comm="ls" path="/dev/sdb" dev="devtmpfs" ino=677 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:fixed_disk_device_t:s0 tclass=blk_file
:
:
:Hash: ls,tuned_t,fixed_disk_device_t,blk_file,getattr
:
:audit2allow
:
:#============= tuned_t ==============
:allow tuned_t fixed_disk_device_t:blk_file getattr;
:
:audit2allow -R
:
:#============= tuned_t ==============
:allow tuned_t fixed_disk_device_t:blk_file getattr;
:
Comment 1 Karel Volný 2012-04-04 10:02:15 EDT
CCing tuned maintainer, and jscotka & jskarvad as this is from PM testday

note, this may be connected to bug #809836
Comment 2 Michal Ambroz 2012-04-04 19:47:12 EDT
Should be probably solved together with other events triggered by 
"tuned-adm profile something".

Marking as duplicate of 809832.

*** This bug has been marked as a duplicate of bug 809832 ***

Note You need to log in before you can comment on or make changes to this bug.