Bug 809919 - Mark fd as bad if open(dir) fails during fd-migration after graph switch
Mark fd as bad if open(dir) fails during fd-migration after graph switch
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
:
: 810079 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 12:34 EDT by Raghavendra G
Modified: 2012-04-19 23:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 23:37:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2012-04-04 12:34:17 EDT
Description of problem:
During migration of fd after graph switch, if open(dir) fails, the fd is not marked as bad. Instead, future calls just pass through the new graph. With fdctx for protocol/client being NULL, the fd is treated as anonymous fd and the call fails/succeeds based on that treatment. However this behavior is not desired.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Raghavendra G 2012-04-04 12:36:55 EDT
Thanks to Junaid for pointing this bug out.
Comment 2 Anand Avati 2012-04-04 19:27:52 EDT
CHANGE: http://review.gluster.com/3085 (fuse-bridge/fd-migration: document migration failures in fdctx.) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Junaid 2012-04-05 01:49:41 EDT
*** Bug 810079 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.