Bug 810426 - [abrt] gnome-shell-3.2.2.1-1.fc16: g_malloc0: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)
[abrt] gnome-shell-3.2.2.1-1.fc16: g_malloc0: Process /usr/bin/gnome-shell wa...
Status: CLOSED DUPLICATE of bug 702257
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:7a922ce594bfc800f733490a0c0...
:
: 810479 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 00:00 EDT by Tim Zorn
Modified: 2012-04-16 19:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 702257
Environment:
Last Closed: 2012-04-06 10:08:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (20.42 KB, text/plain)
2012-04-06 00:00 EDT, Tim Zorn
no flags Details
File: build_ids (6.41 KB, text/plain)
2012-04-06 00:01 EDT, Tim Zorn
no flags Details
File: maps (79.63 KB, text/plain)
2012-04-06 00:01 EDT, Tim Zorn
no flags Details
File: var_log_messages (14.40 KB, text/plain)
2012-04-06 00:01 EDT, Tim Zorn
no flags Details
File: backtrace (38.50 KB, text/plain)
2012-04-06 00:01 EDT, Tim Zorn
no flags Details

  None (edit)
Description Tim Zorn 2012-04-06 00:00:52 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
comment:        new backtrace with 'export G_SLICE=always-malloc' in ~/.bashrc
crash_function: g_malloc0
executable:     /usr/bin/gnome-shell
kernel:         3.3.0-8.fc16.x86_64
pid:            3171
pwd:            /home/tim
reason:         Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)
time:           Thu 05 Apr 2012 11:59:10 PM EDT
uid:            1000
username:       tim

backtrace:      Text file, 39425 bytes
build_ids:      Text file, 6562 bytes
dso_list:       Text file, 20910 bytes
maps:           Text file, 81537 bytes
var_log_messages: Text file, 14749 bytes

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=4
:HOSTNAME=Tim
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=b18fa2979c04e18f799af6d00000000c-1333681005.734152-1745936811
:GNOME_KEYRING_CONTROL=/tmp/keyring-c0CuHS
:IMSETTINGS_MODULE=none
:USER=tim
:LIBGL_DRIVERS_PATH=/usr/lib/dri:/usr/lib64/dri
:G_SLICE=always-malloc
:USERNAME=tim
:MAIL=/var/spool/mail/tim
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/tim/.local/bin:/home/tim/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/tim
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=2969
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/tim
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=tim
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bJCHKIEQhC,guid=8df2baf735208cef2ca77edd000001cf
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/tim
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-tim-QIxlfb/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2973,unix/unix:/tmp/.ICE-unix/2973
:GPG_AGENT_INFO=/tmp/keyring-c0CuHS/gpg:0:1
:SSH_AUTH_SOCK=/tmp/keyring-c0CuHS/ssh
:DESKTOP_AUTOSTART_ID=10f0be15d89d3617f1133368100621957900000029730000

event_log:
:2012-04-06-00:00:14> Analyzing coredump 'coredump'
:2012-04-06-00:00:17  Coredump references 161 debuginfo files, 1 of them are not installed
:2012-04-06-00:00:17  Setting up yum repositories
:2012-04-06-00:00:17  Looking for needed packages in repositories
:2012-04-06-00:00:17  Can't find packages for 1 debuginfo files
:2012-04-06-00:00:17  Missing debuginfo file: /usr/lib/debug/.build-id/-/.debug
:2012-04-06-00:00:17  Generating backtrace
:2012-04-06-00:00:25  Backtrace is generated and saved, 39425 bytes
:2012-04-06-00:00:32> Element 'xsession_errors' saved
:2012-04-06-00:00:32> GConf directory /apps/gnome-shell does not exist
:2012-04-06-00:00:32* (exited with 1)
:2012-04-06-00:00:34> Smolt profile successfully saved

smolt_data:
:
:
:General
:=================================
:UUID: 09e4a591-1c12-466c-9c5e-832436771f7d
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5986.70
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) II X2 250 Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 6
:Number of CPUs: 2
:CPU Speed: 3000
:System Memory: 3951
:System Swap: 1998
:Vendor: To Be Filled By O.E.M.
:System: To Be Filled By O.E.M. To Be Filled By O.E.M.
:Form factor: Desktop
:Kernel: 3.3.0-8.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17296:6217:17296) pci, ahci, STORAGE, Motherboard (one of many)
:(4098:43656:5963:43656) pci, snd_hda_intel, MULTIMEDIA, Barts HDMI Audio [Radeon HD 6800 Series]
:(4098:23060:6217:23060) pci, None, HOST/PCI, RD890 PCI to PCI bridge (external gfx0 port B)
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4098:23062:6217:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port B)
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4098:17302:6217:17302) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:6217:17303) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:43624:6023:43624) pci, snd_hda_intel, MULTIMEDIA, Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
:(7023:28707:6217:28707) pci, xhci_hcd, USB, N/A
:(4098:17312:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 0)
:(4098:17315:4098:0) pci, pcieport, PCI/PCI, N/A
:(4098:17308:6217:17308) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17285:6217:17285) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17309:6217:17309) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:6217:30866) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:6217:17305) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4332:33128:6217:33128) pci, r8169, ETHERNET, Motherboard (one of many)
:(4098:17302:6217:17302) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:26425:5963:57716) pci, fglrx_pci, VIDEO, Barts PRO [ATI Radeon HD 6800 Series]
:(4098:17303:6217:17303) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:6217:17302) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:6217:17303) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:26849:6023:12288) pci, fglrx_pci, VIDEO, Manhattan [Mobility Radeon HD 5430 Series]
:(4098:23068:6217:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port H)
:(4098:23064:6217:23060) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port D)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 44702012 41807150 39569211 11190272 10986212 10986212
:/dev/sdb2 WITHHELD vfat 2048 2048 2088983 186637 186637 0 0 0
:/dev/sdb1 WITHHELD fuseblk UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN UNKNOWN
:

xsession_errors:
:(gnome-shell:3171): folks-DEBUG: individual-aggregator.vala:310: Setting primary store IDs to defaults.
:(gnome-shell:3171): folks-DEBUG: individual-aggregator.vala:338: Primary store IDs are 'eds' and 'system'.
:(gnome-shell:3171): folks-WARNING **: Failed to find primary PersonaStore with type ID 'eds' and ID 'system'.
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:(gnome-shell:3171): Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
:*** glibc detected *** /usr/bin/gnome-shell: malloc(): smallbin double linked list corrupted: 0x000000000573b6e0 ***
:/usr/bin/gnome-shell(main+0x4f1)[0x4029e1]
:/usr/bin/gnome-shell[0x402b09]
:00400000-00405000 r-xp 00000000 08:03 2496775                            /usr/bin/gnome-shell
:00604000-00605000 r--p 00004000 08:03 2496775                            /usr/bin/gnome-shell
:00605000-0060d000 rw-p 00005000 08:03 2496775                            /usr/bin/gnome-shell
:3216400000-321649c000 r-xp 00000000 08:03 3156089                        /usr/lib64/gnome-shell/libgnome-shell.so
:321649c000-321669b000 ---p 0009c000 08:03 3156089                        /usr/lib64/gnome-shell/libgnome-shell.so
:321669b000-321669d000 r--p 0009b000 08:03 3156089                        /usr/lib64/gnome-shell/libgnome-shell.so
:321669d000-32166a1000 rw-p 0009d000 08:03 3156089                        /usr/lib64/gnome-shell/libgnome-shell.so
:7f2c005d4000-7f2c005d7000 r--p 00000000 08:03 3156925                    /usr/lib64/gnome-shell/Gvc-1.0.typelib
:7f2c04695000-7f2c0469f000 r--p 00000000 08:03 3156927                    /usr/lib64/gnome-shell/St-1.0.typelib
:7f2c07915000-7f2c0791e000 r--p 00000000 08:03 3156926                    /usr/lib64/gnome-shell/Shell-0.1.typelib
:gnome-shell-calendar-server[3279]: Got HUP on stdin - exiting
:gnome-session[2973]: WARNING: Application 'gnome-shell.desktop' killed by signal
:(gnome-shell:4075): folks-DEBUG: individual-aggregator.vala:310: Setting primary store IDs to defaults.
:(gnome-shell:4075): folks-DEBUG: individual-aggregator.vala:338: Primary store IDs are 'eds' and 'system'.
:(gnome-shell:4075): folks-WARNING **: Failed to find primary PersonaStore with type ID 'eds' and ID 'system'.
Comment 1 Tim Zorn 2012-04-06 00:00:58 EDT
Created attachment 575602 [details]
File: dso_list
Comment 2 Tim Zorn 2012-04-06 00:01:02 EDT
Created attachment 575603 [details]
File: build_ids
Comment 3 Tim Zorn 2012-04-06 00:01:04 EDT
Created attachment 575604 [details]
File: maps
Comment 4 Tim Zorn 2012-04-06 00:01:06 EDT
Created attachment 575605 [details]
File: var_log_messages
Comment 5 Tim Zorn 2012-04-06 00:01:09 EDT
Created attachment 575606 [details]
File: backtrace
Comment 6 Owen Taylor 2012-04-06 09:54:19 EDT
Unfortunately, this backtrace isn't more useful- it just shows a crash from memory corruption at some previous time. If you *are not* using FGLRX and have some reliable way of reproducing a crash with Fedora 16, I'm interested in that, however.
Comment 7 Owen Taylor 2012-04-06 09:59:46 EDT
*** Bug 810479 has been marked as a duplicate of this bug. ***
Comment 8 Owen Taylor 2012-04-06 10:01:17 EDT
You may have said this elsewhere, but are you using any GNOME Shell extensions?
(From the command line '$ gsettings get org.gnome.shell enabled-extensions')
Comment 9 Owen Taylor 2012-04-06 10:08:05 EDT
Oh, I see fglrx from your comments on the other bug. (Note that bug 702257 combines a well known, though not debugged, fglrx crash with other crashes that aren't from fglrx but end up with similar backtraces so ABRT combines them - confusing.)

A good valgrind log could have a smoking gun, but valgrinding GNOME Shell is quite tricky - the problem is that valgrind doesn't get everything right - so any real errors are lost in a sea of false positives - so  you either have to have a well tuned "suppressions file" or dump out everything and be skilled at extracting the real errors from the false positives.

*** This bug has been marked as a duplicate of bug 702257 ***
Comment 10 Tim Zorn 2012-04-16 19:39:49 EDT
Owen Taylor, how soon after running in valgrind should it crash to be useful. I've got it down to be able to reproduce soft of reliably.

Note You need to log in before you can comment on or make changes to this bug.