Bug 810699 - [abrt] kernel: [111749.012292] WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfb/0x100()
[abrt] kernel: [111749.012292] WARNING: at fs/sysfs/group.c:138 sysfs_remove_...
Status: CLOSED DUPLICATE of bug 797559
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:d802a0ab48aca8e22d2b4f18c8c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 08:41 EDT by DeepPurpleFedora
Modified: 2012-04-12 20:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 20:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DeepPurpleFedora 2012-04-08 08:41:36 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-8.fc16.x86_64 root=UUID=29b60b82-ce11-44e4-be3a-e5b9353eac86 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rd.luks=0 LANG=en_US.UTF-8
comment:        As far as I can tell I have been running this kernel the first time after its initail instillation.  I got the report after around a day or two of no restarting and a few suspends, but the most recent return from suspend for some reason is when I got the kernel crash message.
event_log:      2012-04-08-08:37:24> Smolt profile successfully saved
kernel:         3.3.0-8.fc16.x86_64
reason:         [111749.012292] WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfb/0x100()
time:           Wed 04 Apr 2012 06:40:13 PM EDT

backtrace:
:[111749.012292] WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfb/0x100()
:[111749.012294] Hardware name: OEM
:[111749.012296] sysfs group ffffffffa02060f0 not found for kobject 'cpu1'
:[111749.012298] Modules linked in: nls_utf8 udf crc_itu_t tcp_lp fuse lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state ip6table_filter ipt_MASQUERADE iptable_nat nf_nat ip6_tables nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 snd_hda_codec_realtek snd_usb_audio snd_hda_intel snd_hda_codec snd_usbmidi_lib snd_hwdep snd_rawmidi 8139too snd_seq ppdev arc4 snd_pcm rtl8180 mac80211 8139cp eeprom_93cx6 uinput snd_seq_device snd_timer snd edac_core parport_pc edac_mce_amd soundcore k8temp shpchp microcode parport mii i2c_viapro cfg80211 sunrpc rfkill snd_page_alloc binfmt_misc ata_generic pata_acpi pata_via sata_via usb_storage nouveau ttm drm_kms_helper drm i2c_core mxm_wmi video wmi [last unloaded: scsi_wait_scan]
:[111749.012342] Pid: 9715, comm: pm-suspend Not tainted 3.3.0-8.fc16.x86_64 #1
:[111749.012344] Call Trace:
:[111749.012350]  [<ffffffff81057aff>] warn_slowpath_common+0x7f/0xc0
:[111749.012355]  [<ffffffff81057bf6>] warn_slowpath_fmt+0x46/0x50
:[111749.012358]  [<ffffffff811f08e9>] ? sysfs_get_dirent+0x59/0x80
:[111749.012362]  [<ffffffff811f29bb>] sysfs_remove_group+0xfb/0x100
:[111749.012368]  [<ffffffffa02045dd>] mc_cpu_callback+0xd1/0x11e [microcode]
:[111749.012373]  [<ffffffff815f7a5d>] notifier_call_chain+0x4d/0x70
:[111749.012378]  [<ffffffff8107fc6e>] __raw_notifier_call_chain+0xe/0x10
:[111749.012381]  [<ffffffff810598e0>] __cpu_notify+0x20/0x40
:[111749.012384]  [<ffffffff815d2d61>] _cpu_down+0x81/0x270
:[111749.012388]  [<ffffffff81059b47>] disable_nonboot_cpus+0xa7/0x150
:[111749.012391]  [<ffffffff8109cd1c>] suspend_devices_and_enter+0x20c/0x300
:[111749.012394]  [<ffffffff8109cf79>] enter_state+0x169/0x1b0
:[111749.012398]  [<ffffffff8109b8a7>] state_store+0xb7/0x130
:[111749.012403]  [<ffffffff812c292f>] kobj_attr_store+0xf/0x30
:[111749.012406]  [<ffffffff811ef0ff>] sysfs_write_file+0xef/0x170
:[111749.012409]  [<ffffffff81181673>] vfs_write+0xb3/0x180
:[111749.012411]  [<ffffffff8118199a>] sys_write+0x4a/0x90
:[111749.012415]  [<ffffffff815fbca9>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 13ac0d54-8e07-41b0-9ed6-159690218cfb
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4399.32
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
:CPU Stepping: 2
:CPU Family: 15
:CPU Model Num: 107
:Number of CPUs: 2
:CPU Speed: 2200
:System Memory: 2002
:System Swap: 2047
:Vendor: Foxconn
:System: OEM 
:Form factor: Desktop
:Kernel: 3.3.0-8.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4358:13111:4358:13111) pci, None, PCI/ISA, VT8237A PCI to ISA Bridge
:(4358:12548:4358:12548) pci, ehci_hcd, USB, USB 2.0
:(4358:12344:4358:12344) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:12344:4358:12344) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:12344:4358:12344) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:10366:4358:13182) pci, None, HOST/PCI, VT8251 Ultra VLINK Controller
:(4358:9014:0:0) pci, None, HOST/PCI, K8M890CE Host Bridge
:(4358:13110:0:0) pci, None, HOST/PCI, K8M890CE Host Bridge
:(4358:822:4358:822) pci, agpgart-amd64, HOST/PCI, K8M890CE Host Bridge
:(4358:4918:0:0) pci, None, HOST/PCI, K8M890CE Host Bridge
:(4358:29494:0:0) pci, None, HOST/PCI, K8M890CE Host Bridge
:(4358:17206:0:0) pci, None, HOST/PCI, K8M890CE Host Bridge
:(4358:45448:0:0) pci, None, PCI/PCI, VT8237 PCI bridge [K8T800/K8T890 South]
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4318:1601:14402:51523) pci, nouveau, VIDEO, G96 [GeForce 9400 GT]
:(4358:21302:0:0) pci, None, BASE, K8M890CE I/O APIC Interrupt Controller
:(4332:33157:4332:33157) pci, rtl8180, ETHERNET, RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller
:(4358:12936:4187:3316) pci, snd_hda_intel, MULTIMEDIA, VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)
:(4358:41528:0:0) pci, pcieport, PCI/PCI, K8T890 PCI to PCI Bridge Controller
:(4332:33081:4187:3204) pci, 8139too, ETHERNET, RTL-8139/8139C/8139C+
:(4358:49720:0:0) pci, pcieport, PCI/PCI, K8T890 PCI to PCI Bridge Controller
:(4358:12344:4358:12344) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:13179:0:0) pci, None, HOST/PCI, VT8237A Host Bridge
:(4358:13178:4358:13178) pci, None, PCI/PCI, VT8237A PCI to PCI Bridge
:(4358:21303:4187:3207) pci, sata_via, STORAGE, N/A
:(4358:1393:4187:3207) pci, pata_via, STORAGE, VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 13081819 8785214 8129854 3276800 2854688 2854688
:/dev/sda2 /home ext4 4096 4096 108218336 103151736 97734917 27090944 27041214 27041214
:/dev/sda1 /boot ext4 1024 1024 508745 410210 384610 128016 127785 127785
:
Comment 1 DeepPurpleFedora 2012-04-08 08:46:39 EDT
As far as I can tell I have been running this kernel the first time after its initail instillation.  I got the report after around a day or two of no restarting and a few suspends, but the most recent return from suspend for some reason is when I got the kernel crash message.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 2 Bryan Sutherland 2012-04-10 13:37:14 EDT
Looks like this may be an issue with the kernel against AMD CPUS. This kernel had been running fine until I attempted to come back from hibernation

HW info: http://www.smolts.org/client/show/?uuid=pub_b8a47788-3a98-43e2-ad18-18c1be4d7b55

WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfb/0x100()
Hardware name: System Product Name
sysfs group ffffffffa01d60f0 not found for kobject 'cpu1'
Modules linked in: fuse nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack vfat fat tcp_lp be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core 8021q fcoe libfcoe lockd ib_addr garp stp llc iscsi_tcp libiscsi_tcp libiscsi libfc scsi_transport_fc scsi_transport_iscsi scsi_tgt ip6t_REJECT snd_hda_codec_hdmi snd_hda_intel snd_hda_codec snd_hwdep snd_intel8x0 snd_ac97_codec ac97_bus snd_seq snd_seq_device snd_pcm ppdev parport_pc parport uinput snd_timer snd serio_raw hid_logitech_dj e100 forcedeth mii edac_core edac_mce_amd microcode asus_atk0110 k8temp joydev i2c_nforce2 soundcore sunrpc snd_page_alloc ata_generic usb_storage pata_acpi pata_amd sata_nv radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: nf_conntrack]
Pid: 9014, comm: pm-hibernate Not tainted 3.3.1-3.fc16.x86_64 #1
Call Trace:
 [<ffffffff8105798f>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff81057a86>] warn_slowpath_fmt+0x46/0x50
 [<ffffffff811f0529>] ? sysfs_get_dirent+0x59/0x80
 [<ffffffff811f25fb>] sysfs_remove_group+0xfb/0x100
 [<ffffffffa01d45dd>] mc_cpu_callback+0xd1/0x11e [microcode]
 [<ffffffff815f7d9d>] notifier_call_chain+0x4d/0x70
 [<ffffffff8107fafe>] __raw_notifier_call_chain+0xe/0x10
 [<ffffffff81059770>] __cpu_notify+0x20/0x40
 [<ffffffff815d30b1>] _cpu_down+0x81/0x270
 [<ffffffff810599d7>] disable_nonboot_cpus+0xa7/0x150
 [<ffffffff8109d682>] hibernation_snapshot+0x222/0x2e0
 [<ffffffff8109ddef>] hibernate+0x11f/0x200
 [<ffffffff8109b78c>] state_store+0x10c/0x130
 [<ffffffff81160963>] ? alloc_pages_current+0xa3/0x110
 [<ffffffff812c28ef>] kobj_attr_store+0xf/0x30
 [<ffffffff811eed3f>] sysfs_write_file+0xef/0x170
 [<ffffffff811813f3>] vfs_write+0xb3/0x180
 [<ffffffff8118171a>] sys_write+0x4a/0x90
 [<ffffffff815fbfe9>] system_call_fastpath+0x16/0x1b
Comment 3 Josh Boyer 2012-04-12 20:35:36 EDT

*** This bug has been marked as a duplicate of bug 797559 ***

Note You need to log in before you can comment on or make changes to this bug.