This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 797559 - [abrt] kernel: WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfa/0x100()
[abrt] kernel: WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfa/0x100()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:c4e9572a732781837b648cf9880...
: Reopened
: 806499 806658 810699 812164 814799 (view as bug list)
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-02-26 12:56 EST by Timothy Davis
Modified: 2012-04-25 23:27 EDT (History)
27 users (show)

See Also:
Fixed In Version: kernel-2.6.43.2-6.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 09:26:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
FC17 Beta message log (594.41 KB, application/octet-stream)
2012-04-25 06:05 EDT, Timothy Davis
no flags Details

  None (edit)
Description Timothy Davis 2012-02-26 12:56:19 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-0.rc3.git7.2.fc17.x86_64 root=UUID=ba0a1015-4172-4061-8fa3-e134d8b25f87 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
comment:        Tried to suspend system
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
reason:         WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfa/0x100()
time:           Thu 23 Feb 2012 07:24:25 PM EST

backtrace:
:WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfa/0x100()
:Hardware name:  
:sysfs group ffffffffa0199130 not found for kobject 'cpu1'
:Modules linked in: fuse binfmt_misc lockd sunrpc ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables arc4 rt73usb rt2x00usb rt2x00lib mac80211 cfg80211 rfkill crc_itu_t snd_intel8x0 snd_ac97_codec edac_core ac97_bus snd_pcm snd_page_alloc edac_mce_amd snd_timer k8temp microcode serio_raw snd soundcore i2c_nforce2 uinput ata_generic pata_acpi sata_nv pata_amd nouveau mxm_wmi wmi video drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 1704, comm: pm-suspend Not tainted 3.3.0-0.rc3.git7.2.fc17.x86_64 #1
:Call Trace:
: [<ffffffff81060bef>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81060ce6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff8123663b>] ? sysfs_get_dirent+0x5b/0x80
: [<ffffffff8123877a>] sysfs_remove_group+0xfa/0x100
: [<ffffffffa019764a>] mc_cpu_callback+0xda/0x129 [microcode]
: [<ffffffff816a265e>] notifier_call_chain+0x6e/0x110
: [<ffffffff8109182e>] __raw_notifier_call_chain+0xe/0x10
: [<ffffffff81062c60>] __cpu_notify+0x20/0x40
: [<ffffffff81679494>] _cpu_down+0x84/0x2d0
: [<ffffffff81691ba3>] ? printk+0x51/0x53
: [<ffffffff81062ee4>] disable_nonboot_cpus+0xa4/0x150
: [<ffffffff810b509d>] suspend_devices_and_enter+0x38d/0x4a0
: [<ffffffff810b5346>] enter_state+0x196/0x1d0
: [<ffffffff810b387a>] state_store+0xba/0x130
: [<ffffffff8131eecf>] kobj_attr_store+0xf/0x20
: [<ffffffff812347b6>] sysfs_write_file+0xe6/0x160
: [<ffffffff811bb44f>] vfs_write+0xaf/0x190
: [<ffffffff811bb78d>] sys_write+0x4d/0x90
: [<ffffffff816a6f29>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 1b54c924-cd3f-43f3-85f4-2fd87a29e4df
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5224.33
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) 64 FX-60 Dual Core Processor
:CPU Stepping: 2
:CPU Family: 15
:CPU Model Num: 35
:Number of CPUs: 2
:CPU Speed: 2600
:System Memory: 1986
:System Swap: 4095
:Vendor: Unknown
:System:  
:Form factor: Desktop
:Kernel: 3.3.0-0.rc3.git7.2.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4318:85:4318:52100) pci, sata_nv, STORAGE, CK804 Serial ATA Controller
:(4318:83:4318:52100) pci, pata_amd, STORAGE, CK804 IDE
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4318:93:0:0) pci, pcieport, PCI/PCI, CK804 PCIE Bridge
:(4318:92:0:0) pci, None, PCI/PCI, CK804 PCI Bridge
:(4318:90:4318:52100) pci, ohci_hcd, USB, CK804 USB Controller
:(4318:91:4318:52100) pci, ehci_hcd, USB, CK804 USB Controller
:(4318:93:0:0) pci, pcieport, PCI/PCI, CK804 PCIE Bridge
:(4545:1100:4545:1100) pci, None, SIMPLE, LT WinModem
:(4318:1057:6510:1152) pci, nouveau, VIDEO, G86 [GeForce 8500 GT]
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4318:89:4318:52100) pci, snd_intel8x0, MULTIMEDIA_AUDIO, CK804 AC'97 Audio Controller
:(4318:84:4318:52100) pci, sata_nv, STORAGE, CK804 Serial ATA Controller
:(4318:93:0:0) pci, pcieport, PCI/PCI, CK804 PCIE Bridge
:(4318:94:0:0) pci, None, MEMORY, CK804 Memory Controller
:(4318:93:0:0) pci, pcieport, PCI/PCI, CK804 PCIE Bridge
:(4318:82:4318:52100) pci, nForce2_smbus, SERIAL, CK804 SMBus
:(4318:80:4318:52100) pci, None, PCI/ISA, CK804 ISA Bridge
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda6 / ext4 4096 4096 4357631 2365644 2146982 1093440 795083 795083
:
Comment 1 Timothy Davis 2012-03-22 22:49:55 EDT
Suspended computer

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 2 igor.redhat@gmail.com 2012-03-25 00:40:16 EDT
This happened upon resume going out of hibernate. The hibernate was triggered by running out of battery.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 3 Andre Vehreschild 2012-03-27 02:17:18 EDT
System start from hibernate.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 4 igor.redhat@gmail.com 2012-03-27 12:03:14 EDT
Saw this upon resume from suspend

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 5 Josh Boyer 2012-03-28 14:01:09 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.
Comment 6 Brad Hubbard 2012-03-31 19:37:33 EDT
Hibernated and then resumed.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 7 Marc Ludwig 2012-04-02 09:22:15 EDT
Tried to set the Laptop in sleepmode when closed the lid. After wakeup the message ocours.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 8 John Mellor 2012-04-03 20:34:41 EDT
Unknown.  Booted back up from sleep and noticed the abrt icon.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 9 igor.redhat@gmail.com 2012-04-11 14:42:12 EDT
this showed up after a resume from suspend.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 10 igor.redhat@gmail.com 2012-04-11 14:45:43 EDT
it's probably not clear from the automated report above but this happened on 3.3.1-3.fc16.x86_64 for me.
Comment 11 Timothy Davis 2012-04-11 14:52:50 EDT
I have not been able to use suspend since kernel 3.0.0
Comment 12 Josh Boyer 2012-04-12 20:35:05 EDT
*** Bug 806499 has been marked as a duplicate of this bug. ***
Comment 13 Josh Boyer 2012-04-12 20:35:08 EDT
*** Bug 806658 has been marked as a duplicate of this bug. ***
Comment 14 Josh Boyer 2012-04-12 20:35:27 EDT
*** Bug 812164 has been marked as a duplicate of this bug. ***
Comment 15 Josh Boyer 2012-04-12 20:35:36 EDT
*** Bug 810699 has been marked as a duplicate of this bug. ***
Comment 16 Josh Boyer 2012-04-12 20:39:26 EDT
Should be fixed by:

https://lkml.org/lkml/2012/4/12/265
and
https://lkml.org/lkml/2012/4/12/266
Comment 17 Josh Boyer 2012-04-17 11:11:03 EDT
Fixed in all branches.
Comment 18 JO 2012-04-17 13:05:08 EDT
Powering up from suspend

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 19 Jaroslav Škarvada 2012-04-18 13:35:05 EDT
After resume from S2R.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 20 Kritta 2012-04-19 09:00:50 EDT
When running software update it gives me a message that the backend spawned and quit unexpectedly report this immediately

Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)
Comment 21 Dave Jones 2012-04-20 14:04:28 EDT
*** Bug 814799 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2012-04-21 11:21:35 EDT
kernel-3.3.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.2-8.fc17
Comment 23 Fedora Update System 2012-04-21 12:26:26 EDT
kernel-3.3.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.2-6.fc16
Comment 24 Fedora Update System 2012-04-21 12:46:22 EDT
kernel-2.6.43.2-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.2-6.fc15
Comment 25 Fedora Update System 2012-04-21 17:07:19 EDT
Package kernel-3.3.2-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.2-8.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6344/kernel-3.3.2-8.fc17
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2012-04-24 00:28:19 EDT
kernel-3.3.2-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2012-04-24 10:54:10 EDT
kernel-3.3.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Timothy Davis 2012-04-24 14:02:10 EDT
I still can't use suspend
Comment 29 Josh Boyer 2012-04-24 14:19:15 EDT
(In reply to comment #28)
> I still can't use suspend

Does it fail with the exact backtrace in the initial comment on kernel 3.3.2-8.fc17?  If so, please attach that backtrace so we can see.
Comment 30 Timothy Davis 2012-04-25 06:05:04 EDT
Created attachment 580121 [details]
FC17 Beta message log
Comment 31 Timothy Davis 2012-04-25 06:06:12 EDT
No, it doesn't fail with the same; no error is generated.
Should I open a new bugzilla stating that suspend isn't working.
Comment 32 Josh Boyer 2012-04-25 09:26:09 EDT
(In reply to comment #31)
> No, it doesn't fail with the same; no error is generated.
> Should I open a new bugzilla stating that suspend isn't working.

Yes.  We try to keep one issue per bug.  Also, you might try some of the steps here before opening the new bug:

http://fedoraproject.org/wiki/Common_kernel_problems#Suspend.2FResume_failure
Comment 33 Timothy Davis 2012-04-25 09:34:26 EDT
Agreed, we can close this and I'll open another specific to suspend failure.
The link seems to be for suspend mode that fails to recover.
Comment 34 Fedora Update System 2012-04-25 23:27:34 EDT
kernel-2.6.43.2-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.