Bug 810773 - after upgrade kernel to 3.3.1-3, my wireless not stable
after upgrade kernel to 3.3.1-3, my wireless not stable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 813332 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 23:27 EDT by netroby
Modified: 2012-04-22 00:15 EDT (History)
11 users (show)

See Also:
Fixed In Version: kernel-3.3.2-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:30:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (74.07 KB, text/plain)
2012-04-08 23:27 EDT, netroby
no flags Details

  None (edit)
Description netroby 2012-04-08 23:27:51 EDT
Created attachment 915437 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 netroby 2012-04-08 23:45:43 EDT
I found similar reporter:

https://bugzilla.novell.com/show_bug.cgi?id=756013
https://lkml.org/lkml/2012/4/3/26

please help and check .
Comment 2 netroby 2012-04-08 23:50:42 EDT
here is my pci information:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation GF106 [GeForce GT 555M SDDR3] (rev a1)
07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
08:00.0 Ethernet controller: Atheros Communications AR8151 v2.0 Gigabit Ethernet (rev c0)
09:00.0 USB Controller: VIA Technologies, Inc. Device 3432 (rev 02)
Comment 3 netroby 2012-04-08 23:51:43 EDT
http://www.mentby.com/Group/linux-kernel/331-ath9k-regression.html

here is more research.
Comment 4 Alexei Panov 2012-04-11 16:33:11 EDT
I can confirm this bug. It is very annoying. And I've written script as a workaround.
Script here http://repo.elemc.name/repos/scripts/rfr1002/ath9k-workaround.sh
Simply put this script to /etc/NetworkManager/dispatcher.d/ and make it executable.
Comment 5 Alexei Panov 2012-04-11 16:35:04 EDT
Oh, I'm sorry, script is here http://repo.elemc.name/repos/scripts/rfr1002/ath9k-nm
Previous script for hibernation (/ etc / pm / sleep.d)
Comment 6 Evgeniy 2012-04-12 17:27:43 EDT
I had the same and I confirm what these scripts helped me. Big thanks Alexei Panov.
Comment 7 planetan 2012-04-12 20:54:11 EDT
My wireless is not working after I upgraded to 3.3.1-3
Comment 8 netroby 2012-04-12 21:05:15 EDT
(In reply to comment #4)
> I can confirm this bug. It is very annoying. And I've written script as a
> workaround.
> Script here http://repo.elemc.name/repos/scripts/rfr1002/ath9k-workaround.sh
> Simply put this script to /etc/NetworkManager/dispatcher.d/ and make it
> executable.

This scripts should reconnect wireless, but if you do not want to focus the wireless often disconnect automatically, you should revert kernel to 3.1.0


ath9k driver with kernel 3.1.0 working well , it will not disconnect automatically.
Comment 9 John W. Linville 2012-04-13 10:05:02 EDT
Please try the test kernels here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3980617

Do they resolve the issue for you?
Comment 10 Alexei Panov 2012-04-13 15:21:51 EDT
This bug appeared in Fedora 17 with b43 module.
uname -r 3.3.1-5.fc17.i686
08:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
Comment 11 Robert Solomon 2012-04-14 12:11:33 EDT
Still experiencing this bug with:
# uname -r
3.3.1-5.fc16.i686.PAE
# lspci -v |grep -A 13 Wireless
01:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: AzureWave Device 1067
	Physical Slot: eeepc-wifi
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at f8000000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 2
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [90] MSI-X: Enable- Count=1 Masked-
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
	Kernel driver in use: ath9k
	Kernel modules: ath9k

Wireless works fine with config-3.3.0-8.fc16.i686.PAE

thanks for giving this your attention.
Comment 12 netroby 2012-04-16 08:27:14 EDT
Would you please upgrade kernel to kernel 3.3.2?

seems the upstream reverts commit to a stable commit.

thanks the guys from qualcomm.

http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.3.2
commit 2ed63a49ab039d590f7f9fef63706d83805079c6
Author: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date:   Tue Apr 10 12:26:11 2012 +0530

    Revert "ath9k: fix going to full-sleep on PS idle"
    
    commit 011afa1ed8c408d694957d2474d89dc81a60b70c upstream.
    
    This reverts commit c1afdaff90538ef085b756454f12b29575411214.
    
    Users have reported connection failures in 3.3.1 and suspend/resume
    failures in 3.4-rcX. Revert this commit for now - PS IDLE can be
    fixed in a clean manner later on.
    
    Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Comment 13 Josh Boyer 2012-04-16 09:46:15 EDT
(In reply to comment #12)
> Would you please upgrade kernel to kernel 3.3.2?

http://koji.fedoraproject.org/koji/buildinfo?buildID=313130

It's built, just not filed as an update yet.
Comment 14 Robert Solomon 2012-04-16 12:58:18 EDT
(In reply to comment #13)
> (In reply to comment #12)
> > Would you please upgrade kernel to kernel 3.3.2?
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=313130
> 
> It's built, just not filed as an update yet.

running 3.3.2-1.fc16.i686.PAE so far no problems with wireless.  I want to test with my wireless at home before I say this is resolved.
Comment 15 Fedora Update System 2012-04-16 15:07:32 EDT
kernel-3.3.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc16
Comment 16 Fedora Update System 2012-04-16 15:10:54 EDT
kernel-3.3.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc17
Comment 17 Fedora Update System 2012-04-16 17:57:31 EDT
Package kernel-3.3.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.2-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5994/kernel-3.3.2-1.fc17
then log in and leave karma (feedback).
Comment 18 Jerry 2012-04-16 21:35:19 EDT
3.3.2-1-fc16 fixes the problem on my system, testing for several hours now with no issues, no dropouts, no lost  network manager.
Comment 19 Robert Solomon 2012-04-16 22:20:18 EDT
(In reply to comment #18)
> 3.3.2-1-fc16 fixes the problem on my system, testing for several hours now with
> no issues, no dropouts, no lost  network manager.

ditto here.  thanks again.
Comment 20 emailadhoc 2012-04-17 10:18:53 EDT
*** Bug 813332 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2012-04-18 15:30:33 EDT
kernel-3.3.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 netroby 2012-04-20 19:42:07 EDT
Kernel  3.3.2-1 is ok both on Fedora 16 and Fedora 17.
thanks
Comment 23 Fedora Update System 2012-04-22 00:15:40 EDT
kernel-3.3.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.