Bug 813332 - regression in Linux 3.3.1 (ath9k)
regression in Linux 3.3.1 (ath9k)
Status: CLOSED DUPLICATE of bug 810773
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 10:11 EDT by emailadhoc
Modified: 2012-04-17 10:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 10:18:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description emailadhoc 2012-04-17 10:11:00 EDT
after updating to the kernel 3.3.1-5.fc16.x86_64 I can no longer connect to wifi networks after disassociating from them, or after resuming from ACPI S3 status.

The incriminated commit is commit c1afdaff90538ef085b756454f12b29575411214.

That issue have been fixed upstream, with commit 2ed63a49ab039d590f7f9fef63706d83805079c6, which is included in the latest stable kernel, 3.3.2
Comment 1 emailadhoc 2012-04-17 10:14:35 EDT
commit ad07d7b92e72331be7fa555491d42686e8c4e925
Author: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date:   Fri Apr 13 09:42:02 2012 -0700

    Linux 3.3.2

commit 2ed63a49ab039d590f7f9fef63706d83805079c6
Author: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date:   Tue Apr 10 12:26:11 2012 +0530

    Revert "ath9k: fix going to full-sleep on PS idle"
    
    commit 011afa1ed8c408d694957d2474d89dc81a60b70c upstream.
    
    This reverts commit c1afdaff90538ef085b756454f12b29575411214.
    
    Users have reported connection failures in 3.3.1 and suspend/resume
    failures in 3.4-rcX. Revert this commit for now - PS IDLE can be
    fixed in a clean manner later on.
    
    Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Comment 2 emailadhoc 2012-04-17 10:18:53 EDT

*** This bug has been marked as a duplicate of bug 810773 ***

Note You need to log in before you can comment on or make changes to this bug.