Bug 810796 - Kernel 3.3.1-3 error reconnect Atheros AR928X Wireless Network Adapter
Kernel 3.3.1-3 error reconnect Atheros AR928X Wireless Network Adapter
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 812500 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 04:10 EDT by Patrick Moelands
Modified: 2012-04-24 00:27 EDT (History)
20 users (show)

See Also:
Fixed In Version: kernel-3.3.2-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:30:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick Moelands 2012-04-09 04:10:44 EDT
Description of problem: after boot and login in the wireless network adapter connects without any problem to the wireless network. When this connection is interrupted (by hand or after the laptop went into hybernation), reconnecting isn't possible. The system keeps asking for the wifi password. The only way to connect to the network is to reboot the system.

Kernel: kernel-3.3.1-3.fc16.x86_64
Wifi card: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

How reproducible: disconnect the wifi connection and retry to connect.
 
Actual results: with every attempt to reconnect, the system keeps asking for the wifi password.

Additional info: this happens with the 3.3.1-3 Kernel. When the system is booted with the 3.1.0-7 kernel (default kernel from the Fedora 16 installation) the problem does not occur.
Comment 1 Sajid Zaman 2012-04-09 06:30:55 EDT
I also have the same problem when i updated the kernel to 3.3.1-3 , it is and was working fine with all the older kernels.
Comment 2 Sean 2012-04-09 11:04:01 EDT
Wifi card: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

I am also effected by this. 
Tested what not works: 3.3.1-2.fc16.x86_64 and 3.3.1-3.fc16.x86_64. 

Tested what works: 3.3.0-8.fc16.x86_64 and the kernels before that since Fedora 16 release.
Comment 3 Mohammed Shafi 2012-04-10 06:07:32 EDT
this should fix
http://comments.gmane.org/gmane.linux.kernel.wireless.general/88543
revert patch from Sujith, got to fix unassociated idle power save
Comment 4 Guido 2012-04-11 15:44:15 EDT
I have this problem too, but I can't even connect the first time.
Kernel 3.3.0-8.fc16.x86_64 is working, kernel 3.3.1-3.fc16.x86_64 NO!
Comment 5 John W. Linville 2012-04-11 16:30:02 EDT
That narrows it down quite a bit, and only one patch between 3.3.0 and 3.3.1 seems relevant.  In fact, that very patch is also being reverted in my current upstream wireless fix tree...

Test kernel w/ the revert building here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3980617

Please give that a try and post the results here...thanks!
Comment 6 Guido 2012-04-11 18:12:06 EDT
Kernel 3.3.1-5.bz810796.fc16.x86_64 solved the problem for me, but I didn't try suspend/resume. Now I can connect with my wireless

AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Thank you very much
Comment 7 Patrick Moelands 2012-04-12 14:18:39 EDT
The problem is solved by using your kernel (3.3.1-5.bz810796.fc16.x86_64). Both manual disconnecting and (forced) hybernation work without any problem. Thanks John!
Comment 8 Orion Poplawski 2012-04-13 11:34:58 EDT
Confirming that 3.3.1-5.bz810796.fc16.i686.PAE fixes the issue for me too.
Comment 9 Sajid Zaman 2012-04-14 02:15:00 EDT
does the kernel 3.3.1-5.bz810796.fc16.i686.PAE is equivalent to 3.3.1-5.PAE ?? if yes then my card is not working yet

Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Comment 10 Iván Jiménez 2012-04-14 13:22:06 EDT
(In reply to comment #5)
> That narrows it down quite a bit, and only one patch between 3.3.0 and 3.3.1
> seems relevant.  In fact, that very patch is also being reverted in my current
> upstream wireless fix tree...
> 
> Test kernel w/ the revert building here:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3980617
> 
> Please give that a try and post the results here...thanks!

This fixes it for me, with wifi:
07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Comment 11 gavinw 2012-04-15 00:22:16 EDT
kernel-3.3.1-5.fc16.i686 doesn't fix the problem.

Atheros Communications Inc. AR9485 Wireless Network Adapter
Comment 12 Artyom Kunyov 2012-04-15 04:49:11 EDT
kernel-3.3.1-5.fc16 doesn't fix the problem on my XPS M1530.
Comment 13 Patrick Moelands 2012-04-15 07:53:30 EDT
When checking the info on updates (http://lists.fedoraproject.org/pipermail/package-announce/2012-April/date.html) you will see that the 3.3.1.5 kernel doesn't fix this problem.

Details on the 3.3.1-5 kernel are described here:
http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078256.html

The latest reported bugfix that made it into this kernel dates from april 10. The fix for our problem dates april 11 and isn't included.
Comment 14 Artyom Kunyov 2012-04-15 08:13:16 EDT
According to 3.2.2 changelog, this fix is included.
See the first commit here: http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.3.2
Comment 15 Patrick Moelands 2012-04-15 09:17:15 EDT
The commit you mention is from the kernel.org site dated on April 13. Fedora's latest kernel (kernel-3.3.1-5.fc16) was released on the same day. I doubt that within a couple of hours Fedora is releasing their own kernel based on changes signed off that day by the people without any QA.

When you look at the name of the "patched-kernel" it suggests to me that is based on the 3.3.1-5 kernel (hence the name 3.3.1-5.bz810796). And that would explain why people using the 3.3.1-5 kernel still have the problem.
Comment 16 admin 2012-04-15 11:00:34 EDT
Bug is still exist with Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01).

I can't connect to any wireless network.
Comment 17 Guido 2012-04-16 06:10:36 EDT
I think you have to wait for kernel-3.3.2
Comment 18 Ryan 2012-04-16 09:15:49 EDT
My girlfriend using Fedora 16 on her laptop has this problem. She has 3.3.1-5 x86_64 kernel. laptop disconnects constantly from the network...
Comment 19 Josh Boyer 2012-04-16 09:45:41 EDT
(In reply to comment #17)
> I think you have to wait for kernel-3.3.2

It's built, just not filed as an update yet.

http://koji.fedoraproject.org/koji/buildinfo?buildID=313130
Comment 20 Josh Boyer 2012-04-16 11:01:17 EDT
*** Bug 812500 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2012-04-16 15:07:39 EDT
kernel-3.3.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc16
Comment 22 Fedora Update System 2012-04-16 15:11:02 EDT
kernel-3.3.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc17
Comment 23 Fedora Update System 2012-04-16 17:57:38 EDT
Package kernel-3.3.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.2-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5994/kernel-3.3.2-1.fc17
then log in and leave karma (feedback).
Comment 24 Patrick Moelands 2012-04-17 00:46:36 EDT
(In reply to comment #21)
> kernel-3.3.2-1.fc16 has been submitted as an update for Fedora 16.
> https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc16

New kernel tested, confirming problem solved (karma/feedback given).
Comment 25 admin 2012-04-17 04:38:55 EDT
Confirming problem solved.
Comment 26 Alexandre Franke 2012-04-17 16:25:35 EDT
I tried
$ sudo yum update --enablerepo=updates-testing kernel-3.3.2-1.fc16
but it told me there's no such package available.
I guess I have to wait until "Pushed" is marked true on https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc16
Right?
Comment 27 Josh Boyer 2012-04-17 16:33:02 EDT
(In reply to comment #26)
> I tried
> $ sudo yum update --enablerepo=updates-testing kernel-3.3.2-1.fc16
> but it told me there's no such package available.
> I guess I have to wait until "Pushed" is marked true on
> https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc16
> Right?

Yes.  Bodhi will leave a comment similar to comment #23 when it's available in the f16 repos.
Comment 28 Alexandre Franke 2012-04-17 16:43:16 EDT
However I noted in the meantime that two people have already commented that they tested it. Did they manually download it? Would you recommend I do the same?
Comment 29 Jeremy Newton 2012-04-17 17:26:58 EDT
(In reply to comment #28)
> However I noted in the meantime that two people have already commented that
> they tested it. Did they manually download it? Would you recommend I do the
> same?

Either is fine; if you're eager and wish to update sooner, you could manually download it.
Comment 30 Fedora Update System 2012-04-18 15:30:56 EDT
kernel-3.3.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Fedora Update System 2012-04-22 00:16:24 EDT
kernel-3.3.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Rafa 2012-04-24 00:27:25 EDT
# lspci 
01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

# uname -a
Linux empress 3.3.2-1.fc16.x86_64 #1 SMP Sat Apr 14 00:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
 

Not working. I read somewhere that maybe its something related to energy. I'm using my laptop without battery, just for your information. 

Please any advice will be so much appreciated.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.