Bug 812500 - Can't connect to wireless AP (ath9k)
Can't connect to wireless AP (ath9k)
Status: CLOSED DUPLICATE of bug 810796
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 23:45 EDT by Jeremy Newton
Modified: 2012-04-16 11:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 11:01:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Newton 2012-04-13 23:45:05 EDT
Description of problem:
If I attempt to connect to a wireless AP with my laptop and it fails to connect. This seems to happen over and over, and rarely manages to connect to the wireless AP. I'm using a laptop with an ath9k wireless card.

Version-Release number of selected component (if applicable):
This is not a problem in kernel 3.3.0-8 and I can confirm this as becoming a problem as of kernel 3.3.1-1. Due to the circumstances, one could assume this is a bug in 3.3.1 itself.

As well, I can confirm this with the following Fedora kernel versions:
3.3.1-1.fc16, 3.3.1-2.fc16, 3.3.1-3.fc16

How reproducible:
Very reproducible

Steps to Reproduce:
1. Start into Fedora 16 with one of the confirmed kernel listed above.
2. Try to connect to a wireless AP
  
Actual results:
Mostly consistently failed connections.

Expected results:
Mostly consistently successful connections.

Additional info:
I'm using an EeePC 1015PX with an Atheros AR9285 wireless card.
Note this seems to be specifically a regression in ath9k, though may include others.

Please let me know if I can provide any more information that would help.
Comment 1 John W. Linville 2012-04-16 10:55:36 EDT
A 3.3.2-based kernel should resolve this issue when it becomes available through the update system.
Comment 2 Josh Boyer 2012-04-16 11:01:16 EDT

*** This bug has been marked as a duplicate of bug 810796 ***

Note You need to log in before you can comment on or make changes to this bug.