Bug 810832 - growisofs fails sometimes with SK=3h/POWER CALIBRATION AREA ERROR, I/O Error, disc is writable by another writer
growisofs fails sometimes with SK=3h/POWER CALIBRATION AREA ERROR, I/O Error,...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 06:45 EDT by Reartes Guillermo
Modified: 2012-09-18 05:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 05:45:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
usbmon output of the DV-W28SS-RZ3 (89.04 KB, text/plain)
2012-04-09 06:47 EDT, Reartes Guillermo
no flags Details
blktrace of the DV-W28SS-RZ3 (31.34 KB, application/octet-stream)
2012-04-09 06:48 EDT, Reartes Guillermo
no flags Details
blkparse (human text readable) output DV-W28SS-RZ3 (50.28 KB, text/plain)
2012-04-09 06:48 EDT, Reartes Guillermo
no flags Details
usbmon output of the DV-W28SS-VZ3 (4.71 MB, text/plain)
2012-04-09 06:53 EDT, Reartes Guillermo
no flags Details
blktrace of the DV-W28SS-VZ3 (2.19 MB, application/octet-stream)
2012-04-09 06:55 EDT, Reartes Guillermo
no flags Details
blkparse (human text readable) output DV-W28SS-VZ3 (3.48 MB, text/plain)
2012-04-09 06:57 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-04-09 06:45:58 EDT
Description of problem:

This happens from time to time, at first i thought that it was a bad media. The last time i found a media that fails and took it with me for later testing.

We are using the TEAC DV-W28SS-RZ3 first:

<LAUNCH USB MONITOR>
<INSERT USB-SATA SunPlus Bridge>

<LAUNCH BLKTRACE ON THE DVD Device>
<INSERT DVD+R RETRIEVED FROM AFA:TORTUGAS aka "BAD_DISC">

# dvd+rw-mediainfo /dev/sr1 
INQUIRY:                [TEAC    ][DV-W28SS-R      ][1.0C]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Bh, DVD+R
 Media ID:              MCC/004
 Current Write Speed:   8.0x1385=11080KB/s
 Write Speed #0:        8.0x1385=11080KB/s
 Write Speed #1:        6.0x1385=8310KB/s
 Write Speed #2:        4.0x1385=5540KB/s
 Write Speed #3:        3.0x1385=4155KB/s
 Speed Descriptor#0:    00/2295103 R@8.0x1385=11080KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#1:    00/2295103 R@8.0x1385=11080KB/s W@6.0x1385=8310KB/s
 Speed Descriptor#2:    00/2295103 R@8.0x1385=11080KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#3:    00/2295103 R@8.0x1385=11080KB/s W@3.0x1385=4155KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2295104*2KB=4700372992
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           2295104*2KB
 Track Size:            2295104*2KB
 ROM Compatibility LBA: 270336
READ CAPACITY:          0*2048=0

# growisofs -Z /dev/sr1 -R -J /test/1/
Executing 'mkisofs -R -J /test/1/ | builtin_dd of=/dev/sr1 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
  3.13% done, estimate finish Sat Apr  7 17:41:13 2012
/dev/sr1: "Current Write Speed" is 8.2x1352KBps.
:-[ WRITE@LBA=0h failed with SK=3h/POWER CALIBRATION AREA ERROR]: Input/output error
:-( write failed: Input/output error

# eject /dev/sr1

<STOP BLKTRACE>
<STOP USBMON>

Now, i repeated the test with the TEAC DV-W28SS-VZ3:

<LAUNCH USB MONITOR>
<INSERT USB-SATA SunPlus Bridge>

<LAUNCH BLKTRACE ON THE DVD Device>
<INSERT DVD+R RETRIEVED FROM AFA:TORTUGAS aka "BAD_DISC">

# dvd+rw-mediainfo /dev/sr1 
INQUIRY:                [TEAC    ][DV-W28SS-V      ][1.0B]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Bh, DVD+R
 Media ID:              MCC/004
 Current Write Speed:   8.0x1385=11080KB/s
 Write Speed #0:        8.0x1385=11080KB/s
 Write Speed #1:        6.0x1385=8310KB/s
 Write Speed #2:        4.0x1385=5540KB/s
 Write Speed #3:        3.0x1385=4155KB/s
 Speed Descriptor#0:    00/0 R@8.0x1385=11080KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#1:    00/0 R@8.0x1385=11080KB/s W@6.0x1385=8310KB/s
 Speed Descriptor#2:    00/0 R@8.0x1385=11080KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#3:    00/0 R@8.0x1385=11080KB/s W@3.0x1385=4155KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2295104*2KB=4700372992
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           2295104*2KB
 Track Size:            2295104*2KB
 ROM Compatibility LBA: 270336
READ CAPACITY:          0*2048=0
[root@grimmjow ~]# growisofs -Z /dev/sr1 -R -J /test/1/
Executing 'mkisofs -R -J /test/1/ | builtin_dd of=/dev/sr1 obs=32k seek=0'
I: -input-charset not specified, using utf-8 (detected in locale settings)
  3.13% done, estimate finish Sat Apr  7 17:59:44 2012
/dev/sr1: "Current Write Speed" is 8.2x1352KBps.
  6.26% done, estimate finish Sat Apr  7 18:12:30 2012
  9.39% done, estimate finish Sat Apr  7 18:08:36 2012
 12.52% done, estimate finish Sat Apr  7 18:06:39 2012
 15.64% done, estimate finish Sat Apr  7 18:05:29 2012
 18.77% done, estimate finish Sat Apr  7 18:04:47 2012
 21.89% done, estimate finish Sat Apr  7 18:04:13 2012
 25.02% done, estimate finish Sat Apr  7 18:03:51 2012
 28.15% done, estimate finish Sat Apr  7 18:03:31 2012
 31.28% done, estimate finish Sat Apr  7 18:03:15 2012
 34.40% done, estimate finish Sat Apr  7 18:03:01 2012
 37.53% done, estimate finish Sat Apr  7 18:02:50 2012
 40.65% done, estimate finish Sat Apr  7 18:02:41 2012
 43.79% done, estimate finish Sat Apr  7 18:02:33 2012
 46.91% done, estimate finish Sat Apr  7 18:02:26 2012
 50.04% done, estimate finish Sat Apr  7 18:02:19 2012
 53.16% done, estimate finish Sat Apr  7 18:02:14 2012
 56.29% done, estimate finish Sat Apr  7 18:02:09 2012
 59.42% done, estimate finish Sat Apr  7 18:02:05 2012
 62.55% done, estimate finish Sat Apr  7 18:02:01 2012
 65.67% done, estimate finish Sat Apr  7 18:01:58 2012
 68.80% done, estimate finish Sat Apr  7 18:01:54 2012
 71.92% done, estimate finish Sat Apr  7 18:01:51 2012
 75.06% done, estimate finish Sat Apr  7 18:01:49 2012
 78.18% done, estimate finish Sat Apr  7 18:01:46 2012
 81.31% done, estimate finish Sat Apr  7 18:01:44 2012
 84.43% done, estimate finish Sat Apr  7 18:01:42 2012
 87.56% done, estimate finish Sat Apr  7 18:01:40 2012
 90.69% done, estimate finish Sat Apr  7 18:01:38 2012
 93.82% done, estimate finish Sat Apr  7 18:01:36 2012
 96.94% done, estimate finish Sat Apr  7 18:01:34 2012
Total translation table size: 0
Total rockridge attributes bytes: 249
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
159901 extents written (312 MB)
builtin_dd: 159904*2KB out @ average 2.1x1352KBps
/dev/sr1: flushing cache
/dev/sr1: closing track
/dev/sr1: closing session
/dev/sr1: reloading tray

<THE DISC SELF-EJECTED THIS TIME>

<STOP BLKTRACE>
<STOP USBMON>

So, the TEAC DV-W28SS-RZ3 was unable to write this disc,
i tried several times before, and in this test.
The TEAC DV-W28SS-VZ3 wrote the disc without complaining. 
Was the disc bad or was the TEAC at fault? Growisofs? Who knows. 

# sha256sum /media/CDROM/bin1.tar 
65063a00ac694f5a9273de154d564a33ea5a66c7ef778a5a68b14af47facafdd  /media/CDROM/bin1.tar
# sha256sum /test/1/bin1.tar 
65063a00ac694f5a9273de154d564a33ea5a66c7ef778a5a68b14af47facafdd  /test/1/bin1.tar

This was verified with: MATSHITA DVD+/-RW UJ8A2, 1.02

I have seem posts and reports of something similar over random forums without
any conclusive explanations, so i tested it with USBMON and BLKTRACE, and got 
traces of the issue happening. I hope that if there is a bug, it can help to identify it.


Version-Release number of selected component (if applicable):
F16, dvd+rw-tools-7.1-8.fc16.x86_64 (and older, like Centos 5.3 / 5.8)
kernel: 3.3.1-2.fc16.x86_64

How reproducible:
sometimes, but it can be months for it to happen.

Steps to Reproduce:
1. burn a dvd+r

  
Actual results:
the disc media is unwritable for X writer (it happens only on that disc and not
on the other media of the same batch). The disc can be writen by another writer.

Expected results:
be able to write as long as the media inserted is good (something i don't know yet, because it seems like a bug).

Additional info:
Traces performed.
Comment 1 Reartes Guillermo 2012-04-09 06:47:33 EDT
Created attachment 576171 [details]
usbmon output of the DV-W28SS-RZ3
Comment 2 Reartes Guillermo 2012-04-09 06:48:21 EDT
Created attachment 576172 [details]
blktrace of the DV-W28SS-RZ3
Comment 3 Reartes Guillermo 2012-04-09 06:48:59 EDT
Created attachment 576173 [details]
blkparse (human text readable) output DV-W28SS-RZ3
Comment 4 Reartes Guillermo 2012-04-09 06:53:18 EDT
Created attachment 576174 [details]
usbmon output of the DV-W28SS-VZ3
Comment 5 Reartes Guillermo 2012-04-09 06:55:07 EDT
Created attachment 576175 [details]
blktrace of the DV-W28SS-VZ3
Comment 6 Reartes Guillermo 2012-04-09 06:57:05 EDT
Created attachment 576176 [details]
blkparse (human text readable) output DV-W28SS-VZ3
Comment 7 Honza Horak 2012-04-10 05:04:42 EDT
(In reply to comment #0)
> How reproducible:
> sometimes, but it can be months for it to happen.

So I suppose it's not probably caused by the build dvd+rw-tools-7.1-8.fc16.x86_64, which is actually in testing only for some days. But to be sure, can you, please, test some older build of dvd+rw-tools and kernel to see if the problem is there as well? And if you can test some older builds also regarding the bug #810838, it'd be great.

dvd+rw-tools-7.1-6.fc17 can be found here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=284523

For some older kernel, check:
http://koji.fedoraproject.org/koji/packageinfo?packageID=8
Comment 8 Reartes Guillermo 2012-04-10 13:33:46 EDT
This might qualify as an older kernel / and growisofs build:

CentOS 5.3 i386, 2.6.18-128.el5PAE
----------------------------------

# lsusb 
Bus 003 Device 001: ID 0000:0000  
Bus 003 Device 002: ID 04f2:0402 Chicony Electronics Co., Ltd 
Bus 004 Device 002: ID 0458:003a KYE Systems Corp. (Mouse Systems) 
Bus 004 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 004: ID 1bcf:0c31 Sunplus Innovation Technology Inc. 
Bus 001 Device 001: ID 0000:0000  

# lsusb -t 
Bus#  4
`-Dev#   1 Vendor 0x0000 Product 0x0000
  `-Dev#   2 Vendor 0x0458 Product 0x003a
Bus#  3
`-Dev#   1 Vendor 0x0000 Product 0x0000
  `-Dev#   2 Vendor 0x04f2 Product 0x0402
Bus#  2
`-Dev#   1 Vendor 0x0000 Product 0x0000
Bus#  1
`-Dev#   1 Vendor 0x0000 Product 0x0000
  `-Dev#   4 Vendor 0x1bcf Product 0x0c31


# dvd+rw-mediainfo /dev/scd0
INQUIRY:                [TEAC    ][DV-W28SS-R      ][1.0C]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Bh, DVD+R
 Media ID:              MCC/003
 Current Write Speed:   8.0x1385=11080KB/s
 Write Speed #0:        8.0x1385=11080KB/s
 Write Speed #1:        6.0x1385=8310KB/s
 Write Speed #2:        4.0x1385=5540KB/s
 Write Speed #3:        3.0x1385=4155KB/s
 Speed Descriptor#0:    00/2295103 R@8.0x1385=11080KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#1:    00/2295103 R@8.0x1385=11080KB/s W@6.0x1385=8310KB/s
 Speed Descriptor#2:    00/2295103 R@8.0x1385=11080KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#3:    00/2295103 R@8.0x1385=11080KB/s W@3.0x1385=4155KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2295104*2KB=4700372992
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           2295104*2KB
 Track Size:            2295104*2KB
 ROM Compatibility LBA: 270336
READ CAPACITY:          0*2048=0
 
# time growisofs -Z /dev/scd0 -R -J /test/1/
Executing 'mkisofs -R -J /test/1/ | builtin_dd of=/dev/scd0 obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
  9.42% done, estimate finish Tue Apr 10 14:57:23 2012
 18.84% done, estimate finish Tue Apr 10 14:57:23 2012
 28.23% done, estimate finish Tue Apr 10 14:57:23 2012
/dev/scd0: "Current Write Speed" is 8.2x1352KBps.
 37.66% done, estimate finish Tue Apr 10 14:59:09 2012
 47.05% done, estimate finish Tue Apr 10 14:58:54 2012
 56.47% done, estimate finish Tue Apr 10 14:58:42 2012
 65.86% done, estimate finish Tue Apr 10 14:58:35 2012
 75.29% done, estimate finish Tue Apr 10 14:58:29 2012
 84.68% done, estimate finish Tue Apr 10 14:58:25 2012
 94.10% done, estimate finish Tue Apr 10 14:58:21 2012
Total translation table size: 0
Total rockridge attributes bytes: 249
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
53151 extents written (103 MB)
builtin_dd: 53152*2KB out @ average 1.2x1352KBps
/dev/scd0: flushing cache
/dev/scd0: closing track
/dev/scd0: closing session
/dev/scd0: reloading tray

real    1m32.644s
user    0m0.072s
sys     0m0.991s

# dvd+rw-mediainfo /dev/scd0
INQUIRY:                [TEAC    ][DV-W28SS-R      ][1.0C]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Bh, DVD+R
 Media ID:              MCC/003
 Current Write Speed:   8.0x1385=11080KB/s
 Write Speed #0:        8.0x1385=11080KB/s
 Write Speed #1:        6.0x1385=8310KB/s
 Write Speed #2:        4.0x1385=5540KB/s
 Write Speed #3:        3.0x1385=4155KB/s
 Speed Descriptor#0:    00/2295103 R@8.0x1385=11080KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#1:    00/2295103 R@8.0x1385=11080KB/s W@6.0x1385=8310KB/s
 Speed Descriptor#2:    00/2295103 R@8.0x1385=11080KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#3:    00/2295103 R@8.0x1385=11080KB/s W@3.0x1385=4155KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2295104*2KB=4700372992
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           2295104*2KB
 Track Size:            2295104*2KB
 ROM Compatibility LBA: 270336
READ CAPACITY:          0*2048=0


# time growisofs -Z /dev/scd0 -R -J -speed=10 /test/x/
Executing 'mkisofs -R -J /test/x/ | builtin_dd of=/dev/scd0 obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
  3.13% done, estimate finish Tue Apr 10 15:04:20 2012
  6.26% done, estimate finish Tue Apr 10 15:04:20 2012
  9.39% done, estimate finish Tue Apr 10 15:04:20 2012
/dev/scd0: "Current Write Speed" is 8.2x1352KBps.
:-[ WRITE@LBA=0h failed with SK=3h/POWER CALIBRATION AREA ERROR]: Input/output error
:-( write failed: Input/output error

real    0m28.092s
user    0m0.000s
sys     0m0.100s


# time growisofs -Z /dev/scd0 -R -J -speed=10 /test/a/
Executing 'mkisofs -R -J /test/a/ | builtin_dd of=/dev/scd0 obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
  3.34% done, estimate finish Tue Apr 10 15:04:55 2012
  6.69% done, estimate finish Tue Apr 10 15:05:09 2012
 10.02% done, estimate finish Tue Apr 10 15:05:04 2012
/dev/scd0: "Current Write Speed" is 8.2x1352KBps.
:-[ WRITE@LBA=0h failed with SK=3h/POWER CALIBRATION AREA ERROR]: Input/output error
:-( write failed: Input/output error

real    0m26.688s
user    0m0.001s
sys     0m0.100s



# time growisofs -Z /dev/scd0 -R -J /test/x/
Executing 'mkisofs -R -J /test/x/ | builtin_dd of=/dev/scd0 obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
  3.13% done, estimate finish Tue Apr 10 15:05:37 2012
  6.26% done, estimate finish Tue Apr 10 15:05:37 2012
  9.39% done, estimate finish Tue Apr 10 15:05:37 2012
/dev/scd0: "Current Write Speed" is 8.2x1352KBps.
:-[ WRITE@LBA=0h failed with SK=3h/POWER CALIBRATION AREA ERROR]: Input/output error
:-( write failed: Input/output error

real    0m22.616s
user    0m0.003s
sys     0m0.111s


# ls -l /test/a/
total 299504
-rw-r--r-- 1 root root 306377839 Apr  8 14:35 uneven1.file

# ls -l /test/x/
total 319760
-rw-r--r-- 1 root root 327106560 Apr 10 15:02 bin1gj.tar

<HOST RESET / INIT 6>

# time growisofs -Z /dev/scd0 -R -J -speed=10 /test/x/ 
Executing 'mkisofs -R -J /test/x/ | builtin_dd of=/dev/scd0 obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
  3.13% done, estimate finish Tue Apr 10 15:12:18 2012
  6.26% done, estimate finish Tue Apr 10 15:12:02 2012
  9.39% done, estimate finish Tue Apr 10 15:11:57 2012
/dev/scd0: "Current Write Speed" is 8.2x1352KBps.
:-[ WRITE@LBA=0h failed with SK=3h/POWER CALIBRATION AREA ERROR]: Input/output error
:-( write failed: Input/output error

real    0m30.381s
user    0m0.001s
sys     0m0.108s


# time growisofs -Z /dev/scd0 -R -J -speed=9 /test/x/ 
Executing 'mkisofs -R -J /test/x/ | builtin_dd of=/dev/scd0 obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
  3.13% done, estimate finish Tue Apr 10 15:14:37 2012
  6.26% done, estimate finish Tue Apr 10 15:14:37 2012
  9.39% done, estimate finish Tue Apr 10 15:14:37 2012
/dev/scd0: "Current Write Speed" is 6.1x1352KBps.
 12.52% done, estimate finish Tue Apr 10 15:19:40 2012
 15.64% done, estimate finish Tue Apr 10 15:18:59 2012
 18.77% done, estimate finish Tue Apr 10 15:18:26 2012
 21.89% done, estimate finish Tue Apr 10 15:18:07 2012
 25.02% done, estimate finish Tue Apr 10 15:17:48 2012
 28.15% done, estimate finish Tue Apr 10 15:17:38 2012
 31.28% done, estimate finish Tue Apr 10 15:17:29 2012
 34.40% done, estimate finish Tue Apr 10 15:17:19 2012
 37.53% done, estimate finish Tue Apr 10 15:17:14 2012
 40.65% done, estimate finish Tue Apr 10 15:17:07 2012
 43.79% done, estimate finish Tue Apr 10 15:17:03 2012
 46.91% done, estimate finish Tue Apr 10 15:16:57 2012
 50.04% done, estimate finish Tue Apr 10 15:16:52 2012
 53.16% done, estimate finish Tue Apr 10 15:16:50 2012
 56.29% done, estimate finish Tue Apr 10 15:16:46 2012
 59.42% done, estimate finish Tue Apr 10 15:16:44 2012
 62.55% done, estimate finish Tue Apr 10 15:16:41 2012
 65.67% done, estimate finish Tue Apr 10 15:16:40 2012
 68.80% done, estimate finish Tue Apr 10 15:16:37 2012
 71.92% done, estimate finish Tue Apr 10 15:16:36 2012
 75.06% done, estimate finish Tue Apr 10 15:16:34 2012
 78.18% done, estimate finish Tue Apr 10 15:16:33 2012
 81.31% done, estimate finish Tue Apr 10 15:16:31 2012
 84.43% done, estimate finish Tue Apr 10 15:16:30 2012
 87.56% done, estimate finish Tue Apr 10 15:16:28 2012
 90.69% done, estimate finish Tue Apr 10 15:16:27 2012
 93.82% done, estimate finish Tue Apr 10 15:16:31 2012
 96.94% done, estimate finish Tue Apr 10 15:16:29 2012
Total translation table size: 0
Total rockridge attributes bytes: 251
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
159901 extents written (312 MB)
builtin_dd: 159904*2KB out @ average 2.0x1352KBps
/dev/scd0: flushing cache
/dev/scd0: closing track
/dev/scd0: closing session
/dev/scd0: reloading tray

real    2m32.090s
user    0m0.097s
sys     0m0.808s

<REMOVE & REPLUG USB-SATA Bridge>

# time growisofs -Z /dev/scd0 -R -J -speed=10 /test/x/ 
Executing 'mkisofs -R -J /test/x/ | builtin_dd of=/dev/scd0 obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
  3.13% done, estimate finish Tue Apr 10 15:20:10 2012
  6.26% done, estimate finish Tue Apr 10 15:20:10 2012
  9.39% done, estimate finish Tue Apr 10 15:20:10 2012
/dev/scd0: "Current Write Speed" is 8.2x1352KBps.
:-( unable to WRITE@LBA=0h: Input/output error
:-( write failed: Input/output error

real    1m22.156s
user    0m0.004s
sys     0m0.105s

# sg_inq /dev/scd0
standard INQUIRY:
  PQual=0  Device_type=5  RMB=1  version=0x00  [no conformance claimed]
  [AERC=0]  [TrmTsk=0]  NormACA=1  HiSUP=1  Resp_data_format=3
  SCCS=0  ACC=0  TPGS=0  3PC=0  Protect=0  BQue=0
  EncServ=0  MultiP=0  [MChngr=0]  [ACKREQQ=0]  Addr16=0
  [RelAdr=0]  WBus16=0  Sync=0  Linked=0  [TranDis=0]  CmdQue=0
  [SPI: Clocking=0x0  QAS=0  IUS=0]
    length=96 (0x60)   Peripheral device type: cd/dvd
 Vendor identification: TEAC    
 Product identification: DV-W28SS-R      
 Product revision level: 1.0C

So, the first time it worked (at 8x), but after that, only 6x is a safe speed.

In the messages, i got:

Apr 10 15:18:29 test9 kernel: usb 1-1: new high speed USB device using ehci_hcd and address 4
Apr 10 15:18:29 test9 kernel: usb 1-1: configuration #1 chosen from 1 choice
Apr 10 15:18:29 test9 kernel: scsi12 : SCSI emulation for USB Mass Storage devices
Apr 10 15:18:34 test9 kernel:   Vendor: TEAC      Model: DV-W28SS-R        Rev: 1.0C
Apr 10 15:18:34 test9 kernel:   Type:   CD-ROM                             ANSI SCSI revision: 00
Apr 10 15:18:34 test9 kernel: sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda caddy
Apr 10 15:18:34 test9 kernel: sr 12:0:0:0: Attached scsi generic sg1 type 5
Apr 10 15:21:11 test9 kernel: usb 1-1: reset high speed USB device using ehci_hcd and address 4
Apr 10 15:21:21 test9 kernel: usb 1-1: reset high speed USB device using ehci_hcd and address 4
Apr 10 15:21:29 test9 kernel: sr 12:0:0:0: timing out command, waited 60s

I got:
* WRITE@LBA=0h failed with SK=3h/POWER CALIBRATION AREA ERROR
* unable to WRITE@LBA=0h: Input/output error

The last one, seems to caused the USB-SATA Bridge to disconnect & reset.
Comment 9 Honza Horak 2012-04-12 08:28:45 EDT
Well, it seems like a hardware issue for me. You can try other burning utilities like cdrskin (in package libburn) or Nero for Linux to see if there is a difference. For similar issues a new cable or a firmware update helps sometimes and you can also try different media type.

Some more advice are at: 
http://forums.fedoraforum.org/showthread.php?t=243268
Comment 10 Reartes Guillermo 2012-04-13 19:28:50 EDT
Actually, it appears to be specific to the writer model DV-W28SS-R (i have more than one of them). This writer needs patch to write twice (see 799299), so maybe it still needs more patching. Maybe the blktraces might reveal something different between the DV-W28SS-R and the DV-W28SS-V.

It also very reproductible with DVD+R media id: MMC/003 and MMC/004

Also i reproduced the issue with CDBurnerXP, both the power calibration and the usb disconnection.

Currently, the only workaround is to use a lower speed, like 6x or the lowest speed, just to be sure. Or use a beter queality media. 

Also, by insisting, growisofs might write the disc, or disconnect the usb-sata bridge (happened with 3 different bridges 2xsunplus 1xjmicron). It seeems that before the disconnection, something happens. The correct behaviour should be keep outputing the error or print another but not disconnect the bridges. (the issue itself does not requiere usb to happen, since it happens directly attaching the writer to a sata controller.
Comment 11 Honza Horak 2012-04-23 11:20:01 EDT
There is another build, that fixes a similar issue (actually the bug #810483) available in testing updates or here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=314370

However, I don't believe the fix can solve your issue, but you can give it a try.
Comment 12 Honza Horak 2012-09-18 05:45:16 EDT
I tried to google for such error messages and it seems it is not problem only in dvd+rw-tools, which corresponds with your last comment, as you reproduced it with CDBurnerXP too.

The cause given is mostly incompatibility between media and drive or simply cheap media. A working solution then could be to use another media or lower speed, as you did.

I'm going to mention that error in documentation, but for now closing this bug, since it seems dvd+rw-tools doesn't do anything wrong.

Note You need to log in before you can comment on or make changes to this bug.