Bug 810919 - Monitor Overview Page - Instance and Application numbers are not updated with page refresh
Monitor Overview Page - Instance and Application numbers are not updated with...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Tzu-Mainn Chen
Rehana
: Triaged, ZStream
Depends On:
Blocks: 859451 824101
  Show dependency treegraph
 
Reported: 2012-04-09 12:05 EDT by Ronelle Landy
Modified: 2012-12-04 10:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The application and instance count on the “Monitor Overview” page did not update in real-time when a user deleted an application. This update adds real-time updates to the application and instance count in "Monitor Overview".
Story Points: ---
Clone Of: 824101
: 824101 859451 (view as bug list)
Environment:
Last Closed: 2012-12-04 10:03:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot1 - 100 Instances/Applications in CRZ Heading (129.23 KB, image/png)
2012-04-09 12:05 EDT, Ronelle Landy
no flags Details
Screenshot2 - 101 Instances/Applications showing in Heading (223.68 KB, image/png)
2012-04-09 12:06 EDT, Ronelle Landy
no flags Details
conductor/pools before application is deleted (84.21 KB, image/png)
2012-09-21 11:09 EDT, Ronelle Landy
no flags Details
/conductor/pools after the app is deleted (82.49 KB, image/png)
2012-09-21 11:10 EDT, Ronelle Landy
no flags Details
details page - before delete (60.00 KB, image/png)
2012-09-21 11:11 EDT, Ronelle Landy
no flags Details
details page after delete (76.36 KB, image/png)
2012-09-21 11:11 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-04-09 12:05:30 EDT
Created attachment 576249 [details]
Screenshot1 - 100 Instances/Applications in CRZ Heading

Description of problem:
I have two browsers pointing at the same Conductor instance - both open to the Monitor Overview page: /conductor/pools. There are 101 instances running.

 - Using one browser, I stop the first of the 101 instances. After a few minutes I check the second browser. The instance is shown as stopped in the second browse - all good so far.

 - Now I go back to the first browser, to the conductor/deployments page and delete the second entry (deployment) and later the third. After a few minutes I check the second browser (still pointing at conductor/pools). This browser does not show the deleted instances but the *number* of Applications and *Instances* listed in the Cloud Resource Zone heading is not updated and still shows 101 Applications and 101 Instances. (see attached screenshots). 


Steps to Reproduce:
1. Open two browsers pointing at the same Conductor instance - both open to the Monitor Overview page: /conductor/pools
2. Using one browser, navigate to the conductor/deployments page
3. Delete one deployment
4. In the same browser navigate to the conductor/pools page - see that the deleted instance is no longer visible and the number of Instances and Applications has been updated (see screenshot 1)
5. Go to the second browser. See that the deleted instance is not showing but the number of Instances and Applications is not updated. (see screenshot 2)
  
rpms tested:

rpm -qa |grep aeolus
aeolus-conductor-daemons-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
Comment 1 Ronelle Landy 2012-04-09 12:06:24 EDT
Created attachment 576255 [details]
Screenshot2 - 101 Instances/Applications showing in Heading
Comment 3 Tzu-Mainn Chen 2012-05-21 11:20:32 EDT
Patch created:

https://fedorahosted.org/pipermail/aeolus-devel/2012-May/010487.html
Comment 4 Tzu-Mainn Chen 2012-05-22 13:05:31 EDT
Patch pushed to master:

commit 5c54d1dbc08a30ed4d5f14a7d628a156f3ca1141
BZ810919 mustach-ify pretty-view pool header so that instance/deployment counts are automatically updated
Comment 6 Tzu-Mainn Chen 2012-05-23 10:50:30 EDT
cloned to 824101

*** This bug has been marked as a duplicate of bug 824101 ***
Comment 10 Ronelle Landy 2012-09-21 11:08:28 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

Applications numbers do update when both of the two browsers are pointing at /conductor/pools (see screenshots attached: BeforeDelete.png and AfterDelete.png)

Application numbers do not update when the second browser (the one not involved in deleting the app) is pointing at the details page /conductor/pools/1 (see attached screenshots 28Apps.png and still8_apps.png
Comment 11 Ronelle Landy 2012-09-21 11:09:20 EDT
Created attachment 615478 [details]
conductor/pools before application is deleted
Comment 12 Ronelle Landy 2012-09-21 11:10:22 EDT
Created attachment 615479 [details]
/conductor/pools after the app is deleted
Comment 13 Ronelle Landy 2012-09-21 11:11:00 EDT
Created attachment 615480 [details]
details page - before delete
Comment 14 Ronelle Landy 2012-09-21 11:11:28 EDT
Created attachment 615481 [details]
details page after delete
Comment 15 Ronelle Landy 2012-09-21 11:13:15 EDT
Marking this BZ as 'verified' and opening an other BZ for the details page.
Comment 17 errata-xmlrpc 2012-12-04 10:03:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.