This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 811030 - virt-manager should %ifarch spice support
virt-manager should %ifarch spice support
Status: CLOSED DUPLICATE of bug 613529
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 18:42 EDT by David Aquilina
Modified: 2014-06-23 20:19 EDT (History)
8 users (show)

See Also:
Fixed In Version: virt-manager-0.9.1-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-21 15:08:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-manager.spec patch (703 bytes, patch)
2012-04-09 18:43 EDT, David Aquilina
no flags Details | Diff
Correct spec file patch (422 bytes, patch)
2012-04-23 15:32 EDT, David Aquilina
no flags Details | Diff

  None (edit)
Description David Aquilina 2012-04-09 18:42:42 EDT
Description of problem:

The spice-gtk package is only available on x86/x86_64, and so this prevents virt-manager from being installable on other architectures such as ppc64. 

Since spice support is only a define in the virt-manager spec, it should be ifarch'd to only be enabled on architectures where spice-gtk is available. 

Patch attached has been tested to build, and the resulting virt-manager RPM does not require spice-gtk: 

[dwa@ppc-hub task_485663]$ rpm -q --requires -p virt-manager-0.9.1-2.dwa.fc17.noarch.rpm  | grep spice
[dwa@ppc-hub task_485663]$
Comment 1 David Aquilina 2012-04-09 18:43:37 EDT
Created attachment 576323 [details]
virt-manager.spec patch
Comment 2 David Aquilina 2012-04-23 15:32:35 EDT
Created attachment 579672 [details]
Correct spec file patch

Realized I had attached an older version of the patch (mis-capitalized %ifarch).
Comment 3 Fedora Update System 2012-04-25 09:56:44 EDT
virt-manager-0.9.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.1-3.fc17
Comment 4 Fedora Update System 2012-04-26 15:26:25 EDT
Package virt-manager-0.9.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6651/virt-manager-0.9.1-3.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-05-02 16:51:57 EDT
virt-manager-0.9.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jeff Raber 2012-05-29 23:57:36 EDT
The spice-gtk-python package dependency is no longer being pulled in for x86_64. See bug 819270
Comment 7 Cole Robinson 2012-06-06 17:23:49 EDT
Have to reopen this, as mentioned in Comment #6. Basically there is no way for a noarch package to have dependencies conditional on the install architecture.

In RHEL we fixed this by making virt-manager archful, but honestly I'm not motivated to do that here. The correct solution would be to have spice get it's act together and make itself available itself on ppc.
Comment 8 Cole Robinson 2012-10-21 15:08:03 EDT
Closing this as a dup of the spice ExclusiveArch bug

*** This bug has been marked as a duplicate of bug 613529 ***

Note You need to log in before you can comment on or make changes to this bug.