Bug 811066 - Warnings running broker scripts from command line
Warnings running broker scripts from command line
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Kubernetes (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Triaged
: 822769 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 22:25 EDT by Mike McGrath
Modified: 2015-05-14 21:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McGrath 2012-04-09 22:25:03 EDT
Description of problem:
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/application.rb:15: warning: already initialized constant APP_NAME_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/application.rb:16: warning: already initialized constant NAMESPACE_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/application.rb:17: warning: already initialized constant UNSCALABLE_FRAMEWORKS
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/application.rb:18: warning: already initialized constant SCALABLE_EMBEDDED_CARTS
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/cloud_user.rb:8: warning: already initialized constant DEFAULT_SSH_KEY_NAME
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/legacy_reply.rb:4: warning: already initialized constant API_VERSION
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/legacy_reply.rb:5: warning: already initialized constant API_CAPABILITY
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/legacy_reply.rb:6: warning: already initialized constant C_CAPABILITY
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/legacy_request.rb:5: warning: already initialized constant APP_NAME_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/legacy_request.rb:6: warning: already initialized constant NAMESPACE_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/validators/key_validator.rb:2: warning: already initialized constant KEY_NAME_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/validators/key_validator.rb:3: warning: already initialized constant KEY_NAME_MIN_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/validators/namespace_validator.rb:2: warning: already initialized constant NAMESPACE_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.8.5/lib/stickshift-controller/app/models/validators/namespace_validator.rb:3: warning: already initialized constant NAMESPACE_MIN_LENGTH
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader

Just causes extra scroll during tests.
Comment 1 Dan McPherson 2012-05-29 13:08:29 EDT
*** Bug 822769 has been marked as a duplicate of this bug. ***
Comment 2 Abhishek Gupta 2012-06-15 21:57:51 EDT
Fixed and waiting for merge
https://github.com/openshift/crankcase/pull/136
Comment 3 Xiaoli Tian 2012-06-19 06:15:48 EDT
Tested this on devenv_1857, run any of the admin scripts or unit testing, no warning messages now.

rhc-admin-ctl-usage --list
Gear usage not found for user: xtian+b100@redhat.com
Done

[root@ip-10-196-62-88 functional]# ruby billing_events_test.rb 
Loaded suite billing_events_test
Started
.
Finished in 1.01509 seconds.

Note You need to log in before you can comment on or make changes to this bug.