Bug 822769 - Warning message is seen while running rhc-admin-* commands
Warning message is seen while running rhc-admin-* commands
Status: CLOSED DUPLICATE of bug 811066
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Krishna Raman
libra bugs
: Triaged
: 824772 825901 825905 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 01:51 EDT by Johnny Liu
Modified: 2015-05-14 21:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 13:08:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-05-18 01:51:14 EDT
Description of problem:
When running rhc-admin-ctl-district command, some warning is always printed out. 

# rhc-admin-ctl-district
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.11.2/lib/stickshift-controller/app/models/cloud_user.rb:8: warning: already initialized constant DEFAULT_SSH_KEY_NAME
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.11.2/lib/stickshift-controller/app/models/validators/key_validator.rb:2: warning: already initialized constant KEY_NAME_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.11.2/lib/stickshift-controller/app/models/validators/key_validator.rb:3: warning: already initialized constant KEY_NAME_MIN_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.11.2/lib/stickshift-controller/app/models/validators/namespace_validator.rb:2: warning: already initialized constant NAMESPACE_MAX_LENGTH
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.11.2/lib/stickshift-controller/app/models/validators/namespace_validator.rb:3: warning: already initialized constant NAMESPACE_MIN_LENGTH
No districts created yet.  Use 'rhc-admin-ctl-district -c create' to create one.


Version-Release number of selected component (if applicable):
devenv_1780

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Xiaoli Tian 2012-05-29 00:40:45 EDT
*** Bug 824772 has been marked as a duplicate of this bug. ***
Comment 2 Xiaoli Tian 2012-05-29 00:41:43 EDT
*** Bug 825905 has been marked as a duplicate of this bug. ***
Comment 3 Xiaoli Tian 2012-05-29 00:41:53 EDT
*** Bug 825901 has been marked as a duplicate of this bug. ***
Comment 4 Xiaoli Tian 2012-05-29 00:45:44 EDT
Almost all admin commands will meet warning messages above like: 
rhc-admin-ctl-user, rhc-admin-ctl-district, rhc-admin-ctl-domain etc. and migration scripts.
Comment 5 Dan McPherson 2012-05-29 13:08:29 EDT

*** This bug has been marked as a duplicate of bug 811066 ***

Note You need to log in before you can comment on or make changes to this bug.