Bug 811159 - [abrt] python-cups-1.9.61-1.fc17: __GI_fileno: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] python-cups-1.9.61-1.fc17: __GI_fileno: Process /usr/bin/python was ki...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-cups (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:85481db58335e05110db4d094cd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 06:08 EDT by Jiri Popelka
Modified: 2012-04-18 19:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-cups-1.9.61-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 19:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.38 KB, text/plain)
2012-04-10 06:08 EDT, Jiri Popelka
no flags Details
File: maps (20.00 KB, text/plain)
2012-04-10 06:08 EDT, Jiri Popelka
no flags Details
File: dso_list (4.35 KB, text/plain)
2012-04-10 06:08 EDT, Jiri Popelka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 951001 None None None Never

  None (edit)
Description Jiri Popelka 2012-04-10 06:08:45 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/lib/rpm/postscriptdriver.prov
comment:        Everytime I locally build some "printing" package, e.g. foomatic, hplip, splix.
crash_function: __GI_fileno
executable:     /usr/bin/python
kernel:         3.3.1-3.fc17.x86_64
pid:            20920
pwd:            /home/jpopelka/FEDORA_GIT/foomatic
remote_result:  NOTFOUND
time:           Tue 10 Apr 2012 11:57:38 AM CEST
uid:            1000
username:       jpopelka
var_log_messages: Apr 10 11:57:38 zepelin abrt[20933]: Saved core dump of pid 20920 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-04-10-11:57:38-20920 (5300224 bytes)

backtrace:      Text file, 34177 bytes
dso_list:       Text file, 4453 bytes
maps:           Text file, 20484 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/jpopelka/1

core_backtrace:
:11d196ee9220c6039404f4ba675abf3a24d8f0aa 0x737b0 fileno_unlocked libc.so.6 -
:94f1c0b450228e30c5ae12cec3b3e8d2916ed589 0x139fd - cups.so -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x9c950 - libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x49a1e PyObject_Call libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xd877c PyEval_EvalFrameEx libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xdaf59 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xdaf59 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xdc7c1 PyEval_EvalCodeEx libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x6d2bb - libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x49a1e PyObject_Call libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x57ef0 - libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x49a1e PyObject_Call libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xd6097 PyEval_CallObjectWithKeywords libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x58bfa PyInstance_New libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x49a1e PyObject_Call libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xd877c PyEval_EvalFrameEx libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xdc7c1 PyEval_EvalCodeEx libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xdc892 PyEval_EvalCode libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xf566a - libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xf6422 PyRun_FileExFlags libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0xf6dfb PyRun_SimpleFileExFlags libpython2.7.so.1.0 -
:4743afc0117cda9819d571cd9d0f6f368ac043b6 0x107b72 Py_Main libpython2.7.so.1.0 -

environ:
:XDG_VTNR=1
:GIT_PS1_SHOWDIRTYSTATE=1
:KDE_MULTIHEAD=false
:SSH_AGENT_PID=1793
:XDG_SESSION_ID=1
:HOSTNAME=zepelin.brq.redhat.com
:DM_CONTROL=/var/run/xdmctl
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:TERM=xterm
:XDM_MANAGED=method=classic
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/jpopelka/.gtkrc-2.0:/home/jpopelka/.gtkrc-2.0-kde4:/home/jpopelka/.kde/share/config/gtkrc-2.0
:KONSOLE_DBUS_SERVICE=:1.221
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/jpopelka/.gtkrc:/home/jpopelka/.kde/share/config/gtkrc
:GS_LIB=
:WINDOWID=243269653
:SHELL_SESSION_ID=9a7bb71051e54000a09f8c1f76cc964e
:KDE_FULL_SESSION=true
:USER=jpopelka
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/tmp/ssh-pCwJFnQB1759/agent.1759
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1871,unix/unix:/tmp/.ICE-unix/1871
:DESKTOP_SESSION=default
:MAIL=/var/spool/mail/jpopelka
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/jpopelka/bin
:_=/usr/bin/rpmbuild
:PWD=/home/jpopelka/FEDORA_GIT/foomatic
:EDITOR=vim
:KDE_SESSION_UID=1000
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:KONSOLE_DBUS_SESSION=/Sessions/3
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/bin/ksshaskpass
:XDG_SEAT=seat0
:HOME=/home/jpopelka
:SHLVL=4
:COLORFGBG=15;0
:LANGUAGE=
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=default
:LOGNAME=jpopelka
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-YI8IV3CwDB,guid=140f4e0c2793fbaa865c5d87000000e5
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/jpopelka
:PROFILEHOME=
:QT_PLUGIN_PATH=/home/jpopelka/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:XAUTHORITY=/tmp/kde-jpopelka/xauth-1000-_0
:RPM_BUILD_ROOT=/home/jpopelka/rpmbuild/BUILDROOT/foomatic-4.0.8-8.fc18.x86_64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31357                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31357                31357                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[408593]
:pos:	0
:flags:	00
:1:pipe:[408594]
:pos:	0
:flags:	01
:2:pipe:[402336]
:pos:	0
:flags:	01
Comment 1 Jiri Popelka 2012-04-10 06:08:49 EDT
Created attachment 576435 [details]
File: backtrace
Comment 2 Jiri Popelka 2012-04-10 06:08:51 EDT
Created attachment 576436 [details]
File: maps
Comment 3 Jiri Popelka 2012-04-10 06:08:53 EDT
Created attachment 576437 [details]
File: dso_list
Comment 4 Tim Waugh 2012-04-10 07:01:14 EDT
Expect this is due to the bug fixed upstream by 6d36a5b.
Comment 5 Jiri Popelka 2012-04-10 08:20:05 EDT
Yes, seems to be fixed now.
Comment 6 Fedora Update System 2012-04-10 12:34:55 EDT
python-cups-1.9.61-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-cups-1.9.61-2.fc17
Comment 7 Fedora Update System 2012-04-11 21:10:36 EDT
Package python-cups-1.9.61-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-cups-1.9.61-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5722/python-cups-1.9.61-2.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-04-18 19:05:31 EDT
python-cups-1.9.61-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.