Bug 811272 - Regression with ipw2200 wireless adapter in Dell Inspiron 9300
Regression with ipw2200 wireless adapter in Dell Inspiron 9300
Status: CLOSED DUPLICATE of bug 802106
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 11:14 EDT by Scott Dowdle
Modified: 2012-04-23 05:29 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 717186
Environment:
Last Closed: 2012-04-23 05:29:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2012-04-10 11:14:35 EDT
+++ This bug was initially created as a clone of Bug #717186 +++

I have been running Fedora 32-bit on my Dell Inspiron 9300 laptop for some time now and I haven't had the first bit of problem with the ipw2200 based wireless it until Fedora 17.  I upgrade my systems on the same day (or within a day or two) of when updates are made available and have been keeping up-to-date with releases.

I've tried various Fedora 17 releases thus far including the Alpha release and most recently the Beta RC3 release.  RC4 just showed up yesterday so I'll test that too ASAP.

Anyway, on all Fedora 17 builds I've tried so far the wireless is not detected and does not show up in NetworkManager.  The work around talked about in bug 717186 (filed against Fedora 15) works for me but is very inconvenient.  Somehow this regression has worked its way into the kernel or the various wireless support packages... not sure which.  It would be nice if this were fixed before final release.

Kernel versions that worked... any kernel in Fedora 16 and 15.   Kernels that don't work, every kernel I've tried in Fedora 17 including the release provided by Beta RC3 which is 3.3.0-1.fc17.i686.

If anyone can give me any suggestions on how to better gather information for troubleshooting, I'll put in the time as long as it is within my technical abilities.
Comment 1 Josh Boyer 2012-04-10 13:12:45 EDT
I'm not sure we really need a cloned bug for this, but I'll let John and Stanislaw decide what to do here.
Comment 2 Scott Dowdle 2012-04-10 23:28:35 EDT
Just wanted to mention that I tried the Fedora 17 Beta RC4 build from yesterday and it has the same behavior... no wireless card shows in Network Manager.
Comment 3 Scott Dowdle 2012-04-14 10:49:14 EDT
Same results on a Dell Latitude D600 (Pentium D) laptop.  The removing the
module and then modprobing it makes it work.
Comment 4 Stanislaw Gruszka 2012-04-23 05:29:58 EDT

*** This bug has been marked as a duplicate of bug 802106 ***

Note You need to log in before you can comment on or make changes to this bug.