This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 811329 - self heal - dirty afr flags after successfull stat: the regular non-empty file two equally dirty servers case
self heal - dirty afr flags after successfull stat: the regular non-empty fil...
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.2.6
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 13:53 EDT by Rodrigo Severo
Modified: 2014-12-14 14:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-14 14:40:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodrigo Severo 2012-04-10 13:53:18 EDT
Description of problem:
A regular non-empty file with dirty flags with the same values on two server stats successfully but remain with dirty AFR flags.

Version-Release number of selected component (if applicable):
All this has been tested with Gluster 3.2.6
I mentioned 3.2.5 at "Version(s)" above for the lack of 3.2.6 option on the
dropbox.

How reproducible:
Always

Steps to Reproduce:
1.# getfattr -d -m . -h -e hex '/brick/restrito-2/FINANCEIRO/Laura.gnumeric'
getfattr: Removing leading '/' from absolute path names
# file: brick/restrito-2/FINANCEIRO/Laura.gnumeric
trusted.afr.restrito-client-0=0x000000000200000000000000
trusted.afr.restrito-client-1=0x000000000200000000000000
trusted.gfid=0x89dec680f7ef4ea2b02bde2ea27ee204
2.# getfattr -d -m . -h -e hex '/brick/restrito-1/FINANCEIRO/Laura.gnumeric'
getfattr: Removing leading '/' from absolute path names
# file: brick/restrito-1/FINANCEIRO/Laura.gnumeric
trusted.afr.restrito-client-0=0x000000000200000000000000
trusted.afr.restrito-client-1=0x000000000200000000000000
trusted.gfid=0x89dec680f7ef4ea2b02bde2ea27ee204
3.# stat "/mnt/temp/01 FABRICA/Administrativo/FINANCEIRO/Acerto Socios/Laura.gnumeric"
  File: `/mnt/temp/FINANCEIRO/Laura.gnumeric'
  Size: 3437            Blocks: 16         IO Block: 131072 regular file
Device: 16h/22d Inode: 18446744070801506354  Links: 1
Access: (0660/-rw-rw----)  Uid: ( XXX/xxx)   Gid: ( GGG/  ggg)
Access: 2012-03-30 15:46:18.143513039 -0300
Modify: 2012-03-30 15:46:18.153513039 -0300
Change: 2012-03-30 15:46:18.173513039 -0300
 Birth: -
  
Actual results:
AFR flags remain dirty after successfull stat.

Expected results:
Cleaned AFR flags

Additional info:
This might be a duplicate of bug #811244, of bug #811250 and of bug #811317, please advise.
This might be related to the stat-prefetch issue mentioned by Jeff Darcy at
https://bugzilla.redhat.com/show_bug.cgi?id=764232#c14
Comment 1 Amar Tumballi 2012-07-11 01:08:48 EDT
Rodrigo, Can you please try with 3.3.0 release, and see if its fixed for you?
Comment 2 Pranith Kumar K 2012-07-24 09:14:13 EDT
Rodrigo,
    Could you let us know the steps you took that lead the file into this state.

Pranith.
Comment 3 Niels de Vos 2014-11-27 09:54:52 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.

Note You need to log in before you can comment on or make changes to this bug.