Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 811472 - zebra can't start due to selinux denial
Summary: zebra can't start due to selinux denial
Keywords:
Status: CLOSED DUPLICATE of bug 811351
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 811474 (view as bug list)
Depends On:
Blocks: 816135
TreeView+ depends on / blocked
 
Reported: 2012-04-11 08:06 UTC by Martin Cermak
Modified: 2012-04-25 10:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-11 08:31:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Cermak 2012-04-11 08:06:21 UTC
Description of problem:

  One of quagga's services, zebra, can't start due to selinux denial:

type=AVC msg=audit(1334131296.069:829): avc:  denied  { read } for  pid=24075 comm="zebra" name="passwd" dev="dm-1" ino=25148 scontext=system_u:system_r:zebra_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file
type=SYSCALL msg=audit(1334131296.069:829): arch=c000003e syscall=2 success=no exit=-13 a0=7f96d25406ca a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=24075 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="zebra" exe="/usr/sbin/zebra" subj=system_u:system_r:zebra_t:s0 key=(null)


Version-Release number of selected component (if applicable):

# rpm -q quagga selinux-policy kernel
quagga-0.99.20.1-1.fc17.x86_64
selinux-policy-3.10.0-110.fc17.noarch
kernel-3.3.0-0.rc3.git7.2.fc17.x86_64
kernel-3.3.0-8.fc17.x86_64
kernel-3.3.1-3.fc17.x86_64

How reproducible:

Always

Steps to Reproduce:

systemctl start zebra.service

Comment 1 Martin Cermak 2012-04-11 08:07:49 UTC
# service zebra status
...
Apr 11 04:04:57 dhcp-25-124.brq.redhat.com zebra[24102]: privs_init: could not lookup user quagga

Comment 2 Miroslav Grepl 2012-04-11 08:31:50 UTC

*** This bug has been marked as a duplicate of bug 811351 ***

Comment 3 Miroslav Grepl 2012-04-11 08:55:53 UTC
*** Bug 811474 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.