Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 811474 - ripngd can't start due to selinux denial
Summary: ripngd can't start due to selinux denial
Keywords:
Status: CLOSED DUPLICATE of bug 811472
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 816135
TreeView+ depends on / blocked
 
Reported: 2012-04-11 08:18 UTC by Martin Cermak
Modified: 2012-04-25 10:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-11 08:55:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Cermak 2012-04-11 08:18:05 UTC
Description of problem:

  One of quagga's services, ringpd, can't start due to selinux denial:

type=AVC msg=audit(1334131997.759:849): avc:  denied  { read } for  pid=26338 comm="ripngd" name="passwd" dev="dm-1" ino=25148 scontext=system_u:system_r:zebra_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file
type=SYSCALL msg=audit(1334131997.759:849): arch=c000003e syscall=2 success=no exit=-13 a0=7f27a7af66ca a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=26338 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ripngd" exe="/usr/sbin/ripngd" subj=system_u:system_r:zebra_t:s0 key=(null)


Version-Release number of selected component (if applicable):

# rpm -q quagga selinux-policy kernel
quagga-0.99.20.1-1.fc17.x86_64
selinux-policy-3.10.0-110.fc17.noarch
kernel-3.3.0-0.rc3.git7.2.fc17.x86_64
kernel-3.3.0-8.fc17.x86_64
kernel-3.3.1-3.fc17.x86_64

How reproducible:

Always

Steps to Reproduce:

systemctl start ringpd.service

Note:

Service status says: ripngd[26338]: privs_init: could not lookup user quagga

Comment 1 Martin Cermak 2012-04-11 08:36:37 UTC
Similar issue found using ripd:

type=AVC msg=audit(1334133033.280:861): avc:  denied  { getattr } for  pid=28705 comm="ripd" path="/etc/passwd" dev="dm-1" ino=25148 scontext=system_u:system_r:zebra_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file
type=SYSCALL msg=audit(1334133033.280:861): arch=c000003e syscall=5 success=yes exit=0 a0=4 a1=7fff98aaf760 a2=7fff98aaf760 a3=0 items=0 ppid=1 pid=28705 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ripd" exe="/usr/sbin/ripd" subj=system_u:system_r:zebra_t:s0 key=(null)


Similar issue found using ospfd:

type=AVC msg=audit(1334133141.846:867): avc:  denied  { read } for  pid=29630 comm="ospfd" name="passwd" dev="dm-1" ino=25148 scontext=system_u:system_r:zebra_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file
type=SYSCALL msg=audit(1334133141.846:867): arch=c000003e syscall=2 success=no exit=-13 a0=7f9df12f46ca a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=29630 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ospfd" exe="/usr/sbin/ospfd" subj=system_u:system_r:zebra_t:s0 key=(null)


Similar issue found using ospf6d:

type=AVC msg=audit(1334133236.855:869): avc:  denied  { read } for  pid=30079 comm="ospf6d" name="passwd" dev="dm-1" ino=25148 scontext=system_u:system_r:zebra_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file
type=SYSCALL msg=audit(1334133236.855:869): arch=c000003e syscall=2 success=no exit=-13 a0=7f82f29746ca a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=30079 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ospf6d" exe="/usr/sbin/ospf6d" subj=system_u:system_r:zebra_t:s0 key=(null)


Similar issue found using bgpd:

type=AVC msg=audit(1334133373.530:879): avc:  denied  { read } for  pid=31481 comm="bgpd" name="passwd" dev="dm-1" ino=25148 scontext=system_u:system_r:zebra_t:s0 tcontext=system_u:object_r:passwd_file_t:s0 tclass=file
type=SYSCALL msg=audit(1334133373.530:879): arch=c000003e syscall=2 success=no exit=-13 a0=7f54f7b186ca a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=31481 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="bgpd" exe="/usr/sbin/bgpd" subj=system_u:system_r:zebra_t:s0 key=(null)

Comment 2 Miroslav Grepl 2012-04-11 08:55:53 UTC

*** This bug has been marked as a duplicate of bug 811472 ***


Note You need to log in before you can comment on or make changes to this bug.