Bug 811678 - Problems with clickpad on Lenovo Thinkpad X220
Problems with clickpad on Lenovo Thinkpad X220
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
17
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 13:09 EDT by Anish Mangal
Modified: 2012-05-07 00:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-synaptics-1.6.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 00:15:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anish Mangal 2012-04-11 13:09:04 EDT
Description of problem:
The clickpad on the lenovo thinkpad x220 laptop, which has integrated mouse buttons, is buggy with the following problems:

1. Right click doesnt work, instead when I press the right click 'area', a left click happens.
2. While left clicking, the mouse pointer also moves on the screen. i.e. I cannot click and drag reliably using the clickpad

Version-Release number of selected component (if applicable):

Fedora-16 (Fresh install as well as latest updated.)
Fedora-17

How reproducible:

100%

Steps to Reproduce:
Mentioned above


  
Actual results:
N.A.

Expected results:
N.A.

Additional info:
The same clickpad works flawlessly with Ubuntu-12.04 final beta. Apparently they have incorporated some customizations to the touchpad configuration.
Comment 1 Fedora Update System 2012-04-16 03:01:44 EDT
xorg-x11-drv-synaptics-1.5.99.903-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-1.fc17
Comment 2 Fedora Update System 2012-04-16 17:57:51 EDT
Package xorg-x11-drv-synaptics-1.5.99.903-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.5.99.903-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5995/xorg-x11-drv-synaptics-1.5.99.903-1.fc17
then log in and leave karma (feedback).
Comment 3 Anish Mangal 2012-04-17 12:39:06 EDT
(In reply to comment #2)
> Package xorg-x11-drv-synaptics-1.5.99.903-1.fc17:
> * should fix your issue,
> * was pushed to the Fedora 17 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing
> xorg-x11-drv-synaptics-1.5.99.903-1.fc17'
> as soon as you are able to.
> Please go to the following url:
> https://admin.fedoraproject.org/updates/FEDORA-2012-5995/xorg-x11-drv-synaptics-1.5.99.903-1.fc17
> then log in and leave karma (feedback).

Is there one available for f16 as well. I don't wanna migrate to a different version of OS just to test this, or install packages that might break deps.
Comment 4 Andrew Hutchings 2012-04-18 09:15:13 EDT
not only does this update not fix the clickpad for me, it breaks scrolling on it as seen in bug 813686.
Comment 5 Fedora Update System 2012-04-18 23:33:46 EDT
xorg-x11-drv-synaptics-1.5.99.903-2.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-2.20120419git11d892964.fc17
Comment 6 Andrew Hutchings 2012-04-19 00:45:59 EDT
autoscroll fixed but no change in clickpad behaviour.  Is there an option I'm missing somewhere?
Comment 7 Andrew Hutchings 2012-04-19 01:07:04 EDT
ignore me, it does work, just need to do:
synclient RightButtonAreaLeft=3300 RightButtonAreaTop=3999

awesome stuff :)
Comment 8 Andrew Hutchings 2012-04-19 01:21:01 EDT
Can we also have this commit in /usr/share/X11/xorg.conf.d/50-synaptics.conf please:

http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/commit/?id=b6779458bcdb049480310ba1acb3991ad061ffc7

Thanks again :)
Comment 9 Anish Mangal 2012-04-19 02:52:20 EDT
Can we also have this backported to f16 ;-)
Comment 10 Peter Hutterer 2012-04-19 03:02:40 EDT
.conf file is updated, builds coming up in a tick.

I don't think I'll be able to backport this to F16 since it requires some of the multitouch bits only found in server 1.12 (F17). sorry.
Comment 11 Fedora Update System 2012-04-19 03:05:41 EDT
xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc17
Comment 12 Anish Mangal 2012-04-19 03:53:43 EDT
(In reply to comment #10)
> .conf file is updated, builds coming up in a tick.
> 
> I don't think I'll be able to backport this to F16 since it requires some of
> the multitouch bits only found in server 1.12 (F17). sorry.

Okay. (Im)patiently waiting for F17 release. Will upgrade once its out.

Thanks for fixing the issue :-)
Comment 13 Andrew Hutchings 2012-04-19 09:25:05 EDT
Peter: awesome, works great.  If you were at the Openstack design summit right now I would buy you a beer for that :)
Comment 14 Peter Hutterer 2012-04-19 21:31:16 EDT
moving this to F17 since that's where the bug will be fixed. No fix for F16, sorry.
Comment 15 Fedora Update System 2012-04-24 01:54:01 EDT
xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17
Comment 16 Fedora Update System 2012-04-26 19:41:59 EDT
xorg-x11-drv-synaptics-1.5.99.904-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.904-1.fc17
Comment 17 Fedora Update System 2012-05-02 18:48:55 EDT
xorg-x11-drv-synaptics-1.6.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.0-1.fc17
Comment 18 Fedora Update System 2012-05-07 00:15:58 EDT
xorg-x11-drv-synaptics-1.6.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.