Bug 811721 - SELinux is preventing /usr/bin/python from 'getattr' accesses on the file /var/cache/jockey/check.
SELinux is preventing /usr/bin/python from 'getattr' accesses on the file /va...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:321b3c42275bd6a92f8d5ec41e2...
:
: 811571 811722 811724 811725 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 15:46 EDT by info
Modified: 2012-06-22 10:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 10:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description info 2012-04-11 15:46:18 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-3.fc16.x86_64
reason:         SELinux is preventing /usr/bin/python from 'getattr' accesses on the file /var/cache/jockey/check.
time:           Wed 11 Apr 2012 10:46:04 PM EEST

description:
:SELinux is preventing /usr/bin/python from 'getattr' accesses on the file /var/cache/jockey/check.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python should be allowed getattr access on the check file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep jockey-backend /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:var_t:s0
:Target Objects                /var/cache/jockey/check [ file ]
:Source                        jockey-backend
:Source Path                   /usr/bin/python
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.2-5.2.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-3.fc16.x86_64 #1
:                              SMP Wed Apr 4 18:08:51 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 11 Apr 2012 10:39:05 PM EEST
:Last Seen                     Wed 11 Apr 2012 10:39:05 PM EEST
:Local ID                      8feff28b-91a4-4cf0-8162-9137a0237b9a
:
:Raw Audit Messages
:type=AVC msg=audit(1334173145.685:74): avc:  denied  { getattr } for  pid=1781 comm="jockey-backend" path="/var/cache/jockey/check" dev="dm-1" ino=267891 scontext=system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1334173145.685:74): arch=x86_64 syscall=fstat success=yes exit=0 a0=8 a1=7fff7c3e2730 a2=7fff7c3e2730 a3=238 items=0 ppid=1 pid=1781 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=jockey-backend exe=/usr/bin/python subj=system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023 key=(null)
:
:Hash: jockey-backend,rtkit_daemon_t,var_t,file,getattr
:
:audit2allow
:
:#============= rtkit_daemon_t ==============
:allow rtkit_daemon_t var_t:file getattr;
:
:audit2allow -R
:
:#============= rtkit_daemon_t ==============
:allow rtkit_daemon_t var_t:file getattr;
:
Comment 1 Miroslav Grepl 2012-04-12 04:59:49 EDT
*** Bug 811722 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-12 04:59:54 EDT
*** Bug 811724 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-04-12 05:00:00 EDT
*** Bug 811725 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-04-12 05:03:16 EDT
What are you exactly doing?
Comment 5 Miroslav Grepl 2012-04-12 17:29:14 EDT
*** Bug 811571 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.