Bug 811724 - SELinux is preventing jockey-backend from 'execute' accesses on the file /usr/bin/pkcon.
SELinux is preventing jockey-backend from 'execute' accesses on the file /usr...
Status: CLOSED DUPLICATE of bug 811721
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a4baebbf156c23570cf6cbd0609...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 15:47 EDT by info
Modified: 2012-04-12 04:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 04:59:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description info 2012-04-11 15:47:40 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-3.fc16.x86_64
reason:         SELinux is preventing jockey-backend from 'execute' accesses on the file /usr/bin/pkcon.
time:           Wed 11 Apr 2012 10:47:27 PM EEST

description:
:SELinux is preventing jockey-backend from 'execute' accesses on the file /usr/bin/pkcon.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that jockey-backend should be allowed execute access on the pkcon file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep jockey-backend /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:bin_t:s0
:Target Objects                /usr/bin/pkcon [ file ]
:Source                        jockey-backend
:Source Path                   jockey-backend
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           PackageKit-0.6.21-2.fc16.x86_64
:Target RPM Packages           PackageKit-0.6.21-2.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-3.fc16.x86_64 #1
:                              SMP Wed Apr 4 18:08:51 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Wed 11 Apr 2012 10:38:54 PM EEST
:Last Seen                     Wed 11 Apr 2012 10:39:04 PM EEST
:Local ID                      5947521f-f591-4a6a-89d9-9fae752405ec
:
:Raw Audit Messages
:type=AVC msg=audit(1334173144.844:71): avc:  denied  { execute } for  pid=2053 comm="jockey-backend" name="pkcon" dev="dm-1" ino=142206 scontext=system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
:
:
:type=AVC msg=audit(1334173144.844:71): avc:  denied  { read open } for  pid=2053 comm="jockey-backend" name="pkcon" dev="dm-1" ino=142206 scontext=system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
:
:
:type=AVC msg=audit(1334173144.844:71): avc:  denied  { execute_no_trans } for  pid=2053 comm="jockey-backend" path="/usr/bin/pkcon" dev="dm-1" ino=142206 scontext=system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1334173144.844:71): arch=x86_64 syscall=execve success=yes exit=0 a0=f9e0f0 a1=ff3da0 a2=7fff7c3e3d08 a3=20 items=0 ppid=1781 pid=2053 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pkcon exe=/usr/bin/pkcon subj=system_u:system_r:rtkit_daemon_t:s0-s0:c0.c1023 key=(null)
:
:Hash: jockey-backend,rtkit_daemon_t,bin_t,file,execute
:
:audit2allow
:
:#============= rtkit_daemon_t ==============
:allow rtkit_daemon_t bin_t:file { read execute open execute_no_trans };
:
:audit2allow -R
:
:#============= rtkit_daemon_t ==============
:allow rtkit_daemon_t bin_t:file { read execute open execute_no_trans };
:
Comment 1 Miroslav Grepl 2012-04-12 04:59:54 EDT

*** This bug has been marked as a duplicate of bug 811721 ***

Note You need to log in before you can comment on or make changes to this bug.