Bug 812141 - package repository not included when copying DVD to USB stick
package repository not included when copying DVD to USB stick
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-04-12 16:52 EDT by Kamil Páral
Modified: 2012-04-19 05:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-15 14:45:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-04-12 16:52:52 EDT
Description of problem:

I executed this command:

> $ sudo livecd-iso-to-disk --format Fedora-17-Beta-x86_64-DVD.iso /dev/sdb
> Verifying image...
> /mnt/data/iso/Fedora-17-Beta-x86_64-DVD.iso:   6fc130f583fa21eb76d2cddf4d9aea38
> Fragment sums: e22b92c4cdd5f9bf184aba6842639c68d64bc6f7c1ea6b2934ad94fdd758
> Fragment count: 20
> Press [Esc] to abort check.
> Checking: 100.0%
> 
> The media check is complete, the result is: PASS.
> 
> It is OK to use this media.
> WARNING: THIS WILL DESTROY ANY DATA ON /dev/sdb!!!
> Press Enter to continue or ctrl-c to abort
> 
> wipefs: WARNING: /dev/sdb: appears to contain 'dos' partition table
> Waiting for devices to settle...
> mke2fs 1.41.14 (22-Dec-2010)
> Filesystem label=LIVE
> OS type: Linux
> Block size=4096 (log=2)
> Fragment size=4096 (log=2)
> Stride=0 blocks, Stripe width=0 blocks
> 972944 inodes, 3888640 blocks
> 194432 blocks (5.00%) reserved for the super user
> First data block=0
> Maximum filesystem blocks=3984588800
> 119 block groups
> 32768 blocks per group, 32768 fragments per group
> 8176 inodes per group
> Superblock backups stored on blocks: 
> 	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208
> 
> Writing inode tables: done                            
> Creating journal (32768 blocks): done
> Writing superblocks and filesystem accounting information: done
> 
> This filesystem will be automatically checked every 29 mounts or
> 180 days, whichever comes first.  Use tune2fs -c or -i to override.
> Copying live image to target device.
> squashfs.img
>    130367488 100%   65.66MB/s    0:00:01 (xfer#1, to-check=0/1)
> 
> sent 130383477 bytes  received 31 bytes  52153403.20 bytes/sec
> total size is 130367488  speedup is 1.00
> Updating boot config file
> Installing boot loader
> /media/tgttmp.rUxpAs/syslinux is device /dev/sdb1
> Target device is now set up with a Live image!

I ended up with just installer copied to the USB stick, but not the package repository. This is a file listing of the stick:

.
./syslinux
./syslinux/isolinux.bin
./syslinux/boot.cat
./syslinux/vmlinuz
./syslinux/vesamenu.c32
./syslinux/memtest
./syslinux/extlinux.conf
./syslinux/ldlinux.sys
./syslinux/initrd.img
./syslinux/grub.conf
./syslinux/TRANS.TBL
./syslinux/splash.png
./syslinux/boot.msg
./lost+found
./LiveOS
./LiveOS/livecd-iso-to-disk
./LiveOS/squashfs.img

The package repository should be included.

Version-Release number of selected component (if applicable):
livecd-tools-16.10-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. livecd-iso-to-disk --format Fedora-17-Beta-x86_64-DVD.iso /dev/sdb
2. look at files at the target device, package repo not present
Comment 1 Kamil Páral 2012-04-12 16:55:14 EDT
Proposing as F17 Blocker, we have a test case [1] that says:

"The installer should not require you to configure a package repository, it should be able to install using the packages present on the USB stick."

Also also criteria [2] that says:

"The installer must be able to use all supported local and remote package source options"

To be exact, the installer is probably able to use it, it's just not included by the creator script.

[1] https://fedoraproject.org/wiki/QA:Testcase_USB_stick_DVD_litd
[2] https://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria
Comment 2 Brian Lane 2012-04-12 18:00:17 EDT
Please retest with 16.10 from updates-testing and leave karma for it, it fixes this.
Comment 3 Kamil Páral 2012-04-13 03:47:25 EDT
You mean 16.11, right?

https://admin.fedoraproject.org/updates/FEDORA-2012-3066/livecd-tools-16.11-1.fc16

I tested that and it really fixes the problem. I'm leaving this bug open until it's pushed to stable.
Comment 4 Ankur Sinha (FranciscoD) 2012-04-18 13:54:52 EDT
It isn't working for me. I've tried 16.11 on F16, and the latest koji build for F17:

[root@ankur ~]# time livecd-iso-to-disk --reset-mbr  /home/ankur/Downloads/torrents/rtorrent_completed/Fedora-17-ISOs/Fedora-17-Beta-x86_64-DVD/Fedora-17-Beta-x86_64-DVD.iso /dev/sdc1
Verifying image...
/home/ankur/Downloads/torrents/rtorrent_completed/Fedora-17-ISOs/Fedora-17-Beta-x86_64-DVD/Fedora-17-Beta-x86_64-DVD.iso:   6fc130f583fa21eb76d2cddf4d9aea38
Fragment sums: e22b92c4cdd5f9bf184aba6842639c68d64bc6f7c1ea6b2934ad94fdd758
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
/Packages found, will copy source .iso to target
Copying live image to target device.
squashfs.img
   130367488 100%   68.22MB/s    0:00:01 (xfer#1, to-check=0/1)

sent 130383477 bytes  received 31 bytes  52153403.20 bytes/sec
total size is 130367488  speedup is 1.00
Copying /home/ankur/Downloads/torrents/rtorrent_completed/Fedora-17-ISOs/Fedora-17-Beta-x86_64-DVD/Fedora-17-Beta-x86_64-DVD.iso
Fedora-17-Beta-x86_64-DVD.iso
  2484076544 100%   32.75MB/s    0:01:12 (xfer#1, to-check=0/1)

sent 2484379867 bytes  received 31 bytes  30861862.09 bytes/sec
total size is 2484076544  speedup is 1.00
Updating boot config file
Installing boot loader
Target device is now set up with a Live image!

real    2m23.436s
user    0m29.862s
sys     0m14.078s
[root@ankur ~]#
[root@ankur ~]# ls -a /run/media/ankur/LIVE/
.  ..  LiveOS  syslinux
[root@ankur ~]# df -lh
Filesystem      Size  Used Avail Use% Mounted on
rootfs           30G  8.0G   21G  29% /
devtmpfs        1.9G     0  1.9G   0% /dev
tmpfs           1.9G  952K  1.9G   1% /dev/shm
tmpfs           1.9G  1.9M  1.9G   1% /run
/dev/sda6        30G  8.0G   21G  29% /
tmpfs           1.9G     0  1.9G   0% /sys/fs/cgroup
tmpfs           1.9G     0  1.9G   0% /media
/dev/sdb3       176G  160G  7.3G  96% /mnt/Stuff
/dev/sdb1        99G   42G   52G  45% /mnt/Ankur Backup
/dev/sda2        30G   21G  7.7G  73% /mnt/Other
/dev/sdb2        21G   20G  221M  99% /mnt/NTFS Temp
/dev/sda8       206G  189G  6.6G  97% /mnt/Miscellaneous
/dev/sda5       196G  141G   46G  76% /home
/dev/sda3       510M   93M  392M  20% /boot
/dev/sdc1       3.8G  153M  3.7G   4% /run/media/ankur/LIVE
[root@ankur ~]#
Uploading (2.8KiB)...
Error Uploading: INTERNAL SERVER ERROR
[root@ankur ~]# rpm -q livecd-tools
livecd-tools-17.8-1.fc17.x86_64
[root@ankur ~]#


The coomand I've used is given in the docs here:
https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#How_to_Make_a_bootable_USB_Drive_to_Install_Fedora_instead_of_using_a_physical_DVD

If what's given in the docs doesn't work, this is Blocker IMO.
Comment 5 Ankur Sinha (FranciscoD) 2012-04-18 14:01:47 EDT
I was requested to open a new bug, since the command I've used is not the same as Kamil used here. New bug: https://bugzilla.redhat.com/show_bug.cgi?id=813905

Thanks,
Ankur

Note You need to log in before you can comment on or make changes to this bug.