Bug 813905 - livecd-iso-to-disk does not create USB correctly from a DVD image
livecd-iso-to-disk does not create USB correctly from a DVD image
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
17
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-04-18 13:59 EDT by Ankur Sinha (FranciscoD)
Modified: 2012-05-14 08:30 EDT (History)
13 users (show)

See Also:
Fixed In Version: livecd-tools-17.11-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 00:32:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from litd when passing in --format and single partition (3.28 KB, text/plain)
2012-04-18 14:14 EDT, Tim Flink
no flags Details

  None (edit)
Description Ankur Sinha (FranciscoD) 2012-04-18 13:59:31 EDT
I've been trying to create a usb stick as documented here:

https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#How_to_Make_a_bootable_USB_Drive_to_Install_Fedora_instead_of_using_a_physical_DVD

It isn't working for me. I've tried 16.11 on F16, and the latest koji build for
F17:

[root@ankur ~]# time livecd-iso-to-disk --reset-mbr 
/home/ankur/Downloads/torrents/rtorrent_completed/Fedora-17-ISOs/Fedora-17-Beta-x86_64-DVD/Fedora-17-Beta-x86_64-DVD.iso
/dev/sdc1
Verifying image...
/home/ankur/Downloads/torrents/rtorrent_completed/Fedora-17-ISOs/Fedora-17-Beta-x86_64-DVD/Fedora-17-Beta-x86_64-DVD.iso:
  6fc130f583fa21eb76d2cddf4d9aea38
Fragment sums: e22b92c4cdd5f9bf184aba6842639c68d64bc6f7c1ea6b2934ad94fdd758
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
/Packages found, will copy source .iso to target
Copying live image to target device.
squashfs.img
   130367488 100%   68.22MB/s    0:00:01 (xfer#1, to-check=0/1)

sent 130383477 bytes  received 31 bytes  52153403.20 bytes/sec
total size is 130367488  speedup is 1.00
Copying
/home/ankur/Downloads/torrents/rtorrent_completed/Fedora-17-ISOs/Fedora-17-Beta-x86_64-DVD/Fedora-17-Beta-x86_64-DVD.iso
Fedora-17-Beta-x86_64-DVD.iso
  2484076544 100%   32.75MB/s    0:01:12 (xfer#1, to-check=0/1)

sent 2484379867 bytes  received 31 bytes  30861862.09 bytes/sec
total size is 2484076544  speedup is 1.00
Updating boot config file
Installing boot loader
Target device is now set up with a Live image!

real    2m23.436s
user    0m29.862s
sys     0m14.078s
[root@ankur ~]#
[root@ankur ~]# ls -a /run/media/ankur/LIVE/
.  ..  LiveOS  syslinux
[root@ankur ~]# df -lh
Filesystem      Size  Used Avail Use% Mounted on
rootfs           30G  8.0G   21G  29% /
devtmpfs        1.9G     0  1.9G   0% /dev
tmpfs           1.9G  952K  1.9G   1% /dev/shm
tmpfs           1.9G  1.9M  1.9G   1% /run
/dev/sda6        30G  8.0G   21G  29% /
tmpfs           1.9G     0  1.9G   0% /sys/fs/cgroup
tmpfs           1.9G     0  1.9G   0% /media
/dev/sdb3       176G  160G  7.3G  96% /mnt/Stuff
/dev/sdb1        99G   42G   52G  45% /mnt/Ankur Backup
/dev/sda2        30G   21G  7.7G  73% /mnt/Other
/dev/sdb2        21G   20G  221M  99% /mnt/NTFS Temp
/dev/sda8       206G  189G  6.6G  97% /mnt/Miscellaneous
/dev/sda5       196G  141G   46G  76% /home
/dev/sda3       510M   93M  392M  20% /boot
/dev/sdc1       3.8G  153M  3.7G   4% /run/media/ankur/LIVE
[root@ankur ~]#
Uploading (2.8KiB)...
Error Uploading: INTERNAL SERVER ERROR
[root@ankur ~]# rpm -q livecd-tools
livecd-tools-17.8-1.fc17.x86_64
[root@ankur ~]#


Since what's given in the docs doesnt work, this should be a blocker IMO.
Comment 1 Brian Lane 2012-04-18 14:09:20 EDT
It looks like the wiki needs to be updated. You should use --format the first time you create the USB stick and when it is done you should see 2 partitions on the USB stick, one labeled LIVE and the other LIVE-REPO
Comment 2 Tim Flink 2012-04-18 14:14:33 EDT
Created attachment 578433 [details]
output from litd when passing in --format and single partition

I tried the following command on F16 using livecd-tools-16.11 and an 8GB USB stick that had a single 8GB FAT32 partition on it:
livecd-iso-to-disk --format --reset-mbr /home/tflink/fedora_images/17b_rc4/Fedora-17-Beta-x86_64-DVD.iso /dev/sdd1

It does create 2 partitions (LIVE and LIVE-REPO) but the command used by the reporter didn't include --format

This is a problem because the documentation doesn't include --format as an option

https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#How_to_Make_a_bootable_USB_Drive_to_Install_Fedora_instead_of_using_a_physical_DVD
Comment 3 Tim Flink 2012-04-18 14:16:49 EDT
(In reply to comment #1)
> It looks like the wiki needs to be updated. You should use --format the first
> time you create the USB stick and when it is done you should see 2 partitions
> on the USB stick, one labeled LIVE and the other LIVE-REPO

Would it be possible to show an error if --format isn't used and the second partition isn't created? Looking at the output, there is no reason to believe that anything failed unless you're looking very closely at the resultant USB drive
Comment 4 Ankur Sinha (FranciscoD) 2012-04-18 15:13:22 EDT
(In reply to comment #1)
> It looks like the wiki needs to be updated. You should use --format the first
> time you create the USB stick and when it is done you should see 2 partitions
> on the USB stick, one labeled LIVE and the other LIVE-REPO

I'll explain why this is not the correct solution.

The command on the wiki page worked. Since it was on the wiki page, it is what maximum people used. By maximum people, I mean common users, who google and refer to the docs. These do not have to be advanced users, and they do not have to be fedora community folks who know the current status of livecd-tools.

--format is an __optional__ argument. It is __not__ compulsory. This is what the description for livecd-iso-to-disk says: (livecd-iso-to-disk --help)

"Unless you request the --format option, the installation does not destroy
data outside of the LiveOS, syslinux, & EFI folders on your target device.
This allows one to maintain other files on the target disk outside of the
LiveOS filesystem."

It speaks for itself really. A user should not be forced to destroy his/her data on the USB media. What if someone wants to use an external USB HDD and not a tiny USB stick? A live iso is 700MB, the beta iso was 2.6gigs. Formatting even an 8gig pen drive is overkill IMO.


The previous version required __one__ partition, that should be marked bootable, and should have sufficient space. 

This is a loss of functionality in my book. I request that the behaviour be reverted to what it originally was. A certain BLOCKER in my book. 


Ankur
Comment 5 Brian Lane 2012-04-18 15:30:36 EDT
Well, there are a couple of things going on here.

1. There *is* a bug with writing DVD's right now -- if you don't use --format it ends up copying the iso into / of the host system. I'll fix this today. But the first time you setup your USB stick to use F17 DVD's you will need to use --format, there is no way to avoid that. If --format isn't used and there is no 2nd partition setup it should print an error and exit.

2. With a livecd.iso install your comments are correct. Only 1 partition is needed.

3. Because of changes in Anaconda for F17 it is no longer able to use the partition it booted from as a source for the .iso, so this needs to be written to a second partition. The wiki needs to be updated to make this situation clear.
Comment 6 Ankur Sinha (FranciscoD) 2012-04-18 16:05:49 EDT
(In reply to comment #5)
> Well, there are a couple of things going on here.
> 
> 1. There *is* a bug with writing DVD's right now -- if you don't use --format
> it ends up copying the iso into / of the host system. I'll fix this today. But
> the first time you setup your USB stick to use F17 DVD's you will need to use
> --format, there is no way to avoid that. If --format isn't used and there is no
> 2nd partition setup it should print an error and exit.

It doesn't print an error message currently. The addition would be nice.

> 
> 2. With a livecd.iso install your comments are correct. Only 1 partition is
> needed.
> 
> 3. Because of changes in Anaconda for F17 it is no longer able to use the
> partition it booted from as a source for the .iso, so this needs to be written
> to a second partition. The wiki needs to be updated to make this situation
> clear.

Instead of formatting the entire USB, isn't it possible to instead split the partition the user specifies into two, leaving the other partitions untouched? Maybe add an option --using-dvd-iso that takes care of this?

I'm just fishing for solutions here. Pardon me if the idea isn't at all implementable..

I will update the relevant documents as required. 

Ankur
Comment 7 Ankur Sinha (FranciscoD) 2012-04-19 03:29:48 EDT
Hello,

Documents updated. I've sent an email to the testing mailing list too. I see you've added "Fixed in version" information. What fix is this specifically please? 

Thanks,
Ankur
Comment 8 Ankur Sinha (FranciscoD) 2012-04-19 04:22:46 EDT
Complete required command:

livecd-iso-to-disk --format --msdos --reset-mbr <iso path> </dev/sd*>

In this case, shouldn't --msdos be compulsory (along with --format), otherwise it formats it as ext4, which isn't detected by most systems on boot.

Ankur
Comment 9 Ankur Sinha (FranciscoD) 2012-04-19 04:44:28 EDT
Ugh, that didn't work either:

Disk /dev/sdb: 4048 MB, 4048551936 bytes
125 heads, 62 sectors/track, 1020 cylinders, total 7907328 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00045c85

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048     2557951     1277952    c  W95 FAT32 (LBA)
/dev/sdb2         2557952     7904296     2673172+   c  W95 FAT32 (LBA)
[root@ankur ~]#

and my EEEpc won't detect it. 

Any pointers as to what's going wrong?

Ankur
Comment 10 Ankur Sinha (FranciscoD) 2012-04-19 04:51:00 EDT
Worked on my Dell Latitude. I'm going to try and see why this is happening.
Comment 11 satellitgo 2012-04-19 08:29:17 EDT
Entered in wrong bug yesterday:https://bugzilla.redhat.com/show_bug.cgi?id=811412#c22
-revised for subsequent test with 4 GB USB

Used Disk utility on an 4 GB USB
format USB fat
format one partition: /dev/sdb1 750 mb fat;label=LIVE boot flag left balance of USB unformatted
unmount /dev/sdb1

./tools_livecd-iso-to-disk.sh --format --reset-mbr
Fedora-17-Beta-x86_64-DVD.iso /dev/sdb1


Boot USB
now I have 2 UUID entries repo=hd:UUID    then root=live:UUID
It shows the installation repo on list
format with fat /dev/sdb1 and 2-)leaving 3GB of 4GB USB unformatted.
-checking dependencies from install repo! look OK
-Installing from DVD repo....no network connection used.

Installs correctly to HD

There are 2 partitions: LIVE and LIVE-REPO(with Fedora 17 Beta-x86-64-DVD.iso)
anaconda must have created the /dev/sdb2 partition and installed the DVD.iso in
the Unformatted 4 GB part of the USB

grub.conf

debug --graphics
default=0
splashimage=@SPLASHPATH@
timeout 5
hiddenmenu
title Fedora 17-Beta
 findiso
 kernel @KERNELPATH@ @ROOT@ rd.luks=0 rd.md=0 rd.dm=0
 initrd @INITRDPATH@


syslinux.cfg

...
label linux
  menu label ^Install or upgrade Fedora
  menu default
  kernel vmlinuz
  append initrd=initrd.img repo=hd:UUID=3147-B22E:/ root=live:UUID=310D-94BB
quiet rd.luks=0 rd.md=0 rd.dm=0
.......
Comment 12 Brian Lane 2012-04-19 12:38:54 EDT
--msdos isn't required, the filesystem type shouldn't matter. If it isn't booting then it is a problem with the bootloader.

Any new testing of this should use the latest version of livecd-iso-to-disk from updates-testing.
Comment 13 satellitgo 2012-04-19 15:20:47 EDT
http://git.fedorahosted.org/git/?p=hosted/livecd;a=blob;f=tools/livecd-iso-to-disk.sh;hb=HEAD

raw download is what I have been using for my tests per fedora link
Comment 14 Adam Williamson 2012-04-20 16:37:04 EDT
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . We agreed that this bug is accepted as a blocker, under criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media", insofar as the requirement to use --format must be at the least clearly documented (ideally strongly advised/enforced by the tool itself). Doing so would be sufficient to clear the blocker status of this bug.

Note this is a 'special blocker' - as it affects livecd-tools, it does not block the creation of composes, only the final release itself.
Comment 15 Fedora Update System 2012-04-24 18:14:16 EDT
livecd-tools-17.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.9-1.fc17
Comment 16 Fedora Update System 2012-04-25 14:08:23 EDT
livecd-tools-16.13-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.13-1.fc16
Comment 17 Fedora Update System 2012-04-26 15:25:28 EDT
Package livecd-tools-17.9-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-17.9-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6645/livecd-tools-17.9-1.fc17
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-04-26 18:10:04 EDT
livecd-tools-17.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.10-1.fc17
Comment 19 satellitgo 2012-04-26 23:24:05 EDT
tested with https://admin.fedoraproject.org/updates/livecd-tools-17.10-1.fc17 on Virtualbox DVD TC1 x86_64 gnome install. installed the 2 rpms

formatted 8 GB usb fat no (sdb1)


tools_livecd-iso-to-disk --format --reset-mbr Fedora-17-TC1-x86_64-DVD.iso /dev/sdb


.....scroll back failed------copied 3368 rpms to USB-....
Packages/zvbi-fonts-0.2.33-12.fc17.noarch.rpm
      117829 100%  159.15kB/s    0:00:00 (xfer#3356, to-check=9/3368)
repodata/
repodata/0e9ffb58a7c184b0cf39573a2c85ffe606d9359155d4764ae65aa2b6b0d7fd69-other.xml.gz
     1247952 100%    1.28MB/s    0:00:00 (xfer#3357, to-check=8/3368)
repodata/3f98616c25bd703f61db805ff651779641ad8eb614f14925680473e7b0d01a19-Fedora-17-TC1-comps.xml
     1941719 100%    1.55MB/s    0:00:01 (xfer#3358, to-check=7/3368)
repodata/6ad1c3c9702b69dad0e4a4df74003903f69b44b269c05855225e36ed8151c381-primary.sqlite.bz2
     2478251 100%    4.18MB/s    0:00:00 (xfer#3359, to-check=6/3368)
repodata/738250ba159d35a2e7a9e862f93cad47dca744f6e052eb058a6146f3acf51ef6-Fedora-17-TC1-comps.xml.gz
      440672 100%  668.24kB/s    0:00:00 (xfer#3360, to-check=5/3368)
repodata/7539f31b89d3b93fe698306f7430058deb145c25e7789f59e22acf6a0b7c5bee-other.sqlite.bz2
     1198513 100%    1.36MB/s    0:00:00 (xfer#3361, to-check=4/3368)
repodata/ac6ad4ea0e3fb888e25eaedb42d3d253556c3e86b61a200cde5b6ee731bba04a-primary.xml.gz
     1366054 100%  764.93kB/s    0:00:01 (xfer#3362, to-check=3/3368)
repodata/af628b66c37966d48ac5c90cf5e4af7dc5fd17832bea6e30c94614356edcab76-filelists.xml.gz
     2897005 100%    6.43MB/s    0:00:00 (xfer#3363, to-check=2/3368)
repodata/d6aea7ef51e67dcc383c1ea5ec0996c51e625569852c6e68b061776f9941a47c-filelists.sqlite.bz2
     3117988 100%    3.74MB/s    0:00:00 (xfer#3364, to-check=1/3368)
repodata/repomd.xml
        3756 100%    4.61kB/s    0:00:00 (xfer#3365, to-check=0/3368)

sent 3658156062 bytes  received 63955 bytes  3022073.54 bytes/sec
total size is 3657431730  speedup is 1.00
Waiting for device to finish writing
Updating boot config file
Installing boot loader
/media/tgttmp.qPW8PD/syslinux is device /dev/sdb1
Target device is now set up with a Live image!
[root@localhost sugar]# 

copied 3368 rpms to USB

On boot  starts anaconda but does not see installation repo. insists on network setup before proceeding.

No EFI Boot om MAC
Comment 20 satellitgo 2012-04-26 23:35:41 EDT
LIVE/Packages contains the 3368 rpms 
LIVE/repodata has no link to Packages

This is a failure as no "sneaker-net" is possible.
Comment 21 satellitgo 2012-04-27 01:16:02 EDT
livecd-iso-to-disk --format --efi Fedora-17-TC1-x86_64-DVD.iso /dev/sdb1

---------Boots om MacBook Proi7 and Acer aspire one n450------------------

Packages/zvbi-fonts-0.2.33-12.fc17.noarch.rpm
      117829 100%  202.58kB/s    0:00:00 (xfer#3356, to-check=9/3368)
repodata/
repodata/0e9ffb58a7c184b0cf39573a2c85ffe606d9359155d4764ae65aa2b6b0d7fd69-other.xml.gz
     1247952 100%    1.35MB/s    0:00:00 (xfer#3357, to-check=8/3368)
repodata/3f98616c25bd703f61db805ff651779641ad8eb614f14925680473e7b0d01a19-Fedora-17-TC1-comps.xml
     1941719 100%    1.22MB/s    0:00:01 (xfer#3358, to-check=7/3368)
repodata/6ad1c3c9702b69dad0e4a4df74003903f69b44b269c05855225e36ed8151c381-primary.sqlite.bz2
     2478251 100%    1.83MB/s    0:00:01 (xfer#3359, to-check=6/3368)
repodata/738250ba159d35a2e7a9e862f93cad47dca744f6e052eb058a6146f3acf51ef6-Fedora-17-TC1-comps.xml.gz
      440672 100%    1.08MB/s    0:00:00 (xfer#3360, to-check=5/3368)
repodata/7539f31b89d3b93fe698306f7430058deb145c25e7789f59e22acf6a0b7c5bee-other.sqlite.bz2
     1198513 100%    1.50MB/s    0:00:00 (xfer#3361, to-check=4/3368)
repodata/ac6ad4ea0e3fb888e25eaedb42d3d253556c3e86b61a200cde5b6ee731bba04a-primary.xml.gz
     1366054 100%    1.08MB/s    0:00:01 (xfer#3362, to-check=3/3368)
repodata/af628b66c37966d48ac5c90cf5e4af7dc5fd17832bea6e30c94614356edcab76-filelists.xml.gz
     2897005 100%    2.66MB/s    0:00:01 (xfer#3363, to-check=2/3368)
repodata/d6aea7ef51e67dcc383c1ea5ec0996c51e625569852c6e68b061776f9941a47c-filelists.sqlite.bz2
     3117988 100%    3.14MB/s    0:00:00 (xfer#3364, to-check=1/3368)
repodata/repomd.xml
        3756 100%    3.86kB/s    0:00:00 (xfer#3365, to-check=0/3368)

sent 3658156062 bytes  received 63955 bytes  3407750.37 bytes/sec
total size is 3657431730  speedup is 1.00
Waiting for device to finish writing
Updating boot config file
Installing boot loader
Target device is now set up with a Live image!
[root@localhost sugar]# 

Boots om MacBook Proi7 and Acer aspire one n450
still requires networking to install
No install repo available
Comment 22 satellitgo 2012-04-27 08:44:50 EDT
In f17 gnome Version 3.4.1 fully updated: (VirtualBox 4.1.14)
satellit_ 4/27/2012
This works Boots EFI (Mac ) and Legacy PC
Has DVD installation repo!

................................................
Removing:
 livecd-tools x86_64 1:17.10-1.fc17    @/livecd-tools-17.10-1.fc17.x86_64 140 k

Removing:
 python-imgcreate
             x86_64 1:17.10-1.fc17 @/python-imgcreate-17.10-1.fc17.x86_64 274 k

Installing:
 python-imgcreate     x86_64     1:17.9-1.fc17        updates-testing      94 k


Installing:
 livecd-tools      x86_64      1:17.9-1.fc17         updates-testing       73 k

Complete!

.........8 GB USB GPT with /dev/sdb 500MB formatted in f17 Disk-Utility.........

[root@localhost sugar]# livecd-iso-to-disk --format --efi Fedora-17-TC1-x86_64-DVD.iso /dev/sdb1
Verifying image...
/home/sugar/Fedora-17-TC1-x86_64-DVD.iso:   58d524c488dcce9d577bae7cde57bb79
Fragment sums: fe5138ee11e79eaed3dc23ce3e7c9eb7633eeba3b7bcf1f7745f11648f63
Fragment count: 20
Press [Esc] to abort check.
Checking: 032.3%

The media check is complete, the result is: UNKNOWN.

The media check was aborted.
Are you SURE you want to continue?
Press Enter to continue or ctrl-c to abort

/Packages found, will copy source .iso to target
WARNING: THIS WILL DESTROY ANY DATA ON /dev/sdb!!!
Press Enter to continue or ctrl-c to abort

8 bytes were erased at offset 0x00000200 (gpt): 45 46 49 20 50 41 52 54
8 bytes were erased at offset 0xeefffe00 (gpt): 45 46 49 20 50 41 52 54
Your device isn't big enough to hold /home/sugar/Fedora-17-TC1-x86_64-DVD.iso
It is 94 MB too small
[root@localhost sugar]# livecd-iso-to-disk --format --efi Fedora-17-TC1-x86_64-DVD.iso /dev/sdb1
Verifying image...
/home/sugar/Fedora-17-TC1-x86_64-DVD.iso:   58d524c488dcce9d577bae7cde57bb79
Fragment sums: fe5138ee11e79eaed3dc23ce3e7c9eb7633eeba3b7bcf1f7745f11648f63
Fragment count: 20
Press [Esc] to abort check.
Checking: 025.1%

The media check is complete, the result is: UNKNOWN.

The media check was aborted.
Are you SURE you want to continue?
Press Enter to continue or ctrl-c to abort

/Packages found, will copy source .iso to target
WARNING: THIS WILL DESTROY ANY DATA ON /dev/sdb!!!
Press Enter to continue or ctrl-c to abort

8 bytes were erased at offset 0x00000200 (gpt): 45 46 49 20 50 41 52 54
8 bytes were erased at offset 0x1ddbf7e00 (gpt): 45 46 49 20 50 41 52 54
Waiting for devices to settle...
mkdosfs 3.0.12 (29 Oct 2011)
mkdosfs 3.0.12 (29 Oct 2011)
Copying live image to target device.
squashfs.img
   137752576 100%    8.83MB/s    0:00:14 (xfer#1, to-check=0/1)

sent 137769465 bytes  received 31 bytes  8888354.58 bytes/sec
total size is 137752576  speedup is 1.00
Copying /home/sugar/Fedora-17-TC1-x86_64-DVD.iso
Fedora-17-TC1-x86_64-DVD.iso
  3832545280 100%    2.67MB/s    0:22:47 (xfer#1, to-check=0/1)

sent 3833013210 bytes  received 31 bytes  2802934.73 bytes/sec
total size is 3832545280  speedup is 1.00
Updating boot config file
Installing boot loader
Target device is now set up with a Live image!
[root@localhost sugar]# 

Boots Both in EFI (Mac) and on a PC
Comment 23 Brian Lane 2012-05-01 12:49:06 EDT
Make sure the iso you are using has anaconda-17.23-1 or later.
Comment 24 satellitgo 2012-05-01 18:17:53 EDT
using livecd-tools x86_64 1:17.10-1.fc17 :
with GPT and /dev/sdb1 700MB label=LIVE /dev/sdb2 label=LIVE-REPO

Installs all 3k+ rpms in /dev/sdb1 and then cannot access the install repo for
install. (Only sees the repos on line) Boots on Mac EFI and legacy on PC.

Comment: may as well have a netinstall USB. ; /
Comment 25 Brian Lane 2012-05-01 20:34:13 EDT
17.10 does not create 2 partitions. Double check the version you think you are using and make sure you use --format --reset-mbr to wipe the entire USB.
Comment 26 Adam Williamson 2012-05-02 18:33:05 EDT
brian: isn't it desirable for it to also work _without_ using --format?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Brian Lane 2012-05-02 18:49:32 EDT
yes, but if you previously used versions that made the 2 partitions you need to reformat it to reclaim the space used in the 2nd partition for the .iso
Comment 28 Ankur Sinha (FranciscoD) 2012-05-03 00:50:30 EDT
Hey folks,

With the amount of changes being made to livecd-tools, it's really difficult to keep the docs pages up to date. For instance, I had updated the wiki pages for the new behaviour before the test day. Now, it appears that the behaviour has changed again. I haven't been able to follow all the new changes, and therefore cannot update the docs.

Brian, would it be possible for you folks (the livecd-tools maintainers) to take ownership of the wiki pages and maintain them please? It's important that they are in line with the livecd-tools package before release. Otherwise, there'll be utter confusion about the creation and use of USBs to install fedora. 

https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB

Thanks,
Ankur
Comment 29 Adam Williamson 2012-05-03 12:43:26 EDT
Ankur: Brian: I've just done an extensive update of that page:

https://fedoraproject.org/w/index.php?title=How_to_create_and_use_Live_USB&action=historysubmit&diff=286477&oldid=285102

please check the current version over for any obvious mistakes, I've been staring at it long enough I can't see it any more. I _think_ it should reflect the current state of the art (i.e. I don't talk at all about the two partition thing or having to do --format for F17 images, as that is apparently not true any more). I don't think it's worth explaining the case where you go from a two-partition image to a one-partition image as we only had the two-partition thing quite briefly, in an unreleased Fedora version.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 30 Adam Williamson 2012-05-03 12:45:17 EDT
It may be a question whether we just ditch the page entirely and refer to the install guide instead - https://docs.fedoraproject.org/en-US/Fedora/16/html/Installation_Guide/Making_USB_Media.html - as we're essentially keeping two copies of the same instructions ATM.
Comment 31 Brian Lane 2012-05-03 12:58:16 EDT
I'd certainly prefer one document to maintain. I'll take a look at both of them today.
Comment 32 Fedora Update System 2012-05-03 19:18:35 EDT
livecd-tools-16.15-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.15-1.fc16
Comment 33 Fedora Update System 2012-05-03 19:34:27 EDT
livecd-tools-17.11-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.11-1.fc17
Comment 34 satellitgo 2012-05-04 01:38:03 EDT
(In reply to comment #33)
> livecd-tools-17.11-1.fc17 has been submitted as an update for Fedora 17.
> https://admin.fedoraproject.org/updates/livecd-tools-17.11-1.fc17

Installed:
lorax-17.17-1.fc17.x86_64.rpm 
python-imgcreate-17.11-1.fc17.x86_64.rpm
livecd-tools-17.11-1.fc17.x86_64.rpm

Tested livecd-tools-17.11-1.fc17 in a f17TC2 Desktop x86_64 VirtualBox install:

1-)Fedora-17-TC2-x86_64-Live-Desktop.iso
4 GB USB formatted fat with /dev/sd1 fat LIVE boot
 bios boot works
 EFI  boot works

2-)Fedora-17-TC2-x86_64-DVD.iso
8 GB USB formatted fat with /dev/sd1 fat LIVE boot
 Tested with 4 GB USB but ran out of space when extracting .rpms
 bios boot works - sees the DVD install repo.
 Installs to HD 
 EFI-does not work-
 -there is a problem on shutdown-it does not shutdown.
 with root terminal: 
 "shutdown -h now" takes 2 minutes from command line.

3) re-ran with --efi added and it boots both EFI and bios boot
 Did not do a Hd install on MacBookPro i7 after it booted the USB
Comment 35 Ankur Sinha (FranciscoD) 2012-05-04 02:46:34 EDT
(In reply to comment #30)
> It may be a question whether we just ditch the page entirely and refer to the
> install guide instead -
> https://docs.fedoraproject.org/en-US/Fedora/16/html/Installation_Guide/Making_USB_Media.html
> - as we're essentially keeping two copies of the same instructions ATM.

I think this is a great idea. However, then we'll need to put a mechanism in place to ensure that the docs are up to date at all times. For instance, the F16 docs aren't in line with the behaviour for the current version of livecd-tools. The F16 docs aren't modified after F16 releases, are they? I think the wiki page was set up because it's easily modifiable to reflect changes. I haven't seen the docs page (I've always referred to the wiki page), but I'm pretty sure the wiki page is more exhaustive?

Another solution (which I think is better) is to make the wiki page the main document, and just let the docs have a link to it (and no info).

Thanks,
Ankur
Comment 36 Adam Williamson 2012-05-04 06:31:09 EDT
ankur: right, the guide for one release is set in stone once the release is made. the 17 guide should be updated for 17 behaviour, of course, but I haven't checked. actually, afaics, the only practical difference between 16 and 17 now is that dd'ed images should be EFI bootable, and dd'ed USB images should be able to find the packages automatically (so no need for the manual workaround).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 37 Adam Williamson 2012-05-04 08:06:21 EDT
In case anyone missed it in the excessive verbiage in comment #34, satellit says that a DVD image written with livecd-iso-to-disk 17.11, presumably with --efi, does not boot via EFI.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 38 Adam Williamson 2012-05-04 08:08:06 EDT
sorry, skip the above. i was misreading the comment. which is easy to do :( afaict, satellit did not find any actual bugs in 17.11. not working with EFI unless you pass --efi is expected, and the shutdown bug is nothing to do with livecd-iso-to-disk.
Comment 39 Adam Williamson 2012-05-04 18:25:45 EDT
So I think what we need to do for clarity here is to test writing F17 Final TC2 (or TC3, when it lands), using the latest livecd-tools from 17 updates-testing, to an existing FAT-formatted stick *without* --format. Because that's the common use case that worked before (F16) and didn't work for a time with F17, because of the two-partition thing.

I don't think we're all that interested in the case where you have a two-partition stick from an earlier F17 livecd-tools, and you have to use --format to get it back to 'normal'. That's just a transient scenario, I'd say. The key case here is writing the latest-shiny F17 to a 'normal' USB stick, i.e. a FAT-formatted one with some files on it, without reformatting.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 40 Adam Williamson 2012-05-07 13:36:53 EDT
so I'm testing this like so:

Take a USB stick, remove all partitions, 'mklabel msdos' with parted, create a single new partition of type Win95 FAT32, mark it bootable, format it with mkfs.vfat, and copy a file to it (just to test that the file is still around later).

Then try and livecd-iso-to-disk it.

So far, 'livecd-iso-to-disk Fedora-17.TC3-x86_64-Live-Desktop.iso /dev/sdX1' fails to boot, but 'livecd-iso-to-disk --reset-mbr Fedora-17.TC3-x86_64-Live-Desktop.iso /dev/sdX1' works, which is probably as you'd expect. I am now going to test with the DVD ISO.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 41 Samuel Sieb 2012-05-07 13:42:58 EDT
--reset-mbr is needed at least once to install the syslinux bootloader.
Comment 42 Adam Williamson 2012-05-07 16:42:09 EDT
Yes, I know. I was just testing 'dumbly' according to the docs.

Same test with the TC3 DVD image gives the same results, so I think we could say this is fixed in 17.11. Setting VERIFIED.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 43 Fedora Update System 2012-05-08 00:32:36 EDT
livecd-tools-17.11-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.