Bug 812296 - Incompatible version with nokogiri
Incompatible version with nokogiri
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-aws-sdk (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
: 816706 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 06:25 EDT by Marko Myllynen
Modified: 2012-05-04 18:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-aws-sdk-1.4.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 16:28:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-04-13 06:25:57 EDT
Description of problem:
On Fedora 17 / updates as of 2012-04-13:

[root@localhost ~]# boxgrinder-build --help
/usr/share/rubygems/rubygems/dependency.rb:247:in `to_specs': Could not find nokogiri (<= 1.5.0) amongst [aws-sdk-1.3.7, bigdecimal-1.1.0, boxgrinder-build-0.10.1, boxgrinder-core-0.3.11, builder-2.1.2, hashery-1.4.0, httparty-0.8.1, io-console-0.3, json-1.6.5, kwalify-0.7.2, mime-types-1.16, multi_json-1.0.3, multi_xml-0.4.1, net-sftp-2.0.5, net-ssh-2.2.1, nokogiri-1.5.2, open4-1.3.0, progressbar-0.9.0, rdoc-3.12, rest-client-1.6.1, uuidtools-2.1.2] (Gem::LoadError)
        from /usr/share/rubygems/rubygems/specification.rb:771:in `block in activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:760:in `each'
        from /usr/share/rubygems/rubygems/specification.rb:760:in `activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:744:in `activate'
        from /usr/share/rubygems/rubygems/specification.rb:774:in `block in activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:760:in `each'
        from /usr/share/rubygems/rubygems/specification.rb:760:in `activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:744:in `activate'
        from /usr/share/rubygems/rubygems.rb:1210:in `gem'
        from /bin/boxgrinder-build:18:in `<main>'
[root@localhost ~]# 

Version-Release number of selected component (if applicable):
rubygem-boxgrinder-build-0.10.1-1.fc17
rubygem-nokogiri-1.5.2-1.fc17
Comment 1 Brian Harrington 2012-04-24 12:19:53 EDT
I see the same thing on F16 as well.


[bharrington@kraken ~]$ boxgrinder-build 
/usr/lib/ruby/site_ruby/1.8/rubygems/dependency.rb:247:in `to_specs': Could not find nokogiri (<= 1.5.0) amongst [aws-sdk-1.3.7, boxgrinder-build-0.10.1, boxgrinder-core-0.3.11, builder-2.1.2, crack-0.1.8, hashery-1.4.0, httparty-0.7.4, json-1.4.6, kwalify-0.7.2, mime-types-1.16, net-sftp-2.0.5, net-ssh-2.0.23, nokogiri-1.5.2, open4-1.0.1, progressbar-0.9.0, rest-client-1.6.1, uuidtools-2.1.1] (Gem::LoadError)
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:761:in `activate_dependencies'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:758:in `each'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:758:in `activate_dependencies'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:742:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:764:in `activate_dependencies'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:758:in `each'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:758:in `activate_dependencies'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:742:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:1212:in `gem'
	from /usr/bin/boxgrinder-build:18
[bharrington@kraken ~]$ rpm -qa | grep  rubygem
rubygem-aws-sdk-1.3.7-1.fc16.noarch
rubygem-json-1.4.6-3.fc15.x86_64
rubygems-1.8.11-1.fc16.1.noarch
rubygem-hashery-1.4.0-3.fc15.noarch
rubygem-builder-2.1.2-5.fc15.noarch
rubygem-progressbar-0.9.0-3.fc15.noarch
rubygem-open4-1.0.1-2.fc15.noarch
rubygem-net-sftp-2.0.5-3.fc15.noarch
rubygem-mime-types-1.16-3.fc15.noarch
rubygem-crack-0.1.8-4.fc16.noarch
rubygem-rest-client-1.6.1-2.fc15.noarch
rubygem-net-ssh-2.0.23-6.fc15.noarch
rubygem-uuidtools-2.1.1-1.fc14.noarch
rubygem-boxgrinder-core-0.3.11-1.fc16.noarch
rubygem-nokogiri-1.5.2-1.fc16.x86_64
rubygem-kwalify-0.7.2-3.fc16.noarch
rubygem-httparty-0.7.4-1.fc16.noarch
rubygem-boxgrinder-build-0.10.1-1.fc16.noarch
Comment 2 Marek Goldmann 2012-04-25 04:08:35 EDT
Ouch, we'll have a fix ASAP for this. We need to loose specific version requirement for nokogiri.

As a workaround: yum downgrade rubygem-nokogiri.
Comment 3 Marek Goldmann 2012-04-25 04:57:09 EDT
Changing component as this is a rubygem-aws-sdk issue after nokogiri update.
Comment 4 Fedora Update System 2012-04-25 05:28:12 EDT
rubygem-aws-sdk-1.4.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rubygem-aws-sdk-1.4.1-1.fc16
Comment 5 Fedora Update System 2012-04-25 05:28:20 EDT
rubygem-aws-sdk-1.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rubygem-aws-sdk-1.4.1-1.fc17
Comment 6 Marek Goldmann 2012-04-25 05:30:26 EDT
Marko, could you please install rubygem-aws-sdk from koji and try again?
Comment 7 Marko Myllynen 2012-04-25 07:22:09 EDT
(In reply to comment #6)
> Marko, could you please install rubygem-aws-sdk from koji and try again?

Thanks, the build fixed the issue, karma added.
Comment 8 Fedora Update System 2012-04-26 15:30:47 EDT
Package rubygem-aws-sdk-1.4.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-aws-sdk-1.4.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6708/rubygem-aws-sdk-1.4.1-1.fc17
then log in and leave karma (feedback).
Comment 9 Marek Goldmann 2012-04-26 16:04:58 EDT
*** Bug 816706 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-05-04 16:28:30 EDT
rubygem-aws-sdk-1.4.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-05-04 18:52:55 EDT
rubygem-aws-sdk-1.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.