Bug 816706 - Recent update of rubygem-nokogiri breaks rubygem-aws-sdk
Recent update of rubygem-nokogiri breaks rubygem-aws-sdk
Status: CLOSED DUPLICATE of bug 812296
Product: Fedora
Classification: Fedora
Component: rubygem-aws-sdk (Show other bugs)
16
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 14:38 EDT by Rob Millner
Modified: 2013-11-17 19:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 16:04:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2012-04-26 14:38:34 EDT
Description of problem:
A recent update included a newer version of rubygem-nokogiri which no longer satisfies the gem dependencies of rubygem-aws-sdk.

Version-Release number of selected component (if applicable):
rubygem-aws-sdk-1.3.7-1.fc16.noarch

How reproducible:
Always

Steps to Reproduce:
1. yum -y upgrade on Fedora 16
2. Run a ruby script which requires aws-sdk

  
Actual results:
$ ./devenv 
/usr/lib/ruby/site_ruby/1.8/rubygems/dependency.rb:247:in `to_specs': Could not find nokogiri (<= 1.5.0) amongst [ParseTree-3.0.5, RubyInline-3.8.4, ZenTest-4.3.3, abstract-1.0.0, actionmailer-3.0.10, actionpack-3.0.10, activemodel-3.0.10, activerecord-3.0.10, activeresource-3.0.10, activesupport-3.0.10, arel-2.0.9, aws-sdk-1.3.7, builder-2.1.2, bundler-1.0.15, crack-0.1.8, cucumber-1.0.1, diff-lcs-1.1.2, erubis-2.6.6, gem2rpm-0.8.1, gherkin-2.4.5, httparty-0.7.4, i18n-0.5.0, json-1.4.6, json_pure-1.5.1, mail-2.3.0, mime-types-1.16, nokogiri-1.5.2, parseconfig-0.5.2, polyglot-0.3.1, rack-1.3.0, rack-mount-0.7.1, rack-test-0.6.0, rails-3.0.10, railties-3.0.10, rake-0.9.2.2, rake-compiler-0.8.0, rdoc-3.8, regin-0.3.8, rest-client-1.6.1, rhc-0.88.9, ruby2ruby-1.2.4, ruby_parser-2.0.4, rvm-1.0.19, sexp_processor-3.0.4, term-ansicolor-1.0.7, text-format-1.0.0, thor-0.14.6, treetop-1.4.10, tzinfo-0.3.26, uuidtools-2.1.1] (Gem::LoadError)
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:761:in `activate_dependencies'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:758:in `each'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:758:in `activate_dependencies'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:742:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:209:in `try_activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:58:in `require'
	from ./lib/openshift/amz.rb:3
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
	from ./lib/openshift.rb:6
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
	from ./devenv:8


Expected results:
The script runs

Additional info:
Upgrading the RPM to aws-sdk-1.4.1 solves the problem and requires minimal changes to the specfile (just download the newer gem and update version number).
Comment 1 Marek Goldmann 2012-04-26 16:04:58 EDT
Fixed already in updates-testing.

*** This bug has been marked as a duplicate of bug 812296 ***

Note You need to log in before you can comment on or make changes to this bug.