This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 812329 - rhn-charsets / spacewalk-debug tracebacks and prints other errors when on SW with PostgreSQL DB backend
rhn-charsets / spacewalk-debug tracebacks and prints other errors when on SW ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pazdziora
Martin Minar
:
Depends On:
Blocks: 819032
  Show dependency treegraph
 
Reported: 2012-04-13 08:06 EDT by Jan Hutař
Modified: 2016-07-03 20:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.7.38-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:59:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-04-13 08:06:39 EDT
Description of problem:
When you run rhn-charsets or spacewalk-debug on SWnightly with PostgreSQL DB backend, there is a Traceback. Also spacewalk-debug prints other error about missing /etc/tnsnames.ora.


Version-Release number of selected component (if applicable):
spacewalk-backend-tools-1.8.14-1.el6.noarch
spacewalk-postgresql-1.7.3-1.el6.noarch


How reproducible:
1 of 1


Steps to Reproduce:
1. # spacewalk-debug


Actual results:
# spacewalk-debug 
Collecting and packaging relevant diagnostic information.
Warning: this may take some time...
    * copying configuration information
cp: cannot stat `/etc/tnsnames.ora': No such file or directory
    * copying logs
    * copying cobbler files
    * copying monitoring moc logs
    * copying monitoring scout logs
    * copying ssl-build
    * copying /etc/sudoers
    * copying apache, oracle, tomcat, nocpulse entries from /etc/passwd
    * copying apache, oracle, tomcat, nocpulse entries from /etc/group
    * querying RPM database (versioning of Spacewalk, etc.)
    * querying schema version, database charactersets and database
SQL error occurred, traceback follows...
Traceback (most recent call last):
  File "/usr/bin/rhn-charsets", line 85, in <module>
    h.execute()
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 163, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/driver_postgresql.py", line 282, in _execute_wrapper
    retval = apply(function, p, kw)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 217, in _execute
    return self._execute_(args, kwargs)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/driver_postgresql.py", line 295, in _execute_
    self._real_cursor.execute(self.sql, params)
spacewalk.server.rhnSQL.sql_base.SQLStatementPrepareError: ('relation "nls_database_parameters" does not exist\nLINE 3:                 FROM   nls_database_parameters\n                               ^\n', 0, "\n                SELECT parameter, value\n                FROM   nls_database_parameters\n                WHERE  parameter = 'NLS_CHARACTERSET'\n                    OR parameter = 'NLS_NCHAR_CHARACTERSET'\n                ")
    * get diskspace available
    * get database statistics
    * get schema statistics
    * copying schema upgrade logs
    * copying audit.log
    * timestamping
    * creating tarball (may take some time): /tmp/spacewalk-debug.tar.bz2
    * removing temporary debug tree

Debug dump created, stored in /tmp/spacewalk-debug.tar.bz2


Expected results:
No traceback, no error message shown in the output.
Comment 1 Jan Pazdziora 2012-04-13 09:52:36 EDT
The tnsnames.ora error fixed in Spacewalk master, 034b2b11438c39d70effbf54a9a6ccb0894123c6.

I've added sudoers.d, Spacewalk master, 32041195b357640ca763cdc6fb49ad94bd1d5032.
Comment 2 Jan Pazdziora 2012-04-13 10:44:48 EDT
Rewritten rhn-charsets to shell, adding support for PostgreSQL, 92e8e16447fdf58e4289b7769597c740680c5d9c.

Updated rhn-charsets man page, 6fa6ed4adf1e47b205f54c9ab94c87179166d5ec.

Added packaging of PostsgreSQL configuration and logs, 42e75e6b97782cb6f31d096f99d48a0fccd8b712.

All Spacewalk master.
Comment 9 Clifford Perry 2013-10-01 17:59:31 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.