Bug 812469 - pcscd process is dead after a desktop restart.
pcscd process is dead after a desktop restart.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcsc-lite (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bob Relyea
IDM QE LIST
: Regression
: 808733 821008 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 15:54 EDT by Asha Akkiangady
Modified: 2012-06-20 11:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: pcsc-lite-1.5.2-7.el6
Doc Type: Bug Fix
Doc Text:
Cause The pcscd init scrip was pointing to the wrong value to identify the haldaemon. It was also starting up at run-level 2. Consequence chkconfig would not automatically place pcscd after the start of haldaemon. This would casue pcscd to fail to see usb readers (the most common readers). Fix Change the pcscd init script to properly identify haldaemon and only start at run-levels 3,4, and 5. Result chkconfig will now correctly place pcscd start after haldaemon.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:14:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asha Akkiangady 2012-04-13 15:54:52 EDT
Description of problem:
pcscd process is dead after a desktop restart.

Version-Release number of selected component (if applicable):
pcsc-lite-1.5.2-6.el6.i686
coolkey-1.1.0-19.el6.i686
esc-1.1.0-24.el6_2.2.i686

How reproducible:


Steps to Reproduce:
1. Restart a Rhel 6.2 desktop when z-stream packages are installed.
  
Actual results:
pcscd process is dead.

Expected results:
pcscd should be running.

Additional info:
Smart card login requires pcscd to be running upon a desktop restart.
Comment 2 Asha Akkiangady 2012-04-13 16:04:34 EDT
/var/log/messages has this:

Apr 13 15:58:26 dhcp231-57 pcscd: pcscdaemon.c:506:main() pcsc-lite 1.5.2 daemon ready.
Apr 13 15:58:26 dhcp231-57 acpid: starting up
Apr 13 15:58:26 dhcp231-57 acpid: 1 rule loaded
Apr 13 15:58:26 dhcp231-57 acpid: waiting for events: event logging is off
Apr 13 15:58:26 dhcp231-57 pcscd: hotplug_libhal.c:490:HPRegisterForHotplugEvents() Could not initialise connection to hald.
Apr 13 15:58:26 dhcp231-57 pcscd: hotplug_libhal.c:491:HPRegisterForHotplugEvents() Normally this means the HAL daemon (hald) is not running or not ready.
Apr 13 15:58:26 dhcp231-57 pcscd: pcscdaemon.c:525:main() SVCServiceRunLoop returned
Apr 13 15:58:26 dhcp231-57 pcscd: pcscdaemon.c:531:at_exit() cleaning /var/run
Comment 3 Bob Relyea 2012-04-13 20:24:50 EDT
Asha, see bug 788474, comment 5 If that resolves your problem, then close this bug as a dup of that one.

If it doesn't resolve your problem you may be running into bug 808733 which looks similiar, but doesn't seem to be the same. The latter bug I can't reproduce, so I would probably like to look at your system, but that will have to wait until after next week.

bob
Comment 4 Asha Akkiangady 2012-04-16 12:11:00 EDT
Applied the work-around (https://bugzilla.redhat.com/show_bug.cgi?id=788474#c5), after the desktop restart pcscd process fails to start.

/var/log/messages has this:

Apr 16 10:57:51 dhcp231-57 pcscd: pcscdaemon.c:506:main() pcsc-lite 1.5.2 daemon ready.
Apr 16 10:57:51 dhcp231-57 acpid: starting up
Apr 16 10:57:51 dhcp231-57 acpid: 1 rule loaded
Apr 16 10:57:51 dhcp231-57 acpid: waiting for events: event logging is off
Apr 16 10:57:51 dhcp231-57 pcscd: hotplug_libhal.c:490:HPRegisterForHotplugEvents() Could not initialise connection to hald.
Apr 16 10:57:51 dhcp231-57 pcscd: hotplug_libhal.c:491:HPRegisterForHotplugEvents() Normally this means the HAL daemon (hald) is not running or not ready.
Apr 16 10:57:51 dhcp231-57 pcscd: pcscdaemon.c:525:main() SVCServiceRunLoop returned
Apr 16 10:57:51 dhcp231-57 pcscd: pcscdaemon.c:531:at_exit() cleaning /var/run
Comment 7 Suzanne Yeghiayan 2012-04-19 16:53:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 9 Bob Relyea 2012-04-26 17:41:55 EDT
Asha, can you also try the following:

changeL

# Default-Start: 2 3 4 5

To

# Default-Start: 3 4 5

and

# chkconfig:   2345 25 88

to

# chkconfig:   345 25 88


then do:
/sbin/service pcscd stop
/sbin/chkconfig --del pcscd
/sbin/chkconfig --add pcscd
/sbin/service pcscd start




bob
Comment 10 Asha Akkiangady 2012-04-27 12:27:35 EDT
With the work-around (comment 9) pcscd starts successfully when desktop is restarted.
Comment 11 Bob Relyea 2012-04-27 19:57:07 EDT
Thanks, I'll update pcscd once this gets approved.

bob
Comment 16 Bob Relyea 2012-05-01 13:34:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
   The pcscd init scrip was pointing to the wrong value to identify the haldaemon. It was also starting up at run-level 2.
Consequence
   chkconfig would not automatically place pcscd after the start of haldaemon. This would casue pcscd to fail to see usb readers (the most common readers).
Fix
    Change the pcscd init script to properly identify haldaemon and only start at run-levels 3,4, and 5.
Result
    chkconfig will now correctly place pcscd start after haldaemon.
Comment 17 Bob Relyea 2012-05-01 13:39:29 EDT
*** Bug 788474 has been marked as a duplicate of this bug. ***
Comment 18 Bob Relyea 2012-05-01 13:41:54 EDT
*** Bug 808733 has been marked as a duplicate of this bug. ***
Comment 19 Asha Akkiangady 2012-05-03 09:10:15 EDT
Verified.

Version :: pcsc-lite-1.5.2-7.el6

pcscd process starts successfully when RHEL 6.3 desktop is boot-up.
Comment 22 Bob Relyea 2012-05-11 15:17:48 EDT
*** Bug 821008 has been marked as a duplicate of this bug. ***
Comment 29 errata-xmlrpc 2012-06-20 11:14:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0990.html

Note You need to log in before you can comment on or make changes to this bug.