Bug 821008 - pcscd crashes shortly after starting with a green state during boot because it relies on haldaemon to be running
pcscd crashes shortly after starting with a green state during boot because i...
Status: CLOSED DUPLICATE of bug 812469
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcsc-lite (Show other bugs)
6.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Bob Relyea
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 10:41 EDT by Patrick Rutledge
Modified: 2012-05-11 15:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 15:17:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Rutledge 2012-05-11 10:41:58 EDT
Description of problem:
pcscd crashes shortly after starting with a green state during boot because it relies on haldaemon to be running. after rebooting the system, pcscd will no longer start up unless manually restarted at the command line, it will not come back up after reboot. In /etc/init.d/pcscd it specifically states Should-start hal, but in rc3 and rc5, pcscd is S25 and hal is S26, which is the root cause of the bug. Manually changing pcscd to S27 fixes the problem, but this bug needs to be reviewed and fixed.

Version-Release number of selected component (if applicable):
pcsc-lite 1.5.2 el6

How reproducible:
Enable pcscd, configure a smart card, reboot system.  PCSCD will not be running after system has fully rebooted.

Steps to Reproduce:
1.Configure smartcard and test authentication
2.Make sure pcscd is chkconfiged on
3.Reboot
4.service pcscd status will return not running and stale lock
  
Actual results:

<before reboot>
[root@smartcardtest Desktop]# service pcscd status
pcscd (pid  25701) is running...

<after reboot>
[root@smartcardtest Desktop]# service pcscd status
pcscd dead but subsys locked
[root@smartcardtest Desktop]# service pcscd restart
Stopping PC/SC smart card daemon (pcscd):                  [FAILED]
Starting PC/SC smart card daemon (pcscd):                  [  OK  ]
[root@smartcardtest Desktop]# service pcscd status
pcscd (pid  2970) is running...
[root@smartcardtest Desktop]# 

Expected results:

pcscd running

Additional info:
Comment 2 Ludovic Rousseau 2012-05-11 12:15:47 EDT
I think this bug is a duplicate of Bugs 812469, 788474 and 808733.
Comment 3 Patrick Rutledge 2012-05-11 12:57:49 EDT
You are correct it is a dupe my apologies please close
Comment 4 Bob Relyea 2012-05-11 15:17:48 EDT
No problem Patrick. Better to have to close a dup than miss a real bug.

bob

*** This bug has been marked as a duplicate of bug 812469 ***

Note You need to log in before you can comment on or make changes to this bug.