Bug 812605 - [abrt] qlandkartegt-1.4.0-1.fc16: data: Process /usr/bin/qlandkartegt was killed by signal 11 (SIGSEGV)
Summary: [abrt] qlandkartegt-1.4.0-1.fc16: data: Process /usr/bin/qlandkartegt was kil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qlandkartegt
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5111d7be019e498c9e072c89271...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-15 11:33 UTC by Klaus Lichtenwalder
Modified: 2012-04-22 04:20 UTC (History)
1 user (show)

Fixed In Version: qlandkartegt-1.4.0-2.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-22 03:39:40 UTC
Type: ---


Attachments (Terms of Use)
File: dso_list (18.75 KB, text/plain)
2012-04-15 11:33 UTC, Klaus Lichtenwalder
no flags Details
File: build_ids (7.65 KB, text/plain)
2012-04-15 11:33 UTC, Klaus Lichtenwalder
no flags Details
File: maps (82.02 KB, text/plain)
2012-04-15 11:33 UTC, Klaus Lichtenwalder
no flags Details
File: backtrace (56.64 KB, text/plain)
2012-04-15 11:33 UTC, Klaus Lichtenwalder
no flags Details
backtrace from rebuild with -O0 (45.88 KB, text/plain)
2012-04-16 10:10 UTC, Dan Horák
no flags Details

Description Klaus Lichtenwalder 2012-04-15 11:33:28 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        qlandkartegt
comment:        I was trying to work on a Track, filtering some waypoints and editing the diary
crash_function: data
executable:     /usr/bin/qlandkartegt
kernel:         3.3.1-3.fc16.x86_64
pid:            12139
pwd:            /home/klaus
reason:         Process /usr/bin/qlandkartegt was killed by signal 11 (SIGSEGV)
time:           So 15 Apr 2012 10:42:22 CEST
uid:            1000
username:       klaus

backtrace:      Text file, 58004 bytes
build_ids:      Text file, 7831 bytes
dso_list:       Text file, 19202 bytes
maps:           Text file, 83991 bytes

environ:
:XDG_VTNR=1
:LC_PAPER=de_DE.UTF-8
:SSH_AGENT_PID=2459
:LC_ADDRESS=de_DE.UTF-8
:XDG_SESSION_ID=2
:LC_MONETARY=de_DE.UTF-8
:HOSTNAME=nepomuk.lichtenwalder.name
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-FPylod/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=14bee2057de43778d7ad2acb0000000d-1334326999.128001-1635900358
:HISTSIZE=1000
:PGPPATH=/usr/home/klaus/.pgp/
:TMPDIR=/home/klaus/tmp
:WINDOWID=37748790
:LC_NUMERIC=de_DE.UTF-8
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/tmp/keyring-FPylod
:QTINC=/usr/lib64/qt-3.3/include
:IMSETTINGS_MODULE=none
:VIDEO_OUT_NOSCALE=1
:USER=klaus
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:LC_TELEPHONE=de_DE.UTF-8
:SSH_AUTH_SOCK=/tmp/keyring-FPylod/ssh
:USERNAME=klaus
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2376,unix/unix:/tmp/.ICE-unix/2376
:DESKTOP_SESSION=cinnamon
:MAIL=/var/spool/mail/klaus
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/home/klaus/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/klaus/bin:/home/klaus/bin
:LC_MESSAGES=de_DE.UTF-8
:QT_IM_MODULE=xim
:LC_COLLATE=de_DE.UTF-8
:LC_IDENTIFICATION=de_DE.UTF-8
:PWD=/home/klaus
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=2372
:LANG=de_DE.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:LC_MEASUREMENT=de_DE.UTF-8
:GDMSESSION=cinnamon
:HISTCONTROL=ignoredups
:GPG_TTY=/dev/pts/2
:SHLVL=2
:HOME=/home/klaus
:XDG_SEAT=seat0
:SPELL=/usr/local/bin/spell
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=klaus
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-YYsAT2Dthb,guid=c7033dd8efa1c52923c4f2f400000037
:LC_CTYPE=de_DE.UTF-8
:MOZILLA_HOME=/opt/netscape
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/klaus
:DISPLAY=:0
:GTK_IM_MODULE=gtk-im-context-simple
:LC_TIME=de_DE.UTF-8
:LC_NAME=de_DE.UTF-8
:XAUTHORITY=/var/run/gdm/auth-for-klaus-BodaJa/database
:COLORTERM=gnome-terminal
:_=/usr/bin/qlandkartegt

var_log_messages:
:Apr 15 10:42:22 nepomuk kernel: [152398.351616] qlandkartegt[12139]: segfault at 8 ip 0000003162e87738 sp 00007fffc1702cb0 error 4 in libQtGui.so.4.8.0[3162a00000+a6d000]
:Apr 15 10:42:24 nepomuk abrt[12235]: Saved core dump of pid 12139 (/usr/bin/qlandkartegt) to /var/spool/abrt/ccpp-2012-04-15-10:42:22-12139 (142565376 bytes)

Comment 1 Klaus Lichtenwalder 2012-04-15 11:33:33 UTC
Created attachment 577512 [details]
File: dso_list

Comment 2 Klaus Lichtenwalder 2012-04-15 11:33:35 UTC
Created attachment 577513 [details]
File: build_ids

Comment 3 Klaus Lichtenwalder 2012-04-15 11:33:37 UTC
Created attachment 577514 [details]
File: maps

Comment 4 Klaus Lichtenwalder 2012-04-15 11:33:40 UTC
Created attachment 577515 [details]
File: backtrace

Comment 5 Dan Horák 2012-04-15 15:32:22 UTC
Thanks for the report, Klaus. Did the crash appear randomly or after some specific action? Are able to reproduce it? Anyway I will ask Oliver (author of qlandkartegt) to look at it.

Comment 6 Klaus Lichtenwalder 2012-04-15 17:38:06 UTC
Dan,

it looks like I'm able to reproduce it. After adding a Project to a database and then editing the diary, it seems to crash reliably...

Comment 7 Dan Horák 2012-04-16 10:10:55 UTC
Created attachment 577678 [details]
backtrace from rebuild with -O0

Comment 8 Fedora Update System 2012-04-16 12:20:05 UTC
qlandkartegt-1.4.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qlandkartegt-1.4.0-2.fc16

Comment 9 Fedora Update System 2012-04-16 12:20:14 UTC
qlandkartegt-1.4.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qlandkartegt-1.4.0-2.fc17

Comment 10 Fedora Update System 2012-04-16 12:20:21 UTC
qlandkartegt-1.4.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qlandkartegt-1.4.0-2.fc15

Comment 11 Fedora Update System 2012-04-16 21:56:34 UTC
Package qlandkartegt-1.4.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qlandkartegt-1.4.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5989/qlandkartegt-1.4.0-2.fc17
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2012-04-22 03:39:40 UTC
qlandkartegt-1.4.0-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-04-22 03:41:35 UTC
qlandkartegt-1.4.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2012-04-22 04:20:36 UTC
qlandkartegt-1.4.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.