Bug 812623 - update dependencies - libnuma was splitted out of numactl package
Summary: update dependencies - libnuma was splitted out of numactl package
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Laine Stump
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 812874
TreeView+ depends on / blocked
 
Reported: 2012-04-15 14:01 UTC by Petr Holasek
Modified: 2016-10-04 04:08 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 812874 (view as bug list)
Environment:
Last Closed: 2012-04-26 14:59:26 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Holasek 2012-04-15 14:01:55 UTC
Hi,

for reasons of saving space on liveCD, libnuma was splitted out of numactl
package to numactl-libs. Would you please update dependencies of your package
in this manner?

related bz: https://bugzilla.redhat.com/show_bug.cgi?id=799132

thank you!
Petr H

Comment 1 Laine Stump 2012-04-26 14:59:26 UTC
Currently libvirt only has the following related to numactl:

%if %{with_numactl}
# For QEMU/LXC numa info
BuildRequires: numactl-devel
%endif

so it never directly requires numactl at install/runtime anyway. I assume it's just getting the libs it requires due to the implied dependency created by linking to libnuma.so

To verify, on my f17 system which is more or less identical to rawhide from libvirt's point of view) I just removed the numactl package, and it didn't complain about this breaking any dependency for libvirt (or any other package). On F16, on the other hand (where numactl-libs hasn't been split off from numactl), when I attempt to remove the numactl package, I'm told that this would also necessarily remove libvirt.

I'm closing this. Please re-open if I've missed some detail.


Note You need to log in before you can comment on or make changes to this bug.