Bug 812874 - update dependencies - libnuma was splitted out of numactl package
update dependencies - libnuma was splitted out of numactl package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Laine Stump
Fedora Extras Quality Assurance
: Reopened
Depends On: 812623
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 09:14 EDT by Petr Holasek
Modified: 2012-06-30 18:04 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 812623
Environment:
Last Closed: 2012-06-30 18:04:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Holasek 2012-04-16 09:14:22 EDT
+++ This bug was initially created as a clone of Bug #812623 +++

Hi,

for reasons of saving space on liveCD, libnuma was splitted out of numactl
package to numactl-libs. Would you please update dependencies of your package
in this manner?

related bz: https://bugzilla.redhat.com/show_bug.cgi?id=799132

new numactl package is tagged as f17-override

thank you!
Petr H
Comment 1 Laine Stump 2012-04-26 10:59:33 EDT
Currently libvirt only has the following related to numactl:

%if %{with_numactl}
# For QEMU/LXC numa info
BuildRequires: numactl-devel
%endif

so it never directly requires numactl at install/runtime anyway. I assume it's just getting the libs it requires due to the implied dependency created by linking to libnuma.so

To verify, on my f17 system which is more or less identical to rawhide from libvirt's point of view) I just removed the numactl package, and it didn't complain about this breaking any dependency for libvirt (or any other package). On F16, on the other hand (where numactl-libs hasn't been split off from numactl), when I attempt to remove the numactl package, I'm told that this would also necessarily remove libvirt.

I'm closing this. Please re-open if I've missed some detail.
Comment 2 Eric Blake 2012-05-08 18:44:04 EDT
We may have missed one detail: on F17, we must build against the new devel package.  See also https://www.redhat.com/archives/libvir-list/2012-May/msg00425.html

In libvirt.spec.in, we have:

# Numactl is not available on s390[x] and ARM
%ifarch s390 s390x %{arm}
%define with_numactl 0
%endif

# numad is used to manage the CPU placement dynamically,
# it's not available on s390[x] and ARM.
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 6
%ifnarch s390 s390x %{arm}
%define with_numad    0%{!?_without_numad:%{server_drivers}}
%endif
%endif
%endif

%if %{with_numactl}
# For QEMU/LXC numa info
BuildRequires: numactl-devel
%endif

%if %{with_numad}
BuildRequires: numad
%endif

%if %{with_numad}
Requires: numad
%endif

If I understand correctly, configure needs to know the location of the numad binary, but also needs to link against the numactl libraries, in order for numa tuning to work.
Comment 3 Eric Blake 2012-05-09 15:59:16 EDT
Although numad support was first added added to 0.9.11, it won't work well unless we also backport the additional numad cleanups that are going into 0.9.12, ending with this commit:
commit b0f3244554b7b67183615a353897a2e19e0c6d68
Author: Osier Yang <jyang@redhat.com>
Date:   Wed May 9 12:22:58 2012 +0800

    numad: Check numactl-devel if compiled with numad support
    
    Since now we pre-set memory policy using libnuma to fully
    drive numad, it needs to check numactl-devel if "with_numad"
    is "yes".
    
    configure with groups "--with-numad=yes --with-numactl=yes",
    "--with-numad=no --with-numactl=yes", "--with-numad=yes
    --with-numactl=yes" works fine after the change.
Comment 4 Fedora Update System 2012-06-15 16:30:35 EDT
libvirt-0.9.11.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.4-1.fc17
Comment 5 Fedora Update System 2012-06-16 19:56:28 EDT
Package libvirt-0.9.11.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.9.11.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9549/libvirt-0.9.11.4-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-06-19 11:29:47 EDT
libvirt-0.9.11.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.4-2.fc17
Comment 7 Fedora Update System 2012-06-28 10:05:29 EDT
libvirt-0.9.11.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.4-3.fc17
Comment 8 Fedora Update System 2012-06-30 18:04:58 EDT
libvirt-0.9.11.4-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.