Bug 812641 - cups: migration from /usr/lib/udev/devices/ to /usr/lib/tmpfiles.d/ needed
cups: migration from /usr/lib/udev/devices/ to /usr/lib/tmpfiles.d/ needed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 12:36 EDT by Kay Sievers
Modified: 2012-06-07 14:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: cups-1.5.2-12.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 00:14:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups static legacy /dev/lp[0-3] config (297 bytes, text/plain)
2012-04-15 12:36 EDT, Kay Sievers
no flags Details

  None (edit)
Description Kay Sievers 2012-04-15 12:36:08 EDT
Created attachment 577552 [details]
cups static legacy /dev/lp[0-3] config

Fedora 18 will no longer support /usr/lib/udev/devices/, because in the
future, it is generally discouraged to store any device nodes anywhere outside
of /dev. Any nodes installed in /usr/lib/udev/devices/ will not be copied
to /dev during bootup.

In case we still need to *unconditionally* support the /dev/lp* devices, and only
then, attached is a second tmpfiles.d/ snippet which should be dropped in:
  /usr/lib/tmpfiles.d/cups-lp.conf

Please also move the already existing:
  /etc/tmpfiles.d/cups.conf
to /usr/lib/. RPM packages should generally not install config fragments in
/etc, because /etc is reserved for the local administrator to overwrite the
config supplied by packages in /usr/lib/.

Thanks!
Comment 1 Jiri Popelka 2012-04-17 14:08:09 EDT
(In reply to comment #0)
> Created attachment 577552 [details]
> cups static legacy /dev/lp[0-3] config

Thanks!

> In case we still need to *unconditionally* support the /dev/lp* devices, and
> only
> then, attached is a second tmpfiles.d/ snippet which should be dropped in:
>   /usr/lib/tmpfiles.d/cups-lp.conf

Can we use this also in F17 ?

> Please also move the already existing:
>   /etc/tmpfiles.d/cups.conf
> to /usr/lib/. RPM packages should generally not install config fragments in
> /etc, because /etc is reserved for the local administrator to overwrite the
> config supplied by packages in /usr/lib/.

https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
probably needs some update.
Comment 2 Fedora Update System 2012-04-19 03:41:50 EDT
cups-1.5.2-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cups-1.5.2-12.fc17
Comment 3 Kay Sievers 2012-04-19 10:01:21 EDT
Sorry, I missed the question for some reason.

(In reply to comment #1)
> then, attached is a second tmpfiles.d/ snippet which should be dropped in:
> >   /usr/lib/tmpfiles.d/cups-lp.conf
> 
> Can we use this also in F17 ?

Yeah, that should already work in F17, but seem you found that out already. :)
 
> > Please also move the already existing:
> >   /etc/tmpfiles.d/cups.conf
> > to /usr/lib/. RPM packages should generally not install config fragments in
> > /etc, because /etc is reserved for the local administrator to overwrite the
> > config supplied by packages in /usr/lib/.
> 
> https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
> probably needs some update.

Yeah, nothing should recommend /etc for packaging of new things. But I can not
edit the page. That needs a ticket, I guess?
Comment 4 Fedora Update System 2012-04-19 22:25:09 EDT
Package cups-1.5.2-12.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.2-12.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6219/cups-1.5.2-12.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-05-07 00:14:44 EDT
cups-1.5.2-12.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 rvny 2012-06-07 14:21:35 EDT
(In reply to comment #5)
> cups-1.5.2-12.fc17 has been pushed to the Fedora 17 stable repository.  If
> problems still persist, please make note of it in this bug report.

Sea my bug:

https://bugzilla.redhat.com/show_bug.cgi?id=829431

Simple: not work!!!

[root@localhost]# cat /usr/lib/tmpfiles.d/cups-lp.conf# This file is part of cups.
#
# Legacy parallel port character device nodes, to trigger the
# auto-loading of the kernel module on access.
#
# See tmpfiles.d(5) for details

c /dev/lp0 0660 root lp - 6:0
c /dev/lp1 0660 root lp - 6:1
c /dev/lp2 0660 root lp - 6:2
c /dev/lp3 0660 root lp - 6:3
[root@localhost]# cat /etc/tmpfiles.d/cups.confcat: /etc/tmpfiles.d/cups.conf: No such file or directory
[root@localhost]# echo "from /var/log/messages"
from /var/log/messages
[root@localhost]# Jun  7 23:13:16 localhost kernel: [   31.659541] type=1400 audit(1339096387.115:4): avc:  denied  { create } for  pid=663 comm="systemd-tmpfile" name="lp0" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
[root@localhost]# getenforce
Enforcing
[root@localhost]# rpm -qi cups
Name        : cups
Epoch       : 1
Version     : 1.5.3
Release     : 2.fc17
Architecture: x86_64
Install Date: Thu Jun  7 23:11:00 2012
Group       : System Environment/Daemons
Size        : 9505130
License     : GPLv2
Signature   : RSA/SHA256, Mon May 28 19:53:40 2012, Key ID 50e94c991aca3465
Source RPM  : cups-1.5.3-2.fc17.src.rpm
Build Date  : Mon May 28 13:19:09 2012
Build Host  : x86-04.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.cups.org/
Summary     : Common Unix Printing System
Description :
The Common UNIX Printing System provides a portable printing layer for
UNIX® operating systems. It has been developed by Easy Software Products
to promote a standard printing solution for all UNIX vendors and users.
CUPS provides the System V and Berkeley command-line interfaces.
[root@localhost nargis]#

Note You need to log in before you can comment on or make changes to this bug.