Bug 829431 - Lp0 on cups stop working on cups
Lp0 on cups stop working on cups
Status: CLOSED DUPLICATE of bug 824059
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 13:51 EDT by rvny
Modified: 2012-06-07 08:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 08:57:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rvny 2012-06-06 13:51:16 EDT
Hello. Work fine cups with lp* port (device /dev/lp0). After latest updates, cups can't initialize device:

cat from /var/log/messages:

Jun  6 22:32:29 localhost kernel: [   26.634079] type=1400 audit(1339007538.074:4): avc:  denied  { create } for  pid=682 comm="systemd-tmpfile" name="lp0" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
Jun  6 22:32:29 localhost kernel: [   26.634181] type=1400 audit(1339007538.075:5): avc:  denied  { create } for  pid=682 comm="systemd-tmpfile" name="lp1" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
Jun  6 22:32:29 localhost kernel: [   26.634233] type=1400 audit(1339007538.075:6): avc:  denied  { create } for  pid=682 comm="systemd-tmpfile" name="lp2" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
Jun  6 22:32:29 localhost kernel: [   26.634283] type=1400 audit(1339007538.075:7): avc:  denied  { create } for  pid=682 comm="systemd-tmpfile" name="lp3" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file

[root@localhost]# service cups status                                                      
Redirecting to /bin/systemctl  status cups.service                                                            
cups.service - CUPS Printing Service                                                                          
          Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)
          Active: active (running) since Wed, 06 Jun 2012 22:34:15 +0400; 15min ago
        Main PID: 1984 (cupsd)
          CGroup: name=systemd:/system/cups.service
                  └ 1984 /usr/sbin/cupsd -f

[root@localhost]# ls /dev/lp*
ls: cannot access /dev/lp*: No such file or directory

Whereis /dev/lp* ?
Why I can't print and can't copy files into my printer?
Comment 1 rvny 2012-06-06 13:58:00 EDT
Who is so "successful" cross compile SELinux target policy? I change config to permisive, reboot, and cups initialize:

/var/log/messages:

Jun  6 22:53:14 localhost kernel: [   28.045970] type=1400 audit(1339008784.487:3): avc:  denied  { create } for  pid=654 comm="systemd-tmpfile" name="lp0" scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
Jun  6 22:53:14 localhost kernel: [   28.045998] type=1400 audit(1339008784.487:4): avc:  denied  { getattr } for  pid=654 comm="systemd-tmpfile" path="/dev/lp0" dev="devtmpfs" ino=12521 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
Jun  6 22:53:14 localhost kernel: [   28.046008] type=1400 audit(1339008784.487:5): avc:  denied  { setattr } for  pid=654 comm="systemd-tmpfile" name="lp0" dev="devtmpfs" ino=12521 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
Jun  6 22:53:14 localhost kernel: [   28.047999] type=1400 audit(1339008784.489:6): avc:  denied  { relabelfrom } for  pid=654 comm="systemd-tmpfile" name="lp0" dev="devtmpfs" ino=12521 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file

[root@localhost ~]# ls /dev/lp* -lZ
crw-rw----. root lp system_u:object_r:printer_device_t:s0 /dev/lp0
crw-rw----. root lp system_u:object_r:printer_device_t:s0 /dev/lp1
crw-rw----. root lp system_u:object_r:printer_device_t:s0 /dev/lp2
crw-rw----. root lp system_u:object_r:printer_device_t:s0 /dev/lp3
[root@localhost ~]#

When wait Patch? For again enable SELinux?
Comment 2 Jiri Popelka 2012-06-07 04:51:42 EDT
This is due to fixing of bug #812641.
Comment 3 Miroslav Grepl 2012-06-07 08:57:10 EDT

*** This bug has been marked as a duplicate of bug 824059 ***

Note You need to log in before you can comment on or make changes to this bug.