Bug 812651 - [abrt] wvdial-1.61-5.fc17: WvTaskMan::_stackmaster: Process /usr/bin/wvdial was killed by signal 6 (SIGABRT)
[abrt] wvdial-1.61-5.fc17: WvTaskMan::_stackmaster: Process /usr/bin/wvdial w...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libwvstreams (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Sekletar
Fedora Extras Quality Assurance
abrt_hash:7033d285b0e3a6bf0d9f23bbc78...
:
: 827419 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 14:23 EDT by Pedro Francisco
Modified: 2012-06-16 01:45 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 08:29:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (4.00 MB, text/plain)
2012-04-15 14:23 EDT, Pedro Francisco
no flags Details
File: maps (6.68 KB, text/plain)
2012-04-15 14:23 EDT, Pedro Francisco
no flags Details

  None (edit)
Description Pedro Francisco 2012-04-15 14:23:22 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        wvdial
comment:        Running `sudo wvdial` after having run `sudo wvdialconf`.
crash_function: WvTaskMan::_stackmaster
executable:     /usr/bin/wvdial
kernel:         3.3.1-5.fc17.i686.PAE
pid:            2110
pwd:            /home/pedro
remote_result:  NOTFOUND
time:           Sun 15 Apr 2012 05:29:28 PM WEST
uid:            0
username:       root
var_log_messages: Apr 15 17:29:29 sundaeII abrt[2111]: Saved core dump of pid 2110 (/usr/bin/wvdial) to /var/spool/abrt/ccpp-2012-04-15-17:29:28-2110 (1961984 bytes)

backtrace:      Text file, 4194304 bytes
maps:           Text file, 6840 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/pedro/2

core_backtrace:
:6b03a4d22ac49a27e3a61d9ce17943e7e74418f0 0x424 __kernel_vsyscall linux-gate.so.1 -
:8977b8492e9b9e203c5e53dccd30adf441420b99 0x2e91f raise libc.so.6 -
:8977b8492e9b9e203c5e53dccd30adf441420b99 0x30273 abort libc.so.6 -
:eb07fc6d1f5ae1f9459a4524e607cde0493a119c 0x63083 __assert_fail libwvbase.so.4.6 -
:eb07fc6d1f5ae1f9459a4524e607cde0493a119c 0x3a915 WvTaskMan::_stackmaster() libwvbase.so.4.6 -
:1a93fbfbc1b232266f1b7ead864ae30a009879a4 0x4c668 operator libstdc++.so.6 -
:eb07fc6d1f5ae1f9459a4524e607cde0493a119c 0x3a54a WvTaskMan::start(WvFastString libwvbase.so.4.6 -
:eb07fc6d1f5ae1f9459a4524e607cde0493a119c 0x2d2cc WvCont::operator()(void*) libwvbase.so.4.6 -
:eb07fc6d1f5ae1f9459a4524e607cde0493a119c 0x46ad6 std::tr1::_Function_handler<void* libwvbase.so.4.6 -
:eb07fc6d1f5ae1f9459a4524e607cde0493a119c 0x2e4c9 std::tr1::function<void* libwvbase.so.4.6 -
:eb07fc6d1f5ae1f9459a4524e607cde0493a119c 0x45c13 WvStream::callback() libwvbase.so.4.6 -
:42b8585bdf8f28fdec798d7457d2fd42afbcd756 0x5563 - [exe] -

dso_list:
:/usr/lib/libwvbase.so.4.6 libwvstreams-4.6.1-4.fc17.i686 (Fedora Project) 1334409638
:/usr/lib/libuniconf.so.4.6 libwvstreams-4.6.1-4.fc17.i686 (Fedora Project) 1334409638
:/usr/lib/libselinux.so.1 libselinux-2.1.9-9.fc17.i686 (Fedora Project) 1334408713
:/usr/lib/libpthread-2.15.so glibc-2.15-32.fc17.i686 (Fedora Project) 1334408708
:/usr/lib/libstdc++.so.6.0.17 libstdc++-4.7.0-1.fc17.i686 (Fedora Project) 1334408716
:/usr/lib/libz.so.1.2.5 zlib-1.2.5-6.fc17.i686 (Fedora Project) 1334408716
:/usr/lib/liblockdev.so.1.0.0 lockdev-1.0.4-0.4.20111007git.fc17.i686 (Fedora Project) 1334410121
:/usr/lib/libwvutils.so.4.6 libwvstreams-4.6.1-4.fc17.i686 (Fedora Project) 1334409638
:/usr/lib/libkrb5.so.3.3 krb5-libs-1.10-5.fc17.i686 (Fedora Project) 1334408930
:/usr/lib/libtinfo.so.5.9 ncurses-libs-5.9-4.20120204.fc17.i686 (Fedora Project) 1334408710
:/usr/lib/libkeyutils.so.1.4 keyutils-libs-1.5.5-2.fc17.i686 (Fedora Project) 1334408929
:/usr/lib/libm-2.15.so glibc-2.15-32.fc17.i686 (Fedora Project) 1334408708
:/usr/lib/libcrypto.so.1.0.0h openssl-1:1.0.0h-1.fc17.i686 (Fedora Project) 1334409317
:/usr/lib/libfreebl3.so nss-softokn-freebl-3.13.4-1.fc17.i686 (Fedora Project) 1334490316
:/usr/lib/libcrypt-2.15.so glibc-2.15-32.fc17.i686 (Fedora Project) 1334408708
:/usr/lib/libkrb5support.so.0.1 krb5-libs-1.10-5.fc17.i686 (Fedora Project) 1334408930
:/usr/lib/libreadline.so.6.2 readline-6.2-4.fc17.i686 (Fedora Project) 1334408745
:/usr/lib/libk5crypto.so.3.1 krb5-libs-1.10-5.fc17.i686 (Fedora Project) 1334408930
:/usr/lib/libcom_err.so.2.1 libcom_err-1.42-2.fc17.i686 (Fedora Project) 1334408725
:/usr/lib/ld-2.15.so glibc-2.15-32.fc17.i686 (Fedora Project) 1334408708
:/usr/lib/libgssapi_krb5.so.2.2 krb5-libs-1.10-5.fc17.i686 (Fedora Project) 1334408930
:/usr/lib/libssl.so.1.0.0h openssl-1:1.0.0h-1.fc17.i686 (Fedora Project) 1334409317
:/usr/lib/libwvstreams.so.4.6 libwvstreams-4.6.1-4.fc17.i686 (Fedora Project) 1334409638
:/usr/lib/libc-2.15.so glibc-2.15-32.fc17.i686 (Fedora Project) 1334408708
:/usr/bin/wvdial wvdial-1.61-5.fc17.i686 (Fedora Project) 1334420066
:/usr/lib/libresolv-2.15.so glibc-2.15-32.fc17.i686 (Fedora Project) 1334408708
:/usr/lib/libdl-2.15.so glibc-2.15-32.fc17.i686 (Fedora Project) 1334408708
:/usr/lib/libgcc_s-4.7.0-20120322.so.1 libgcc-4.7.0-1.fc17.i686 (Fedora Project) 1334408687

environ:
:HOSTNAME=sundaeII
:TERM=xterm
:HISTSIZE=1000
:QTDIR=/usr/lib/qt-3.3
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:USERNAME=pedro
:MAIL=/var/spool/mail/pedro
:LANG=en_US.UTF-8
:DISPLAY=:0
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-pedro-8U9zI5/database
:SHELL=/bin/bash
:LOGNAME=root
:USER=root
:PATH=/sbin:/bin:/usr/sbin:/usr/bin
:HOME=/root
:SUDO_COMMAND=/bin/wvdial
:SUDO_USER=pedro
:SUDO_UID=1000
:SUDO_GID=1000

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 unlimited            processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15935                15935                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/0
:pos:	0
:flags:	02
:1:/dev/pts/0
:pos:	0
:flags:	02
:2:/dev/pts/0
:pos:	0
:flags:	02
:3:/dev/pts/0
:pos:	0
:flags:	02
:4:/dev/ttyACM0
:pos:	0
:flags:	02104002

smolt_data:
:
:
:General
:=================================
:UUID: c547e0f8-8b76-4a21-8603-b9d5d9409c4d
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 2992.80
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     T5250  @ 1.50GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 1500
:System Memory: 2008
:System Swap: 2502
:Vendor: Hewlett-Packard
:System: HP Pavilion dv6500 Notebook PC Rev 1
:Form factor: Notebook
:Kernel: 3.3.1-5.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4332:33078:4156:12492) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10752:4156:12492) pci, agpgart-intel, HOST/PCI, Mobile PM965/GM965/GL960 Memory Controller Hub
:(32902:10302:4156:12492) pci, None, SERIAL, 82801H (ICH8 Family) SMBus Controller
:(32902:10281:4156:12492) pci, ahci, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller
:(32902:10320:4156:12492) pci, ata_piix, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller
:(32902:10261:4156:12492) pci, None, PCI/ISA, 82801HEM (ICH8M) LPC Interface Controller
:(32902:16930:4156:4956) pci, iwl3945, NETWORK, Compaq 6710b or nx9420 Notebook
:(32902:10289:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #2
:(32902:9288:4156:12492) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10290:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #3
:(32902:10294:4156:12492) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #1
:(32902:10298:4156:12492) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #2
:(32902:10754:4156:12492) pci, i915, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (primary)
:(32902:10755:4156:12492) pci, None, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (secondary)
:(32902:10303:4156:12492) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10305:4156:12492) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 2
:(32902:10315:4156:12492) pci, snd_hda_intel, MULTIMEDIA, 82801H (ICH8 Family) HD Audio Controller
:(32902:10292:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #4
:(32902:10288:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #1
:(32902:10313:4156:12492) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 6
:(4480:2098:4156:12492) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:4156:12492) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4480:1426:4156:12492) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(4480:2130:4156:12492) pci, None, BASE, xD-Picture Card Controller
:(32902:10293:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda6 / ext4 4096 4096 3833262 2076595 2038212 966656 754587 754587
:/dev/sda5 /boot ext2 1024 1024 495759 443582 417880 128520 128246 128246
:/dev/sda8 /home ext4 4096 4096 19072132 3323379 2368215 4775936 4193561 4193561
:
Comment 1 Pedro Francisco 2012-04-15 14:23:51 EDT
Created attachment 577573 [details]
File: backtrace
Comment 2 Pedro Francisco 2012-04-15 14:23:54 EDT
Created attachment 577574 [details]
File: maps
Comment 3 Account closed by user 2012-05-31 10:41:47 EDT
ping!
Comment 4 Michal Sekletar 2012-06-01 08:53:49 EDT
*** Bug 827419 has been marked as a duplicate of this bug. ***
Comment 5 Michal Sekletar 2012-06-03 08:03:06 EDT
This bug is caused by impairment in libwvstreams, thus changing Component to libwvstreams.
Comment 6 Michal Sekletar 2012-06-04 03:49:04 EDT
I think this bug is caused by optimizations done by new gcc version. I've applied a patch and recompiled libwvstreams package in rawhide[1]. You can download libwvstreams and try it out, your feedback will be greatly appreciated.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=4124838
Comment 7 Account closed by user 2012-06-07 08:43:32 EDT
(In reply to comment #6)

> I think this bug is caused by optimizations done by new gcc version. I've
> applied a patch and recompiled libwvstreams package in rawhide[1]. You can
> download libwvstreams and try it out, your feedback will be greatly
> appreciated.
> 
> [1] http://koji.fedoraproject.org/koji/taskinfo?taskID=4124838

libwvstreams-4.6.1-4 (original release)

--> Modem initialized.
wvdial: utils/wvtask.cc:409: static void WvTaskMan::_stackmaster(): Assertion `magic_number == -0x123678' failed.
Aborted (core dumped)


libwvstreams-4.6.1-5 (new release with wvstreams-4.6.1-magic.patch)

--> Modem initialized.
Segmentation fault (core dumped)

dmesg:
[  809.160784] wvdial[8871]: segfault at 20004 ip 4ba8c783 sp bfdbe000 error 4 in libwvbase.so.4.6[4ba54000+7d000]
Comment 8 Nandan Bhat 2012-06-07 10:19:10 EDT
I am sorry to be contributing patchy information, but I didn't have any luck with the koji package.

My setup is an HP Pavilion dv6 laptop / 4 GB RAM / 320 GB HDD with Fedora 17 x86_64 installed from DVD. 

I am away from my regular internet connectivity options and only a bare basic F17 with a Tata Photon Plus (Huawei EC156) is what I have. I have seen the error above (magic number ... failed ... (core dumped).

I downloaded the koji rpm from another GPRS connection and tried to apply it with rpm -Uvh libwvstreams-4.6.1-5.fc18.x86_64.rpm. Unfortunately, it kept telling me I needed libssl.so.10 and libcrypto.so.10 (from memory; might be off a little). My base F17 does have openssl package that has the required libraries. So I tried using rpm -Uvh --force --nodeps libwvstreams-4.6.1-5.fc18.x86_64.rpm. There is no change in the error message that I see (core dumped).

Only two extra warnings that version information is not available for libssl and libcrypto (probably because of my --force and --nodeps options).

I should be back to regular connectivity in a couple of days. But my question is - is there any special stuff I need to do (like enable rawhide yum repo) before trying this rpm install again?
Comment 9 Jim Minter 2012-06-07 11:41:56 EDT
Michal, the rawhide libwvstreams-4.6.1-5 you link to is uninstallable on f17:

[root@jminter ~]# rpm -U libwvstreams-4.6.1-5.fc18.x86_64.rpm 
error: Failed dependencies:
	libcrypto.so.10(libcrypto.so.10)(64bit) is needed by libwvstreams-4.6.1-5.fc18.x86_64
	libssl.so.10(libssl.so.10)(64bit) is needed by libwvstreams-4.6.1-5.fc18.x86_64

I downloaded the src.rpm and compiled it locally for fc17.  wvdial got a bit further and the error message changed.  Previously it was aborting on magic_number == -0x123678 ; now it's aborting later on with *current_task->stack_magic == 0x123678.

Previously: (libwvstreams-4.6.1-4.fc17.x86_64.rpm)

[root@jminter ~]# wvdial
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CSQ
AT+CSQ
+CSQ: 2,99
OK
--> Sending: AT+CGDCONT=1,"IP","internet"
AT+CGDCONT=1,"IP","internet"
OK
--> Modem initialized.
wvdial: utils/wvtask.cc:409: static void WvTaskMan::_stackmaster(): Assertion `magic_number == -0x123678' failed.
Aborted


Now: (libwvstreams-4.6.1-5.fc17.x86_64.rpm)

[root@jminter ~]# wvdial
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CSQ
AT+CSQ
+CSQ: 8,99
OK
--> Sending: AT+CGDCONT=1,"IP","internet"
AT+CGDCONT=1,"IP","internet"
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
CONNECT 7200000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Thu Jun  7 16:22:22 2012
--> Pid of pppd: 9228
wvdial: utils/wvtask.cc:304: static int WvTaskMan::yield(int): Assertion `*current_task->stack_magic == 0x123678' failed.
Aborted
Comment 10 Michal Sekletar 2012-06-08 02:58:21 EDT
Thanks everyone for valueable feedback, to be honest I have looked at the backtrace provided in Description and isolated module in libwvstreams where this bug resides, created some minimal example use case of this module and tested it, I got the same error message as the one in Description, patch I came up with helped in my case so I thought it might help you guys as well, as it turned out it didn't. Please bare with me, I will try to investigate further. Thank you for your patience.
Comment 11 Michal Sekletar 2012-06-08 08:28:08 EDT
Just a quick update. Looks like this will be tough one and it will take me some time to pin down what's wrong here. I've tried to run test wvstreams-4.6.1/utils/tests/tasktest and it's doing something different with every version of libwvstreams package I've tried (f15, f16, f17, rawhide), my only explanation is that behaviour of library, in particular of module wvtask.cc, is highly dependent on compiler version. Gdb is not helping as much as it could because stack get's smashed by jumping around (getcontext(), setcontext()) and library behaves pretty much randomly in every package version.
Comment 12 Anielkis 2012-06-10 17:31:26 EDT
Michal, I had updated to the libwvstreams-4.6.1-5, and it aborted with segfault.. so I used gdb to debug and found this ... maybe this can help to fix the error

$ gdb wvdial
GNU gdb (GDB) Fedora (7.4.50.20120120-42.fc17)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/wvdial...(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install wvdial-1.61-5.fc17.i686
(gdb) run cult
Starting program: /usr/bin/wvdial cult
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT S7=45 S0=0 L1 V1 X4 &C1 &D2 +FCLASS=0 E1 Q0
AT S7=45 S0=0 L1 V1 X4 &C1 &D2 +FCLASS=0 E1 Q0
OK
--> Modem initialized.

Program received signal SIGSEGV, Segmentation fault.
0xb7d50503 in WvTaskMan::do_task () at utils/wvtask.cc:501
501		    assert(task->magic_number == WVTASK_MAGIC);
(gdb) break 477
Breakpoint 1 at 0xb7d504b2: file utils/wvtask.cc, line 477.
(gdb) run cult
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /usr/bin/wvdial cult
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT S7=45 S0=0 L1 V1 X4 &C1 &D2 +FCLASS=0 E1 Q0
AT S7=45 S0=0 L1 V1 X4 &C1 &D2 +FCLASS=0 E1 Q0
OK
--> Modem initialized.

Breakpoint 1, WvTaskMan::do_task () at utils/wvtask.cc:477
477	    context_return = 0;
(gdb) watch task->magic_number
Watchpoint 2: task->magic_number
(gdb) print task->magic_number
$1 = 1193592
(gdb) n
478	    assert(getcontext(&task->mystate) == 0);
(gdb) n
Watchpoint 2: task->magic_number

Old value = 1193592
New value = <unreadable>
0xb7d504bf in WvTaskMan::do_task () at utils/wvtask.cc:478
478	    assert(getcontext(&task->mystate) == 0);
(gdb) n
479	    if (context_return == 0)
(gdb) n
538	}
(gdb) n

Watchpoint 2 deleted because the program has left the block in
which its expression is valid.

Watchpoint 2 deleted because the program has left the block in
which its expression is valid.

Watchpoint 2 deleted because the program has left the block in
which its expression is valid.
WvTaskMan::_stackmaster () at utils/wvtask.cc:440
440		    assert(magic_number == -WVTASK_MAGIC);
(gdb) n
446	            stack_target->stack_magic = (int *)alloca(sizeof(int));
(gdb) n
447	            *stack_target->stack_magic = WVTASK_MAGIC;
(gdb) n
410		assert(magic_number == -WVTASK_MAGIC);
(gdb) n
413	        assert(getcontext(&stackmaster_task) == 0);
(gdb) n
412	        context_return = 0;
(gdb) n
413	        assert(getcontext(&stackmaster_task) == 0);
(gdb) n
415		if (val == 0)
(gdb) n
417		    assert(magic_number == -WVTASK_MAGIC);
(gdb) n
423	            setcontext(&get_stack_return);
(gdb) n
422	            context_return = 1;
(gdb) n
423	            setcontext(&get_stack_return);
(gdb) n

Program received signal SIGSEGV, Segmentation fault.
0xb7d50503 in WvTaskMan::do_task () at utils/wvtask.cc:501
501		    assert(task->magic_number == WVTASK_MAGIC);
(gdb)
Comment 13 Nandan Bhat 2012-06-11 01:49:16 EDT
My problem is temporarily fixed with a workaround. I have gone ahead and installed the packages available from Fedora 16 DVD and I was able to connect like before.

The packages I removed were:

   libwvstreams-4.6.1-4.fc17.x86_64
   wvdial-1.61-5.fc17.x86_64

The packages I installed were:

   libwvstreams-4.6.1-3.fc15.x86_64.rpm
   wvdial-1.61-4.fc15.x86_64.rpm

Maybe that should help people until working packages are available.
Comment 14 Fabrice Bellet 2012-06-12 03:28:23 EDT
after bissecting the optimizations used by gcc in -O2 mode, it seems to me that the problem is caused by two specific ones : -ftree-dce and -foptimize-sibling-calls

Reverting these two options generates a library that works for me (not with wvdial, but with another application --retchmail-- that shows the same error message with the version of libwvstreams compiled with gcc-4.7.0):

$RPM_OPT_FLAGS -fPIC -fpermissive -fno-strict-aliasing -fno-tree-dce -fno-optimize-sibling-calls

HTH
Comment 15 Philippe Troin 2012-06-13 20:58:25 EDT
(In reply to comment #14)
> after bissecting the optimizations used by gcc in -O2 mode, it seems to me
> that the problem is caused by two specific ones : -ftree-dce and
> -foptimize-sibling-calls

Yes, thanks Fabrice!

I confirm that adding these two gcc options fixes the wvdial problem for me.
No more SIGABRTs.

If anyone else is stuck with this, I have made f17 packages available at:
http://rpm.fifi.org/f17-fifi/x86_64/repoview/libwvstreams.html

Phil.
Comment 16 Account closed by user 2012-06-14 07:51:39 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > after bissecting the optimizations used by gcc in -O2 mode, it seems to me
> > that the problem is caused by two specific ones : -ftree-dce and
> > -foptimize-sibling-calls
> 
> Yes, thanks Fabrice!
> 
> I confirm that adding these two gcc options fixes the wvdial problem for me.
> No more SIGABRTs.
> 
> If anyone else is stuck with this, I have made f17 packages available at:
> http://rpm.fifi.org/f17-fifi/x86_64/repoview/libwvstreams.html
> 
> Phil.

http://koji.fedoraproject.org/koji/buildinfo?buildID=325182 tested on f17 and it works flawlessly. Please, do a f17 update.
Comment 17 Michal Sekletar 2012-06-14 07:53:09 EDT
New package builds are available. Fabrice thank you for pointing out problematic optimizations, I appreciate your assistance.

[f17] http://koji.fedoraproject.org/koji/taskinfo?taskID=4161572
[f18] http://koji.fedoraproject.org/koji/taskinfo?taskID=4161427
Comment 18 Fedora Update System 2012-06-14 08:07:46 EDT
libwvstreams-4.6.1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libwvstreams-4.6.1-6.fc17
Comment 19 Fedora Update System 2012-06-15 08:29:47 EDT
libwvstreams-4.6.1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Nandan Bhat 2012-06-16 01:45:51 EDT
I can use my USB dongle with these packages:
   
   libwvstreams-4.6.1-6.fc17.x86_64.rpm
   wvdial-1.61-5.fc17.x86_64.rpm
   

Thanks for the updates.

Note You need to log in before you can comment on or make changes to this bug.