This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 812660 - Not work Fuse and Fuse-NTFS-3g
Not work Fuse and Fuse-NTFS-3g
Status: CLOSED DUPLICATE of bug 812669
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 15:37 EDT by rvny
Modified: 2012-04-16 00:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 00:18:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rvny 2012-04-15 15:37:01 EDT
Hello. I upgrade from F16 -> F17. All works fine, but I forgot start last command on update:

#fixfiles onboot

After reboot, now I have a very unpleasant! I can't mount ntfs partitions!

In dolphin error:
Error mounting: mount exited with exit code 1: helper failed with:
Error opening '/dev/sdc1': Permission denied
Failed to mount '/dev/sdc1': Permission denied
Please check '/dev/sdc1' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

That's i probe:
1. I disabled SE linux in /etc/selinux/config to enforcing
2. I probe #fixfiles restory
and
#fixfiles -C PREVIOUS_FILECONTEXT restore onboot
3. Reinstall ntfs-3g and fuse with:
#yum reinstall ntfs-3g fuse
4. I reinstall all packages with:
#rpm -qf >allrpm.txt
#yum reinstall `cat allrpm.txt` -y
5. Setup chmod 777 to /dev/sdc1
6. Probe setup GID/UID bit to ntfs-3g
7. Probe download and compile ntfs-3g from sources:
#[root@localhost ntfs-3g_ntfsprogs-2012.1.15]# export LANG=en_EN.UTF-8
[root@localhost ntfs-3g_ntfsprogs-2012.1.15]# mount -t ntfs-3g /dev/sdc1 /media
Failed to write lock '/dev/sdc1': Resource temporarily unavailable
Error opening '/dev/sdc1': Resource temporarily unavailable
Failed to mount '/dev/sdc1': Resource temporarily unavailable

How fix this without Reinstall Fedora 17? Becouse after update all work's are good! And mount ntfs under user!

----
boot.log

Starting FUSE Control File System...                                                                                                                                                                                                           
Failed to start FUSE Control File System                                                                                                                                                                                               [FAILED]
See 'systemctl status sys-fs-fuse-connections.mount' for details. 
-------
[root@localhost ntfs-3g_ntfsprogs-2012.1.15]# systemctl status sys-fs-fuse-connections.mount
sys-fs-fuse-connections.mount - FUSE Control File System
          Loaded: loaded (/usr/lib/systemd/system/sys-fs-fuse-connections.mount; static)
          Active: failed (Result: exit-code) since Sun, 15 Apr 2012 23:57:41 +0400; 37min ago
           Where: /sys/fs/fuse/connections
            What: fusectl
         Process: 728 ExecMount=/bin/mount fusectl /sys/fs/fuse/connections -t fusectl (code=exited, status=32)
          CGroup: name=systemd:/system/sys-fs-fuse-connections.mount
--------
/var/log/messages
Apr 15 23:59:18 localhost kernel: [   13.583213] fuse init (API version 7.18)
Apr 15 23:59:18 localhost kernel: [   13.587226] SELinux: (dev fusectl, type fusectl) has no xattr support
Comment 1 Peter Lemenkov 2012-04-16 00:18:40 EDT

*** This bug has been marked as a duplicate of bug 812669 ***

Note You need to log in before you can comment on or make changes to this bug.