Bug 812669 - Not work Fuse and Fuse-NTFS-3g
Not work Fuse and Fuse-NTFS-3g
Status: CLOSED DUPLICATE of bug 812798
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
: 812660 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 16:15 EDT by rvny
Modified: 2012-04-17 14:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 14:56:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Default RPM after install Gnome Default desktop from net install version (39.42 KB, text/plain)
2012-04-16 01:05 EDT, rvny
no flags Details
After latest updates. Ntfs-3g not work. (37.47 KB, text/plain)
2012-04-16 01:06 EDT, rvny
no flags Details

  None (edit)
Description rvny 2012-04-15 16:15:33 EDT
Hello. After update F16->F17 all works, but I forgot enter last command:

#fixfiles onboot

Now. I can't mount ntfs with ntfs-3g fuse.
Error in dolphin:

Error mounting: mount exited with exit code 1: helper failed with:
Failed to write lock '/dev/sda1': Resource temporarily unavailable
Error opening '/dev/sda1': Resource temporarily unavailable
Failed to mount '/dev/sda1': Resource temporarily unavailable

That I probe:

1. Disable SE linux in /etc/selinux/config to Permissive and with command #setenforce 0
2. Reinstall ntfs-3g fuse with #yum reinstall ntfs-3g fuse
3. Probe relabeling with #fixfiles -C PREVIOUS_FILECONTEXT restore onboot
4. Reinstall all rpm: #rpm -qa >>allrpm.txt && yum reinstall `cat allrpm.txt` -y
5. Set permissions chmod 777 /dev/sda1
6. Setup GID/UID to /bin/ntfs-3g
7. Download and compile new ntfs-3g from sources. Then I probe mount I have errror:

mount /dev/sda1 /media
Failed to write lock '/dev/sda1': Resource temporarily unavailable
Error opening '/dev/sda1': Resource temporarily unavailable
Failed to mount '/dev/sda1': Resource temporarily unavailable


How fix It without reinstall??


------
/var/log/boot.log

Starting FUSE Control File System...                                                                                                                                                                                                           
Failed to start FUSE Control File System                                                                                                                                                                                               [FAILED]
See 'systemctl status sys-fs-fuse-connections.mount' for details.  

----

[root@localhost ntfs-3g_ntfsprogs-2012.1.15]# systemctl status sys-fs-fuse-connections.mount
sys-fs-fuse-connections.mount - FUSE Control File System
          Loaded: loaded (/usr/lib/systemd/system/sys-fs-fuse-connections.mount; static)
          Active: failed (Result: exit-code) since Sun, 15 Apr 2012 23:57:41 +0400; 1h 16min ago
           Where: /sys/fs/fuse/connections
            What: fusectl
         Process: 728 ExecMount=/bin/mount fusectl /sys/fs/fuse/connections -t fusectl (code=exited, status=32)
          CGroup: name=systemd:/system/sys-fs-fuse-connections.mount

-----
/var/log/messages

Apr 15 23:59:18 localhost kernel: [   13.583213] fuse init (API version 7.18)
Apr 15 23:59:18 localhost kernel: [   13.587226] SELinux: (dev fusectl, type fusectl) has no xattr support
Comment 1 rvny 2012-04-15 22:19:36 EDT
Maybe it's similar bug?

http://forums.fedoraforum.org/showthread.php?p=1569823
Comment 2 Peter Lemenkov 2012-04-16 00:18:40 EDT
*** Bug 812660 has been marked as a duplicate of this bug. ***
Comment 3 rvny 2012-04-16 01:05:58 EDT
Created attachment 577623 [details]
Default RPM after install Gnome Default desktop from net install version
Comment 4 rvny 2012-04-16 01:06:37 EDT
Created attachment 577624 [details]
After latest updates. Ntfs-3g not work.
Comment 5 Edward Sheldrake 2012-04-16 02:43:47 EDT
ntfs-3g was not working with selinux in permissive mode, but I booted with selinux properly disabled by selinux=0 on the kernel command line, which solved the problem.

Ironically, I had always been using selinux=0 until a couple of weeks ago.
Comment 6 rvny 2012-04-16 03:10:22 EDT
(In reply to comment #5)
> ntfs-3g was not working with selinux in permissive mode, but I booted with
> selinux properly disabled by selinux=0 on the kernel command line, which solved
> the problem.
> 
> Ironically, I had always been using selinux=0 until a couple of weeks ago.

Yes you are right: with Permissive or Enforcing not work!
With Disabled - worked. I use SElinux in Fedora!

I think this is serious Bug, becouse F16 work correctly wigh SELinux and ntfs-3g + fuse.

Wait bugfix?
Comment 7 Edward Sheldrake 2012-04-16 12:26:31 EDT
See #812798
Comment 8 rvny 2012-04-17 10:38:08 EDT
#rpm -e selinux-policy-3.10.0-114.fc17.noarch selinux-policy-targeted-3.10.0-114.fc17.noarch
#rpm -ihv selinux-policy-3.10.0-110.fc17.noarch.rpm  selinux-policy-targeted-3.10.0-110.fc17.noarch.rpm 
# cat /etc/selinux/config | grep SELINUX
SELINUX=permissive
# SELINUXTYPE= can take one of these two values:
SELINUXTYPE=targete
#reboot

After downgrade selinux to .110 version from 114, fuse Ntfs-3g work on file manager's. This bug can fixed on selinux policy update.
Comment 9 Tom "spot" Callaway 2012-04-17 14:56:08 EDT

*** This bug has been marked as a duplicate of bug 812798 ***

Note You need to log in before you can comment on or make changes to this bug.