Bug 81273 - Fonts not set to iso-8859-2
Fonts not set to iso-8859-2
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 88253 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-07 09:17 EST by Miloslav Trmac
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-29 16:43:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2003-01-07 09:17:03 EST
Description of problem:
Clean install of Phoebe in Czech, cs_CZ.UTF-8
When Evolution starts, it uses ISO-8859-1 fonts and replaces all
ISO-8859-2 chars by underscores. Some of the problems can be
fixed by selecting ISO-8859-2 encoding for screen fonts in
the settings dialog (note that printing fonts already have
ISO-8859-2), but some (e.g. fonts used in the summary view)
don't have a GUI way to change the encoding.

Another bug: In the icon listbox at the left of the settings dialog,
the labels are cut off after accented characters (e.g.
Nastaven instead of Nastaven&icaron; )

Version-Release number of selected component (if applicable):
evolution-1.2.1-2
Comment 1 Jeremy Katz 2003-01-22 22:53:52 EST
I'm not seeing this here -- did you have settings leftover from a previous release?
Comment 2 Miloslav Trmac 2003-01-23 04:11:43 EST
No, clean install with new /home.
A screenshot showing one the problems in the summary view is at
http://www.linuxzone.cz/pictures/Plocha.gif
(Moje po_asi etc).
[I haven't found a way to set up *this* font right. Similar underscores
appear in the config dialog and elsewhere, and some of them can be fixed
as described above].
I'll try to attach more tomorrow, and try the second beta in a week or so.
Comment 3 Martin Sitar 2003-01-24 07:38:58 EST
The same problem in clean install of Red Hat Linux release 8.0.93 (Phoebe) (beta2)
Package evolution-1.2.1-4
Comment 4 Jeremy Katz 2003-02-09 22:16:55 EST
Does this seem better with gtkhtml-1.1.8-1 and evolution 1.2.2 from rawhide?
Comment 5 Martin Sitar 2003-02-10 03:26:39 EST
Yes, fonts look pretty good with this release of evolution and gtkhtml.
I haven`t find any other bug yet .. 
Comment 6 Martin Sitar 2003-02-10 03:49:28 EST
Additionally I found one bug in Settings menu fonts. 
<a href="http://hch.internet.cz/download/sets.png">screenshot</a>
Comment 7 Martin Sitar 2003-02-11 03:40:40 EST
With gtkhtml-1.1.8-3.i386.rpm from todays rawhide is everything once again wrong.
ISO-8859-2 encoding in summary page and Subject of messages are with underscores
without appropriate chracter.
Comment 8 Miloslav Trmac 2003-02-14 15:39:01 EST
clean phoebe 8.0.93 install in cs_CZ.UTF-8 + evolution-1.2.2-1, gtkhtml-1.1.8-3:
- the default *screen* font is still 8859-1;
  note that default default *print* font is 8859-2. IIRC, the defaults (-1 for
  screen, -2 for print) haven't changed
- before changing the default, non-8859-1 chars show as _
- after changing the default, thinks look pretty much OK,
  even the summary view (this is better since my previous report).
  The only problem I have noticed is the icon bar in the Settings dialog
  (see the second screenshot link from Martin)
Comment 9 Jeremy Katz 2003-04-08 20:36:09 EDT
*** Bug 88253 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2003-06-29 16:43:33 EDT
UTF-8 should be handled sanely with 1.4.x in rawhide.
Comment 11 Stephane Jourdan 2003-06-29 17:31:24 EDT
I confirm Evolution 1.4 doesn't have this problem anymore, I didn't test the
current rawhide version but the version available at the maintainer's homepage
on people.redhat.com/~katzj on both clean and old RH9 installs.

That's good news !  

Note You need to log in before you can comment on or make changes to this bug.