Bug 812941 - pulseaudio daemon fails to start (in KDE)
pulseaudio daemon fails to start (in KDE)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 12:02 EDT by Lloyd Matthews
Modified: 2013-02-13 11:24 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 11:24:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lloyd Matthews 2012-04-16 12:02:37 EDT
Description of problem:
This started with an update to kdelibs back on 4/9/12.  Previously for at least the past 1.5 years there have been no problems with sound hardware detection. 
I boot up and log in to KDE and I get a KDE error pop up "Remove Sound
Devices" that states that certain devices are no longer available and would I
like to have them removed.  I also get a KDE notification balloon that states
that HDA NVidia ALC883 does not work and it is falling back to "default".


Version-Release number of selected component (if applicable):


How reproducible:
Happens every time I boot or reboot and go directly into kde.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

If I log into Gnome first after a boot, then log out of Gnome and into KDE, everything is fine.  The system settings for sound shows "Internal Audio Analog Stereo".

I deleted hardwaredatabase file from /var/tmp/kde-cache-LPM/libphonon and rebooted, but I got the same pop up at the KDE desktop.  I did it again, logged into and out of Gnome, then into KDE, no pop up, but it also did not regenerate the hardwaredatabase file.  The first time I deleted the hardwaredatabase file it had the creation date of 4/9/12.

More info:
Fedora 16 upgraded from Fedora 14 (upgrade was back in December of 2011, no
problems until latest kernel)
motherboard: ECS GeForce6100SM-M
Chipset: MCP61S
CPU: AMD Athlog 64 X2 5600+
nouveau driver on integrated Geforce6100 GPU
Comment 1 Lloyd Matthews 2012-04-16 12:06:50 EDT
forgot to specify that this is 32 bit install.

also the problem occurs whether in 3.3.0 or 3.3.1 kernel, even though prior to 4/9/12 there was no problem with the 3.3.0 kernel.
Comment 2 Rex Dieter 2012-04-16 13:09:52 EDT
My guess is that the kernel-3.3.x update renamed the devices.

Else, you're probably seeing a race-condition of kmix starting before pulseaudio is fully initialized (ie, you should only every see "Internal Audio...")
Comment 3 Lloyd Matthews 2012-05-07 14:15:06 EDT
I'm still having this problem.  If I log into KDE on a cold boot or reboot, the problem occurs.  If I log into Gnome first, then into KDE, no problem.  If I log into KDE first, then into Gnome and then back into KDE the problem is gone.  Logging into KDE, then out, then back into KDE without Gnome inbetween still gives the problem.  So logging into Gnome always fixes the problem.

I tried removing phonondevicesrc and regenerating it.  This did not help.  I did notice that phonondevicesrc is regenerated identical to the original, and then I get the sound hardware messages.   If I remove it and reboot, then log into Gnome first, then KDE, phonondevicesrc is NOT regenerated.

When the problem occurs, this is what is shown in /var/logs/messages:

May  7 12:15:14 HAL5000 rtkit-daemon[1719]: Successfully made thread 3178 of process 3178 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
May  7 12:15:15 HAL5000 pulseaudio[3178]: module-udev-detect.c: inotify_init1() failed: Too many open files
May  7 12:15:15 HAL5000 pulseaudio[3178]: module.c: Failed to load  module "module-udev-detect" (argument: ""): initialization failed.
May  7 12:15:15 HAL5000 pulseaudio[3178]: main.c: Module load failed.
May  7 12:15:15 HAL5000 pulseaudio[3178]: main.c: Failed to initialize daemon.
May  7 12:15:15 HAL5000 rtkit-daemon[1719]: Successfully made thread 3208 of process 3208 (/usr/bin/pulseaudio) owned by '500' high priority at nice level -11.
May  7 12:15:15 HAL5000 pulseaudio[3208]: module-udev-detect.c: inotify_init1() failed: Too many open files
May  7 12:15:15 HAL5000 pulseaudio[3208]: module.c: Failed to load  module "module-udev-detect" (argument: ""): initialization failed.
May  7 12:15:15 HAL5000 pulseaudio[3208]: main.c: Module load failed.
May  7 12:15:15 HAL5000 pulseaudio[3208]: main.c: Failed to initialize daemon.
May  7 12:15:15 HAL5000 pulseaudio[3184]: main.c: Daemon startup failed.

These messages go on for eleven sets.  I do not get these messages if I log into Gnome first.  I'm out of ideas on this.  For now I just always log into Gnome first, then KDE.

If you want to see the full messages listings for a good outcome and the problem outcome, the are in bug 812052.  That was the first time I filed a bug on this problem when I thought it was a kernel issue.  That bug is closed.
Comment 4 Rex Dieter 2012-05-09 11:41:09 EDT
Your logs clearly indicate pulseaudio is failing to start (for whatever reason), that's likely the main problem here, triaging there.
Comment 5 Lloyd Matthews 2012-05-11 10:34:32 EDT
I tried another experiment.  I logged into root with the KDE environment and did not get the messages.  I then logged out and into my user account in KDE and there were the messages.  Had to log out of KDE and into/ out of Gnome then back into KDE to clear them.  Can it possibly be something to do with the differences between start-pulseaudio-kde and start-pulseaudio-x11?

How can I start PulseAudio during the boot process.  That way it will be running when I log into KDE (save me the additional task of always logging into Gnome first).  I assume that I would want to start it owned by my user, and with the same method as Gnome.  If someone can point to a good reference for this I would appreciate it.

Thank you.
Comment 6 Rex Dieter 2012-05-11 10:40:53 EDT
pulseaudio is intended to run as part of the user session (via /etc/xdg/autostart/...).  running it during the boot process is not recommended:
http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide
Comment 7 Lloyd Matthews 2012-05-16 10:30:25 EDT
Rex, thank you for the link to the documentation, it was very helpful.  After reading why it should not be a boot process I agree and will not set it up that way.

I have found the solution to this problem.  It came from a posting by you a few months back to another individual that had exactly the same problem.  Your recommendation solved the problem for me.  That was to add a file to /etc/sysctl.d that had the line fs.inotify.max_user_watches = 524288.

So, something with the updates around the end of March, early April caused the inotify error.

Rex, thanks again for the help, and I hope documenting it in this bug will help someone else.
Comment 8 Fedora End Of Life 2013-01-16 10:03:16 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora End Of Life 2013-02-13 11:24:26 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.