Bug 813078 - Document use of IRQBALANCE_BANNED_INTERRUPTS and give examples for it and for IRQBALANCE_BANNED_CPUS
Document use of IRQBALANCE_BANNED_INTERRUPTS and give examples for it and for...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: irqbalance (Show other bugs)
6.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Petr Holasek
John Brier
: ManPageChange, Regression
Depends On:
Blocks: 782183 840683 852981 1020633
  Show dependency treegraph
 
Reported: 2012-04-16 16:10 EDT by nayfield
Modified: 2016-10-04 00:15 EDT (History)
9 users (show)

See Also:
Fixed In Version: irqbalance-1.0.4-3
Doc Type: Bug Fix
Doc Text:
The irqbalance(1) man page does not contain documentation for the IRQBALANCE_BANNED_CPUS and IRQBALANCE_BANNED_INTERRUPTS environment variables. The following documentation will be added to this man page in a future release: IRQBALANCE_BANNED_CPUS Provides a mask of cpus which irqbalance should ignore and never assign interrupts to. This is a hex mask without the leading '0x', on systems with large numbers of processors each group of eight hex digits is separated by a comma ','. i.e. `export IRQBALANCE_BANNED_CPUS=fc0` would prevent irqbalance from assigning irqs to the 7th-12th cpus (cpu6-cpu11) or `export IRQBALANCE_BANNED_CPUS=ff000000,00000001` would prevent irqbalance from assigning irqs to the 1st (cpu0) and 57th-64th cpus (cpu56-cpu63). IRQBALANCE_BANNED_INTERRUPTS Space separated list of integer irq's which irqbalance should ignore and never change the affinity of. i.e. export IRQBALANCE_BANNED_INTERRUPTS="205 217 225"
Story Points: ---
Clone Of: 479856
: 852981 1020633 (view as bug list)
Environment:
Last Closed: 2013-02-21 04:49:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nayfield 2012-04-16 16:10:56 EDT
The documentation change from the RHEL5 errata wasn't upstreamed.

Doc regression ;)



+++ This bug was initially created as a clone of Bug #479856 +++

Created attachment 328890 [details]
Proposed patch for irqbalance.1 man page.

Description of problem:
The man page for irqbalance does not include the environment variable IRQBALANCE_BANNED_INTERRUPTS.

Additionally examples for utilizing IRQBALANCE_BANNED_INTERRUPTS and IRQBALANCE_BANNED_CPUS would be helpful

Version-Release number of selected component (if applicable):
irqbalance-0.55-10

--- Additional comment from nhorman@redhat.com on 2009-01-13 12:42:06 EST ---

Fine, although the example isn't complete, its space delimited at every 32 bits so the example should probably show something like:
IRQBALANCE_BANNED_INTERRUPTS="00000000 0000000c"
Just so that people understand how it works for largesmp systems

--- Additional comment from kasmith@redhat.com on 2009-01-15 17:57:13 EST ---

Created attachment 329148 [details]
Better examples of how to set the env vars.

--- Additional comment from errata-xmlrpc@redhat.com on 2009-09-02 05:18:18 EDT ---

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1265.html
Comment 2 RHEL Product and Program Management 2012-05-03 01:18:27 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Martin Prpic 2012-06-01 06:51:44 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The irqbalance(1) man page does not contain documentation for the IRQBALANCE_BANNED_CPUS and IRQBALANCE_BANNED_INTERRUPTS environment variables. The following documentation will be added to this man page in a future release:

    IRQBALANCE_BANNED_CPUS

        Provides a mask of cpus which irqbalance should ignore and never assign interrupts to. This is a hex mask without the leading '0x', on systems with large numbers of processors each group of eight hex digits is sepearated ba a comma ','. i.e. `export IRQBALANCE_BANNED_CPUS=fc0` would prevent irqbalance from assigning irqs to the 7th-12th cpus (cpu6-cpu11) or `export IRQBALANCE_BANNED_CPUS=ff000000,00000001` would prevent irqbalance from assigning irqs to the 1st (cpu0) and 57th-64th cpus (cpu56-cpu63).

    IRQBALANCE_BANNED_INTERRUPTS

        Space seperated list of integer irq's which irqbalance should ignore and never change the affinity of.  i.e.

        export IRQBALANCE_BANNED_INTERRUPTS="205 217 225"
Comment 8 Laura Bailey 2012-08-02 03:37:56 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -2,10 +2,10 @@
 
     IRQBALANCE_BANNED_CPUS
 
-        Provides a mask of cpus which irqbalance should ignore and never assign interrupts to. This is a hex mask without the leading '0x', on systems with large numbers of processors each group of eight hex digits is sepearated ba a comma ','. i.e. `export IRQBALANCE_BANNED_CPUS=fc0` would prevent irqbalance from assigning irqs to the 7th-12th cpus (cpu6-cpu11) or `export IRQBALANCE_BANNED_CPUS=ff000000,00000001` would prevent irqbalance from assigning irqs to the 1st (cpu0) and 57th-64th cpus (cpu56-cpu63).
+        Provides a mask of cpus which irqbalance should ignore and never assign interrupts to. This is a hex mask without the leading '0x', on systems with large numbers of processors each group of eight hex digits is separated by a comma ','. i.e. `export IRQBALANCE_BANNED_CPUS=fc0` would prevent irqbalance from assigning irqs to the 7th-12th cpus (cpu6-cpu11) or `export IRQBALANCE_BANNED_CPUS=ff000000,00000001` would prevent irqbalance from assigning irqs to the 1st (cpu0) and 57th-64th cpus (cpu56-cpu63).
 
     IRQBALANCE_BANNED_INTERRUPTS
 
-        Space seperated list of integer irq's which irqbalance should ignore and never change the affinity of.  i.e.
+        Space separated list of integer irq's which irqbalance should ignore and never change the affinity of.  i.e.
 
         export IRQBALANCE_BANNED_INTERRUPTS="205 217 225"
Comment 11 John Brier 2012-11-13 11:40:27 EST
Note for RHEL 6.3 irqbalance I actually do see the IRQBALANCE_BANNED_CPUS environment variable mentioned, there is just no example:

In irqbalance-0.55-34.el6.x86_64 I see

       IRQBALANCE_BANNED_CPUS
              Provides a mask of cpus which irqbalance should ignore and never assign interrupts to

In irqbalance-1.0.4-3.el6.x86_64.rpm I see 
       IRQBALANCE_BANNED_CPUS
              Provides a mask of cpus which irqbalance should ignore and never
              assign  interrupts  to.  This  is a hex mask without the leading
              ’0x’, on systems with large numbers of processors each group  of
              eight  hex  digits  is  separated  by  a comma ’,’. i.e. ‘export
              IRQBALANCE_BANNED_CPUS=fc0‘  would   prevent   irqbalance   from
              assigning  irqs  to  the  7th-12th  cpus (cpu6-cpu11) or ‘export
              IRQBALANCE_BANNED_CPUS=ff000000,00000001‘ would prevent  irqbal-
              ance  from  assigning  irqs to the 1st (cpu0) and 57th-64th cpus
              (cpu56-cpu63).


as Petr mentioned in comment 9 there is no mention of IRQBALANCE_BANNED_INTERRUPTS env variable

also the misspelled "sepearated" that Laura mentioned in comment 8 is spelled correctly in the Errata release.

Looks good to me.
Comment 13 errata-xmlrpc 2013-02-21 04:49:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0367.html

Note You need to log in before you can comment on or make changes to this bug.