Bug 813110 - Users are getting connection timeouts while creating an application
Users are getting connection timeouts while creating an application
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
: 813155 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 18:59 EDT by Nam Duong
Modified: 2015-05-14 21:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: rhc-0.91.1-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:46:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-04-16 18:59:19 EDT
Description of problem:
I get this feedback a consistently few times a month now:  Users are getting connection timeouts while creating an application.  See a specific example in the forums:
https://www.redhat.com/openshift/community/forums/openshift/getting-several-connection-timeouts-when-creating-a-new-app#comment-19965
---
sas@ubuntu:~/dev/apps$ rhc app create -a test -t diy-0.1 -l opensas@gmail.com -p ***
Creating application: test
Now your new domain name is being propagated worldwide (this might take a minute)...
ssh: connect to host test-opensas.rhcloud.com port 22: Connection timed out
fatal: The remote end hung up unexpectedly
Error in git clone

Cleaning up application
---

The workaround is simple enough:  Retry a couple of times, or increase the timeout to 120s.  

This is not just limited to the rhc client tools - I see this the Web Console UI, Eclipse plugin and most recently the Forge plugin.  Unfortunately, those other interfaces do not have the capability to increase the timeout parameter (yet) and you're left to retry + patience.

Why not just increase the default from 60s to 90s or 120s?

Thanks;
~Nam
Comment 1 Xiaoli Tian 2012-04-17 03:16:30 EDT
Before rhc-0.91.1-1.el6_2.noarch, only have http.open_timeout = 10s, it works in most time, but after http.read_timeout = 10s is added in rhc-0.91.1-1 ,the client will often failed with execution expired if not set timeout to higher value
Comment 2 Rob Millner 2012-04-17 13:25:20 EDT
*** Bug 813155 has been marked as a duplicate of this bug. ***
Comment 3 Rob Millner 2012-04-17 15:53:46 EDT
The read timeout has been increased to 120s and separated out the open and read timeouts in rhc tools commit 56d5368 and 32319e3.
Comment 4 Meng Bo 2012-04-18 22:46:06 EDT
checked on rhc-0.91.3-1, issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.