Bug 813167 - Stopping a rebalance process says "Completed" in the status
Stopping a rebalance process says "Completed" in the status
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
pre-release
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: shishir gowda
shylesh
:
: 815306 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-04-17 02:30 EDT by shylesh
Modified: 2013-12-08 20:31 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:47:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa42
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-04-17 02:30:25 EDT
Description of problem:
stopping a rebalance process and checking the status shows status as "completed"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a distribute volume and fill with some data
2. add a brick and initiate rebalance 
3. while rebalance is happening issue rebalance stop
4. now check the status twice
  
Actual results:
status will be shown as "completed" 

Expected results:
status is supposed to be "stopped"

Additional info:
Comment 1 Anand Avati 2012-04-25 07:06:18 EDT
CHANGE: http://review.gluster.com/3165 (glusterd/rebalance: Remove state dependency on rpc event) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 2 shishir gowda 2012-04-25 07:35:18 EDT
*** Bug 815306 has been marked as a duplicate of this bug. ***
Comment 3 shylesh 2012-05-23 09:36:15 EDT
Now it says stopped

Note You need to log in before you can comment on or make changes to this bug.