This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 815306 - rebalance status after rebalance stop says "completed"
rebalance status after rebalance stop says "completed"
Status: CLOSED DUPLICATE of bug 813167
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 06:26 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 07:35:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2012-04-23 06:26:52 EDT
Description of problem:
Was running rebalance (rebalance start). Now rebalance status says the rebalance is "in progress". Now I stop the rebalance using 'rebalance stop'. After rebalance stop if I run the 'rebalance status' I get rebalance completed message.

Version-Release number of selected component (if applicable):
glusterfs-3.3.0qa37

How reproducible:
Consistent

Steps to Reproduce:
1. Create and start a distribute volume. (282 dist-rep for ex)
2. Now create some data on the mountpoint. (may be kernel untar)
3. run 'rebalance <volname> start' - You should get "rebalance started successfully" message.
4. Run 'rebalance <volname> status' -- Says "In Progress"
5. Run 'rebalance <volname> stop' -- You should get stopped message.
6. Now Run 'rebalance <volname> status' 
  
Actual results:
[root@gqac014 teragen-dir4]# gluster v rebalance hosdu start
Starting rebalance on volume hosdu has been successful
[root@gqac014 teragen-dir4]# gluster v rebalance hosdu status
                                    Node Rebalanced-files          size       scanned      failures         status
                               ---------      -----------   -----------   -----------   -----------   ------------
                               localhost                0            0            0            0    in progress
      gqac015.sbu.lab.eng.bos.redhat.com                0            0            0            0    in progress
      gqac016.sbu.lab.eng.bos.redhat.com                0            0            0            0    in progress
      gqac017.sbu.lab.eng.bos.redhat.com                0            0            0            0    in progress

[root@gqac014 teragen-dir4]# gluster v rebalance hosdu status
                                    Node Rebalanced-files          size       scanned      failures         status
                               ---------      -----------   -----------   -----------   -----------   ------------
                               localhost                0            0          622            0    in progress
      gqac016.sbu.lab.eng.bos.redhat.com                0            0          622            0    in progress
      gqac015.sbu.lab.eng.bos.redhat.com                0            0          622            0    in progress
      gqac017.sbu.lab.eng.bos.redhat.com                0            0          622            0    in progress

[root@gqac014 teragen-dir4]# gluster v rebalance hosdu stop
                                    Node Rebalanced-files          size       scanned      failures         status
                               ---------      -----------   -----------   -----------   -----------   ------------
                               localhost                0            0         1900            0        stopped
      gqac015.sbu.lab.eng.bos.redhat.com                0            0         1900            0        stopped
      gqac017.sbu.lab.eng.bos.redhat.com                0            0         1900            0        stopped
      gqac016.sbu.lab.eng.bos.redhat.com                0            0         1900            0        stopped
Stopped rebalance process on volume hosdu 

[root@gqac014 teragen-dir4]# gluster v rebalance hosdu status
                                    Node Rebalanced-files          size       scanned      failures         status
                               ---------      -----------   -----------   -----------   -----------   ------------
                               localhost                0            0         1900            0      completed
      gqac015.sbu.lab.eng.bos.redhat.com                0            0         1900            0      completed
      gqac016.sbu.lab.eng.bos.redhat.com                0            0         1900            0      completed
      gqac017.sbu.lab.eng.bos.redhat.com                0            0         1900            0      completed

[root@gqac014 teragen-dir4]# gluster v rebalance hosdu status
                                    Node Rebalanced-files          size       scanned      failures         status
                               ---------      -----------   -----------   -----------   -----------   ------------
                               localhost                0            0         1900            0      completed
      gqac015.sbu.lab.eng.bos.redhat.com                0            0         1900            0      completed
      gqac016.sbu.lab.eng.bos.redhat.com                0            0         1900            0      completed
      gqac017.sbu.lab.eng.bos.redhat.com                0            0         1900            0      completed


Expected results:
Rebalance status before starting rebalance or after stopping it should say the "rebalance is not started on the volume" or something similar.
Comment 1 Amar Tumballi 2012-04-23 07:23:24 EDT
same as bug 807126
Comment 2 shishir gowda 2012-04-25 07:35:17 EDT

*** This bug has been marked as a duplicate of bug 813167 ***

Note You need to log in before you can comment on or make changes to this bug.