Bug 813280 - Sheets cannot be moved in calc
Sheets cannot be moved in calc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
: Reopened
: 813328 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 07:52 EDT by antonio montagnani
Modified: 2012-05-03 18:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-13.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 18:53:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy of screen during copy/move of sheets (137.06 KB, image/png)
2012-04-17 09:58 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2012-04-17 07:52:14 EDT
Description of problem:
Sheets cannot be moved/copied unless you change their name

Version-Release number of selected component (if applicable):
3.4.5.2-12

How reproducible:
always

Steps to Reproduce:
1.have two or more sheets in a file
2.move 
3.
  
Actual results:
they cannot be moved/copied unless you change the name

Expected results:
they should be moved/copied

Additional info:
Comment 1 Eike Rathke 2012-04-17 08:25:43 EDT
Can't reproduce using 3.4.5.2-10.fc16 and changes in -11 and -12 indicate nothing that touched Calc code that could be responsible for this.

Where did you obtain your -12 package?
Comment 2 antonio montagnani 2012-04-17 08:35:00 EDT
directly from updates-testing.

Test Not done on a fresh file, I will test immediately
Comment 3 antonio montagnani 2012-04-17 08:36:55 EDT
forgot to sat that in the Copy/move sheet window I get a yellow warning that name is already used!!! (that should not be a problem).

Same behaviour on a fresh file
Comment 4 Eike Rathke 2012-04-17 09:30:40 EDT
Still can't reproduce using -12 from updates-testing. Both, drag&drop sheet tabs and using the dialog to move/copy sheets, work.
Comment 5 antonio montagnani 2012-04-17 09:58:37 EDT
Created attachment 578040 [details]
Copy of screen during copy/move of sheets

downgraded to standard Libreoffice.....i.e. 10 release
Comment 6 Eike Rathke 2012-04-17 11:38:36 EDT
*** Bug 813328 has been marked as a duplicate of this bug. ***
Comment 7 Eike Rathke 2012-04-17 11:41:08 EDT
Additional comment from bug 813328:

"it seems that happens when you have two files open at the same time..."

And yes, then I can reproduce.
Comment 9 Eike Rathke 2012-04-18 09:17:12 EDT
Upstream 3-5 http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=05579aa8b26f593af650d8434ff1c25c0a2702a6

Added patches to f16 and f17.
Comment 10 antonio montagnani 2012-04-19 16:20:40 EDT
I downloaded updated packages from koij but at least libreoffice-opensymbol-fonts is missing
Comment 11 Caolan McNamara 2012-04-19 16:33:13 EDT
the symbols package is "noarch" so should find it in the "noarch" dir at the same level as the x86_64 and i686 dirs
Comment 12 antonio montagnani 2012-04-19 16:35:57 EDT
found it, but I can't resolve dependecies withthese warnings
hunspell-lt necessario a libreoffice-langpack-lt-1:3.4.5.2-13.fc16.i686
hyphen-lt necessario a libreoffice-langpack-lt-1:3.4.5.2-13.fc16.i686

willing to help
Comment 13 Caolan McNamara 2012-04-19 16:40:35 EDT
yum -y update hunspell-lt hyphen-lt

or wait a day or so and I'll push into testing and a message will be automatically appended here as to how to upgrade to it
Comment 14 antonio montagnani 2012-04-20 01:58:58 EDT
it works here. tnx a lot
Comment 15 antonio montagnani 2012-04-20 03:39:04 EDT
I confirm, on a production machine with large numberof files and sheets it works fine
Comment 16 Fedora Update System 2012-04-24 10:06:11 EDT
libreoffice-3.4.5.2-13.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.5.2-13.fc16
Comment 17 Fedora Update System 2012-04-25 23:32:21 EDT
Package libreoffice-3.4.5.2-13.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.5.2-13.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6631/libreoffice-3.4.5.2-13.fc16
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-05-03 18:53:58 EDT
libreoffice-3.4.5.2-13.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.