Bug 813289 - [abrt] bash-4.2.24-1.fc16: xmalloc: Process /bin/bash was killed by signal 11 (SIGSEGV)
[abrt] bash-4.2.24-1.fc16: xmalloc: Process /bin/bash was killed by signal 11...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
abrt_hash:9a758a3e649c93266de873d9512...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 07:59 EDT by Jakub Filak
Modified: 2016-11-30 19:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 01:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (139.33 KB, text/plain)
2012-04-17 07:59 EDT, Jakub Filak
no flags Details
File: backtrace (388.43 KB, text/plain)
2012-04-17 07:59 EDT, Jakub Filak
no flags Details

  None (edit)
Description Jakub Filak 2012-04-17 07:59:01 EDT
libreport version: 2.0.10.7.ga379.dirty
abrt_version:   2.0.10.19.g64b2f.dirty
backtrace_rating: 4
cmdline:        /bin/bash
comment:        I was experimenting with bash history. I wanted to reload .bash_profile in all of my terminals. I selected a long time unused terminal then I pushed Shitf+Ins and bash crashed.
crash_function: xmalloc
executable:     /bin/bash
kernel:         3.3.1-5.fc16.x86_64
pid:            2359
pwd:            /home/jfilak/git/libreport/src/cli
remote_result:  726891
time:           Tue 17 Apr 2012 01:40:51 PM CEST
uid:            18601
username:       jfilak
var_log_messages: Apr 17 13:40:52 dhcp-25-122 abrt[10874]: Saved core dump of pid 2359 (/bin/bash) to /var/spool/abrt/ccpp-2012-04-17-13:40:51-2359 (15527936 bytes)

backtrace:      Text file, 397753 bytes
core_backtrace: Text file, 142679 bytes

.bash_profile:
:# .bash_profile
:
:# Get the aliases and functions
:if [ -f ~/.bashrc ]; then
:	. ~/.bashrc
:fi
:
:# User specific environment and startup programs
:
:PATH=$PATH:$HOME/.local/bin:$HOME/bin
:
:set -o vi
:shopt -s cdspell
:shopt -s dirspell
:shopt -s histappend
:#export PROMPT_COMMAND="history -a;history -n;$PROMPT_COMMAND"
:export PROMPT_COMMAND="history -a;$PROMPT_COMMAND"
:export HISTSIZE=9999
:export HISTFILESIZE=99999
:export HISTCONTROL="erasedups:ignoreboth"
:export HISTIGNORE="pwd:ls:ls -l:ls -la:ls -lart:ls -al:ls -a:ll:cd:cd \-:cd /:cd ..:cd ../:git pull:git pull --rebase:git status:git diff"
:
:export PATH

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/jfilak/1

dso_list:
:/lib64/libdl-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1333366950
:/lib64/libtinfo.so.5.9 ncurses-libs-5.9-2.20110716.fc16.x86_64 (Fedora Project) 1333363334
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1333366950
:/bin/bash bash-4.2.24-1.fc16.x86_64 (Fedora Project) 1333373281
:/usr/lib64/gconv/gconv-modules.cache glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1333366950
:/lib64/libc-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1333366950
:/lib64/libgcc_s-4.6.3-20120306.so.1 libgcc-4.6.3-2.fc16.x86_64 (Fedora Project) 1333366936
:/usr/lib/locale/locale-archive glibc-common-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1333366942
:/lib64/ld-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1333366950

environ:
:LANGUAGE=
:KDE_MULTIHEAD=false
:KDE_SESSION_VERSION=4
:KONSOLE_DBUS_SERVICE=:1.43
:LOGNAME=jfilak
:WINDOWPATH=2
:KDE_IS_PRELINKED=1
:XDG_VTNR=1
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/jfilak/.gtkrc-2.0:/home/jfilak/.gtkrc-2.0-kde4:/home/jfilak/.kde/share/config/gtkrc-2.0
:KDE_FULL_SESSION=true
:CCACHE_HASHDIR=
:SHLVL=3
:SSH_ASKPASS=/usr/bin/ksshaskpass
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-TYXRraBHMA,guid=d6ae3cbb3c5136e28c4a292700000027
:PATH=/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jfilak/.local/bin:/home/jfilak/bin
:USER=jfilak
:LANG=en_US.UTF-8
:CVS_RSH=ssh
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/jfilak/.gtkrc:/home/jfilak/.kde/share/config/gtkrc
:MAIL=/var/spool/mail/jfilak
:WINDOWID=58720329
:XDG_SEAT=seat0
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:DISPLAY=:0
:PWD=/home/jfilak/git/libreport/src/report-newt
:XDG_SESSION_ID=1
:'PROMPT_COMMAND=history -a;history -n;'
:XCURSOR_THEME=default
:GS_LIB=
:COLORFGBG=0;15
:XAUTHORITY=/tmp/kde-jfilakqH4oHj/xauth-18601-_0
:XDG_RUNTIME_DIR=/run/user/jfilak
:HISTCONTROL=erasedups:ignoreboth
:HISTSIZE=9999
:HOSTNAME=dhcp-25-122.brq.redhat.com
:KDE_SESSION_UID=18601
:SSH_AGENT_PID=1694
:HISTFILESIZE=999999
:XDG_SESSION_COOKIE=37750266f53cf39a2a93b07c0000001f-1334557737.949083-1097022896
:XDG_MENU_PREFIX=kde4-
:TERM=xterm
:PROFILEHOME=
:'HISTIGNORE=pwd:ls:ls -l:ls -la:ls -lart:ls -al:ls -a:ll:cd:cd \\-:cd /:cd ..:cd ../:git pull:git pull --rebase:git status:git diff'
:QT_PLUGIN_PATH=/home/jfilak/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1835,unix/unix:/tmp/.ICE-unix/1835
:SSH_AUTH_SOCK=/tmp/ssh-GgrEpXBQ1693/agent.1693
:KDEDIRS=/usr
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:EDITOR=vim
:KONSOLE_DBUS_SESSION=/Sessions/3
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SHELL_SESSION_ID=44b3ed5a87ea4000a6287d6c4d210af2
:HOME=/home/jfilak
:SHELL=/bin/bash

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29859                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29859                29859                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

maps:
:00400000-004da000 r-xp 00000000 fd:01 2097214                            /bin/bash
:006d9000-006da000 r--p 000d9000 fd:01 2097214                            /bin/bash
:006da000-006e3000 rw-p 000da000 fd:01 2097214                            /bin/bash
:006e3000-006e9000 rw-p 00000000 00:00 0 
:008e2000-008eb000 rw-p 000e2000 fd:01 2097214                            /bin/bash
:015a9000-01c40000 rw-p 00000000 00:00 0                                  [heap]
:31f4e00000-31f4e22000 r-xp 00000000 fd:01 3154764                        /lib64/ld-2.14.90.so
:31f5021000-31f5022000 r--p 00021000 fd:01 3154764                        /lib64/ld-2.14.90.so
:31f5022000-31f5023000 rw-p 00022000 fd:01 3154764                        /lib64/ld-2.14.90.so
:31f5023000-31f5024000 rw-p 00000000 00:00 0 
:31f5600000-31f57ad000 r-xp 00000000 fd:01 3154765                        /lib64/libc-2.14.90.so
:31f57ad000-31f59ad000 ---p 001ad000 fd:01 3154765                        /lib64/libc-2.14.90.so
:31f59ad000-31f59b1000 r--p 001ad000 fd:01 3154765                        /lib64/libc-2.14.90.so
:31f59b1000-31f59b3000 rw-p 001b1000 fd:01 3154765                        /lib64/libc-2.14.90.so
:31f59b3000-31f59b8000 rw-p 00000000 00:00 0 
:31f5a00000-31f5a02000 r-xp 00000000 fd:01 3154767                        /lib64/libdl-2.14.90.so
:31f5a02000-31f5c02000 ---p 00002000 fd:01 3154767                        /lib64/libdl-2.14.90.so
:31f5c02000-31f5c03000 r--p 00002000 fd:01 3154767                        /lib64/libdl-2.14.90.so
:31f5c03000-31f5c04000 rw-p 00003000 fd:01 3154767                        /lib64/libdl-2.14.90.so
:31f6200000-31f6215000 r-xp 00000000 fd:01 3154769                        /lib64/libgcc_s-4.6.3-20120306.so.1
:31f6215000-31f6414000 ---p 00015000 fd:01 3154769                        /lib64/libgcc_s-4.6.3-20120306.so.1
:31f6414000-31f6415000 rw-p 00014000 fd:01 3154769                        /lib64/libgcc_s-4.6.3-20120306.so.1
:3ccaa00000-3ccaa23000 r-xp 00000000 fd:01 3146249                        /lib64/libtinfo.so.5.9
:3ccaa23000-3ccac22000 ---p 00023000 fd:01 3146249                        /lib64/libtinfo.so.5.9
:3ccac22000-3ccac26000 r--p 00022000 fd:01 3146249                        /lib64/libtinfo.so.5.9
:3ccac26000-3ccac27000 rw-p 00026000 fd:01 3146249                        /lib64/libtinfo.so.5.9
:7f023b457000-7f023b463000 r-xp 00000000 fd:01 3145759                    /lib64/libnss_files-2.14.90.so
:7f023b463000-7f023b662000 ---p 0000c000 fd:01 3145759                    /lib64/libnss_files-2.14.90.so
:7f023b662000-7f023b663000 r--p 0000b000 fd:01 3145759                    /lib64/libnss_files-2.14.90.so
:7f023b663000-7f023b664000 rw-p 0000c000 fd:01 3145759                    /lib64/libnss_files-2.14.90.so
:7f023b664000-7f0241a87000 r--p 00000000 fd:01 1327488                    /usr/lib/locale/locale-archive
:7f0241a87000-7f0241a8b000 rw-p 00000000 00:00 0 
:7f0241a9e000-7f0241aa0000 rw-p 00000000 00:00 0 
:7f0241aa0000-7f0241aa7000 r--s 00000000 fd:01 1313739                    /usr/lib64/gconv/gconv-modules.cache
:7f0241aa7000-7f0241aa8000 rw-p 00000000 00:00 0 
:7fff376f4000-7fff37ef3000 rw-p 00000000 00:00 0                          [stack]
:7fff37f82000-7fff37f83000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

open_fds:
:0:/dev/pts/3
:pos:	0
:flags:	0100002
:1:/dev/pts/3
:pos:	0
:flags:	0100002
:2:/dev/pts/3
:pos:	0
:flags:	0100002

smolt_data:
:
:
:General
:=================================
:UUID: dba499aa-a7d8-4ff7-873a-83a9483d8b02
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5054.06
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 540  @ 2.53GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2534
:System Memory: 3753
:System Swap: 5791
:Vendor: LENOVO
:System: 2537CT4 ThinkPad T410
:Form factor: Notebook
:Kernel: 3.3.1-5.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4480:59426:6058:8499) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(4480:57904:6058:8500) pci, None, BASE, Memory Stick Host Controller
:(4480:59442:6058:8502) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(32902:11362:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:6058:8595) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:6058:8598) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:6058:8598) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:6058:8551) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15151:6058:8552) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15111:6058:8550) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:6058:8592) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:4330:6058:8531) pci, e1000e, ETHERNET, 82577LM Gigabit Network Connection
:(32902:9288:6058:8549) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:6058:8543) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:16952:32902:4369) pci, None, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:70:6058:8538) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15178:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:6058:8542) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_dhcp2120-lv_root / ext4 4096 4096 13081819 8525275 7869915 3276800 2926846 2926846
:/dev/mapper/luks-0959131c-e535-4b4c-9224-80f4842bb628 /home ext4 4096 4096 63348345 53229176 50058079 15859712 15837721 15837721
:
Comment 1 Jakub Filak 2012-04-17 07:59:08 EDT
Created attachment 578011 [details]
File: core_backtrace
Comment 2 Jakub Filak 2012-04-17 07:59:12 EDT
Created attachment 578012 [details]
File: backtrace
Comment 3 Michał Bień 2012-05-05 06:16:36 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 812535 ***
Comment 4 Roman Rakus 2012-05-21 07:25:03 EDT
I don't think it's duplicate. Michał Bień why do you think it's a duplicate of bug #812535?
Comment 5 Kamil Dudka 2012-05-21 08:51:41 EDT
Looks like an infinite recursion in the embedded readline library.  Why do not we link bash against the readline library installed on the system?
Comment 6 Fedora Update System 2012-07-24 04:46:39 EDT
bash-4.2.37-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/bash-4.2.37-2.fc17
Comment 7 Fedora Update System 2012-07-24 05:31:34 EDT
bash-4.2.37-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/bash-4.2.37-1.fc16
Comment 8 Fedora Update System 2012-07-24 19:26:16 EDT
Package bash-4.2.37-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bash-4.2.37-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11026/bash-4.2.37-1.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-07-30 01:03:12 EDT
bash-4.2.37-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-01-23 11:22:25 EST
bash-4.2.37-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.