Bug 813336 - [RFE] Change Filtering Options to a Dialog
[RFE] Change Filtering Options to a Dialog
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-04-17 10:17 EDT by Matt Reid
Modified: 2013-01-07 22:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:51:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Changes to the new filter pop up dialog (64.24 KB, image/png)
2012-07-10 12:03 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Matt Reid 2012-04-17 10:17:44 EDT
Description of problem:
The current method of filtering in the All Available Subscriptions tab could be improved.

As is, the All Available Subscriptions tab is cramped, expanding the possible filters makes it almost impossible to see anything at the default window size. I would like to propose pulling filter options out and putting them in a dialog. We can show how many (if any) filters are applied, and if they need to see which ones those are, they can open the dialog. Ideally, we could pull their subscriptions down in the background (defaulting to today's date, which they can alter in the Filter Options dialog), and not make them click update before having the table populated by anything. If they went to the tab before we had any information, or there was a connectivity issue at the time, there could still be an update button to pull down fresh data. Users at the focus group were initially confused what to do when arriving at this tab and seeing an empty table, and after figuring out how to get their data, they tended to click update after messing with the filter options.

In the Filter Options dialog, we have more flexibility to add filters if necessary. We may want to consider adding a "Match my SLA preference" type, other than that, I'm not sure if we need anything else.

By "Match my system" are we just ensuring that any subscriptions match their arch? If so, shouldn't we just say "match my hardware" or "match my system's architecture"? Match my system could be sockets, arch, installed products, etc. "System" seems more ambiguous.

Wireframe showing what I described above can be seen here -
https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Filtering.png

Version-Release number of selected component (if applicable):
subscription-manager-1.0.0-1.git.9.fc486b4

Additional info:

Current implementation of the All Available Subscriptions Tab can be seen here -

Filter options collapsed:
https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Sub%20Man%20Filter.png

Filter options expanded:
https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Sub%20Man%20Filter2.png
Comment 1 RHEL Product and Program Management 2012-04-20 10:07:33 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Matt Reid 2012-07-03 11:48:21 EDT
After talking with Alex, I've tweaked the proposed design to include the date picker outside of the dialog. To ensure we have enough room, I've removed the word "on", reduced the extra width on the date picker, and dropped "Options" from the new Filter button name. The date picker no longer shows in the proposed filter dialog.

This should leave us enough room for everything, even in different languages. 

By reducing the amount of space we needed for filtering, we should increase the available subscriptions table height by the same amount.

Same location:
https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Filtering.png
Comment 5 Alex Wood 2012-07-09 14:41:21 EDT
commit a6b6fc8afc39fa2794cfb29dbc5745d5b7c40249
Merge: a2ba65c d4040bd
Author: Michael Stead <michael.stead@gmail.com>
Date:   Mon Jul 9 11:16:16 2012 -0700

    Merge pull request #126 from candlepin/awood/813336
    
    813336: Change filtering options to a dialog
Comment 6 Sharath Dwaral 2012-07-10 12:03:30 EDT
Created attachment 597385 [details]
Changes to the new filter pop up dialog

version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-firstboot-1.0.8-1.git.33.4e44fc1.el5
subscription-manager-1.0.8-1.git.33.4e44fc1.el5
subscription-manager-gui-1.0.8-1.git.33.4e44fc1.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.8-1.git.33.4e44fc1.el5
python-rhsm-1.0.3-1.git.0.583d26c.el5


Regressions:

- Would like the filter pop up to hold the changes (filter options) in a particular session. As of now, if any changes are made within the pop-up dialog, closed and reopened, it defaults to 2 filters. This was the old behavior and was suggested in the comment above 

Proposed changes:

- Would like to see a check box that greys out the text area when unchecked.

- When a string is typed in the textarea and the checkbox is unchecked, it should hold/save the text within the text area so as to prevent the user from typing the filter string over and over again.
Comment 7 Alex Wood 2012-07-10 15:32:15 EDT
Fix for regression:

commit 20dd0a565280887d2d00a4cc5610947e2f36b2e4
Refs: <origin/awood/813336-2>, awood/813336-2, subscription-manager-1.0.9-1-1-g20dd0a5
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Sat Jul 7 22:27:28 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Tue Jul 10 15:06:55 2012 -0400

    Fix bug where filter options were not persisted when the dialog was reopened.

I'm waiting for mreid's opinion before implementing the proposed changes.
Comment 8 Matt Reid 2012-07-10 15:46:20 EDT
(In reply to comment #7)
> Fix for regression:
> 
> commit 20dd0a565280887d2d00a4cc5610947e2f36b2e4
> Refs: <origin/awood/813336-2>, awood/813336-2,
> subscription-manager-1.0.9-1-1-g20dd0a5
> Author:     Alex Wood <awood@redhat.com>
> AuthorDate: Sat Jul 7 22:27:28 2012 -0400
> Commit:     Alex Wood <awood@redhat.com>
> CommitDate: Tue Jul 10 15:06:55 2012 -0400
> 
>     Fix bug where filter options were not persisted when the dialog was
> reopened.
> 
> I'm waiting for mreid's opinion before implementing the proposed changes.

Now that their filters persist across a session, I don't think we need need to implement the proposed changes. The text will be there until they close out of subscription manager, so complicating things with locks doesn't seem necessary. 

I'd still like to see the date field a bit smaller, as we have room for 14 characters when they'll only ever need to have 10 (4 for year, 2 for days, 2 for months, and 2 separators) in there. It'd be nice if we could collapse that a bit to free up a little more room for translations having potentially longer strings. Sounds like that may not be as simple a change as one would hope though.
Comment 10 Sharath Dwaral 2012-07-18 10:24:31 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-1.0.9-1.git.22.35b5155.el5
subscription-manager-gui-1.0.9-1.git.22.35b5155.el5
subscription-manager-1.0.9-1.git.22.35b5155.el5
subscription-manager-firstboot-1.0.9-1.git.22.35b5155.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5

Verification:

1. The state of checkbox and the text are held within a session.

2. Msg "Press update to search for subscriptions" does not change as soon as "Filters" button is clicked.

Moving to VERIFIED state
Comment 11 J.C. Molet 2012-08-07 09:28:52 EDT
Created Bug 846331 for additional items.
Comment 13 Libor Miksik 2012-10-25 08:30:40 EDT
Thank you for submitting this issue for consideration. Red Hat Enterprise Linux 5 has reached the end of Production 1 Phase of its Life Cycle.  Red Hat does not plan to incorporate the suggested capability in a future Red Hat Enterprise Linux 5 minor release. If you would like Red  Hat to re-consider this feature request and the requested functionality is not currently in Red Hat Enterprise Linux 6, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.
Comment 15 errata-xmlrpc 2013-01-07 22:51:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.