Bug 846331 - [RFE] Improve filter options
[RFE] Improve filter options
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: Bryan Kearney
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-08-07 09:27 EDT by J.C. Molet
Modified: 2014-06-17 20:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:02:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tool-tips of all filter options (290.25 KB, image/png)
2013-10-17 14:15 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description J.C. Molet 2012-08-07 09:27:56 EDT
This is a continuation of Bug 813336

>In the Filter Options dialog, we have more flexibility to add filters if >necessary. We may want to consider adding a "Match my SLA preference" type, >other than that, I'm not sure if we need anything else.
>
>By "Match my system" are we just ensuring that any subscriptions match their >arch? If so, shouldn't we just say "match my hardware" or "match my system's >architecture"? Match my system could be sockets, arch, installed products, etc. >"System" seems more ambiguous.
>
>Wireframe showing what I described above can be seen here -
https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Filtering.png

These items were not completed in the original bug.

For the "Match my system", since it matches on several criteria in addition to arch, perhaps we can put a tooltip explaining what the filter does?
Comment 1 RHEL Product and Program Management 2012-08-07 09:28:46 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Tom Lavigne 2012-09-07 11:25:17 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 4 Bryan Kearney 2012-09-10 12:42:48 EDT
We should be able to get this into 6.4.
Comment 5 Tom Lavigne 2012-09-18 11:51:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Since Red Hat is unable to address this request at this time, 
it has been proposed for the next release of Red Hat Enterprise 
Linux.
Comment 8 Sharath Dwaral 2013-10-17 14:15:06 EDT
Created attachment 813490 [details]
tool-tips of all filter options

Version:

# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription-manager: 1.10.4-1.el7
python-rhsm: 1.10.3-1.el7

See attachment which shows tool tip for all filter options.

VERIFIED
Comment 9 Ludek Smid 2014-06-13 06:02:16 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.