Bug 813666 - Cannot launch X with QXL - it crashes
Cannot launch X with QXL - it crashes
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 03:28 EDT by Yaniv Kaul
Modified: 2013-07-03 22:42 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 14:43:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-04-18 03:28:32 EDT
Description of problem:
With official F17/x64 beta (live desktop), X always crashes after it loads with QXL.
My QEMU command line:

./x86_64-softmmu/qemu-system-x86_64 -spice port=6902,disable-ticketing,jpeg-wan-compression=always,zlib-glz-wan-compression=always,playback-compression=on -k en-us -name F17_Beta -boot d -drive file=~/f17a.qcow2,if=virtio,cache=writethrough,media=disk,format=qcow2 -drive file=~/Downloads/Fedora-17-Beta-x86_64-Live-Desktop.iso,if=scsi,media=cdrom -soundhw hda -m 1024 -cpu core2duo,+x2apic -smp 2 -balloon none -monitor stdio --parallel none -vga qxl -uuid 93226831-ade7-47ea-be28-5e1926d0b7a7

Version-Release number of selected component (if applicable):
qemu-kvm: 24853eece248d4a58d705c2ddf8818647b11b1e9
spice-gtk: ff7994ca59f9afffb028b7380b3deb587d84db0e
kvm module: from F16 - qemu-kvm-0.15.1-4.fc16.x86_64
xorg-x11-drv-qxl-0.0.22-0.fc17.x86_64

How reproducible:
Always - but I'm pretty sure this did NOT happen in F17 beta-RC3 or before that (there were crashes, but not all the time)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2012-04-18 03:30:41 EDT
Will try to extract Xorg.0.log from the VM, but it is full with errors (reported earlier to Alon Levy over IRC) with cache issues of the driver. Not sure they are related.
Comment 2 Yaniv Kaul 2012-04-18 04:09:41 EDT
Also happens with qemu only (git hash 6e7a7f3d9bc2031b4c93c05400b18775ba1b1f55).
Comment 3 Yaniv Kaul 2012-04-18 04:17:45 EDT
Clean install from beta live CD worked, closing the BZ for the time being.
Comment 4 Yaniv Kaul 2012-04-18 09:12:29 EDT
(In reply to comment #3)
> Clean install from beta live CD worked, closing the BZ for the time being.

And re-opening again. After installation of the live CD to disk and boot from disk - I'm back into this situation.
Might be related to https://bugzilla.redhat.com/show_bug.cgi?id=813683.
Comment 5 Alon Levy 2012-04-23 05:11:22 EDT
Thanks for the bug report, can you supply a stacktrace of the crashing X process in the vm?

Thanks,
Alon

Note You need to log in before you can comment on or make changes to this bug.