Bug 813834 - html5 video streams: not streamed as video
html5 video streams: not streamed as video
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.2
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
:
Depends On:
Blocks: 809208
  Show dependency treegraph
 
Reported: 2012-04-18 10:41 EDT by Yonit Halperin
Modified: 2014-06-18 14:32 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-18 14:32:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yonit Halperin 2012-04-18 10:41:23 EDT
Description of problem:
Windows7 guest
Played html5 youtube on Firefox 10.0.1
The movie frames are not classified by spice as video, i.e., they are not mjpeg compressed. The playback is bad as the connection is more limited.

The cause:
spice-server classifies as video streams only drawing commands that their destination surface is the primary one. However, the html5 playback is drawn onto an offscreen surface and is then copied to the primary surface.
We can extend spice to support off-screen surfaces streams, but in order to do that we need to change the inter-surface dependency logic in spice-server.
Comment 3 David Blechter 2012-10-10 11:18:09 EDT
the fix is not up-stream yet, and as the result - out of time for 6.4 -> moving to 6.5
Comment 4 Bill Sanford 2012-11-02 12:04:28 EDT
I am testing RHEV-M si20 with a RHEL 6.3 host and a Windows 7x86_64 guest. I added the 3.1-7 tools ISO and upgraded the QXL driver to qxl-win-0.1-17 (Signed driver from WHQL).

I am seeing glitching with the HTML5 stream in IE9. The jumps are relatively small but very frequent.
Comment 5 Vimal Patel 2012-11-02 13:35:45 EDT
I am also seeing the issue of HTML5 strem skipping, in full screen the quality is very bad on a Win 7 32bit guest.

*Testing qxl-win-0.1.17 (updated from the 3.1.7 tools ISO) on RHEVM si20 with a Win 7 32 bit guest & RHEL 6.3 host.
Comment 7 RHEL Product and Program Management 2013-10-14 01:02:31 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 Bill Sanford 2014-06-09 09:45:14 EDT
I am not sure why this bug was created instead of updating https://bugzilla.redhat.com/show_bug.cgi?id=809208.

I am installing some RHEV-M instances this week and will retest.
Comment 11 David Blechter 2014-06-09 13:22:36 EDT
low priority, but keep it for 6.6 for now
Comment 12 Marc-Andre Lureau 2014-06-18 14:32:43 EDT
it is correctly streamed as video with rhevm 3.4, both with win7 and rhel6 guests, using firefox html5. closing for now

Note You need to log in before you can comment on or make changes to this bug.