This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 814210 - Windows Live XMPP: connection error
Windows Live XMPP: connection error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: telepathy-gabble (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 834042 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 07:38 EDT by Pedro Francisco
Modified: 2012-06-30 17:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-30 17:49:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 51033 None None None 2012-06-19 09:17:14 EDT

  None (edit)
Description Pedro Francisco 2012-04-19 07:38:54 EDT
Description of problem:
can't connect to Windows Live XMPP.

Should be related to «XMPP: Upcoming Breaking Change to Messenger XMPP Service» in http://social.msdn.microsoft.com/Forums/en-US/messengerconnect/thread/5a0ca19f-46d5-4c23-9921-8b032d562c2e .

Citation: "Starting with the March 2012 release, all XMPP apps connecting to xmpp.messenger.live.com must handle the defined stream error condition "see-other-host" "
[credits to http://blogs.gnome.org/xclaesse/2011/12/23/connect-msn-with-xmpp-on-ubuntu-oneiric-11-10/ 's comment by "Tom" which pointed me the server behaviour change]

Version-Release number of selected component (if applicable):
telepathy-gabble-0.16.0-1.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. create account *using Gnome's Online Accounts*
2. enable chat on created account (on by default)
3. open Empathy, wait for it to attempt to connect

Actual results:
"Connection error" message; logs on "Additional info".

Expected results:
Connection successful, loads contacts.

Additional info:
log in http://pastebin.com/VpBZpg9H (expires ~May 18)



Workaround to use Windows Live [for anyone else reading and wanting to use Windows Live]:
use Pidgin or use Empathy to add the account without using "online-accounts"; such will use libpurple with old Windows Live protocol which works.
Comment 1 Pedro Francisco 2012-04-19 15:09:44 EDT
Will discuss it further in https://bugs.freedesktop.org/show_bug.cgi?id=45915 . 

Error occurs 95% of the times, I was able to connect three times now without understanding what changed.
Comment 2 Pedro Francisco 2012-06-19 09:17:14 EDT
Bug above is another issue. Bug added on "External Trackers" is correct one.
Comment 3 Brian Pepple 2012-06-20 21:31:27 EDT
*** Bug 834042 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-06-20 21:34:02 EDT
telepathy-gabble-0.16.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/telepathy-gabble-0.16.1-1.fc17
Comment 5 Fedora Update System 2012-06-22 04:31:12 EDT
Package telepathy-gabble-0.16.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing telepathy-gabble-0.16.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9773/telepathy-gabble-0.16.1-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-06-30 17:49:55 EDT
telepathy-gabble-0.16.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.